Galaxy S9+ ‘star2lte’ /e/OS ‘Q’ dev AOSP Android 10

The /e/ documentation Install /e/ on a Samsung Galaxy S9+ - “star2lte” talks exclusively about TWRP-Recovery, but not about eRecovery, a fork of Lineage-Recovery’s own development.

The version of TWRP we used to test the ROM was 3.3.1-1

I used TWRP 3.5.0_9-0 from Decmber 2020 for the /e/OS ‘Q’ installation; in the meantime TWRP version 3.5.0_9-1 from Jan 27, 2021 is available.

However, after the successful and straightforward installation of /e/ OS ‘Q’, eRecovery e-0.13 and no longer TWRP Recovery is installed on the S9+ without any indication.

eRecovery is good for processing OTA updates and for a few simple additional tasks. However, the feature set is much smaller than that of TWRP Recovery.

The ‘Update recovery’ option in the developer options is functional. It allows the automatic update of eRecovery with system updates “Update the built-in recovery with system updates”.

1 Like

How long will the Samsung Galaxy S9+ ‘star2lte’ still be officially supported?

@SuzieQ: can you forward me to a description how to install eRecovery on s9/s9+?

It’s strange: /e/ offers its lineage fork eRecovery in the same breath as the /e/OS ROM, but doesn’t talk about eRecovery and its installation in the /e/ documentation.

There are several ways to install eRecovery on a Samsung Galaxy. One easy way is via TWRP Recovery, which is recommended in the /e/ documentation.

  1. First transfer the eRecovery .img file to the Galaxy’s internal storage or microSD card.
  2. Open the Main menu of TWRP Recovery on your Galaxy.
  3. Now tap on the Install option on the main menu of TWRP.
  4. In TWRP, switch from ‘Install Zip’ to ‘Install Image’ (bottom right) and select e-recovery.img file.
  5. Once the file is open, “Swipe to confirm Flash”.

Finally, for the sake of safety, confirm the installation by running “Reboot Recovery”. Now the Galaxy should boot into eRecovery and you can use it to install the /e/OS ‘Q’ for example.

@SuzieQ: thanks a lot for the information.

unfortunately, i have an /e/.shop S9 … .after installing Q through TWRP following the install guide it encrypted directly. with TWRP 3.5.2_9 i do not have access to the internal storage.

is there another way to install the erecovery.img over the existing TWRP?

on the other hand i could wait for twrp 3.5.2_10 is out, right? then your description shall work.

The custom recovery can be replaced like the OS. The /e/Recovery has compared to TWRP in lower in feature set, but it manages the OTA update flawlessly in the background (without possibly errant messages) and handles encryption well.

I test and use besides eRecovery and TWRP Recovery also SHRP SKYHAWK Recovery Project. It’s less known, but at least as functional as TWRP, can also handle ‘Magisk’ and ‘Treble’ and is visually appealing.

thanks for your explanation and information about additional recoveries.

in my case i want to use /e/recovery.
i first flashed TWRP, sideloaded /e/ image and overwrote TWRP with /e/recovery after just copied /e/recovery IMG file via win-explorer.
i do not know if this is the quickest way … but it worked :wink:

I think this omission might be the cause of some of my confusion. The rest of it can be explained by trying to use several outdated guides instead of one that is actually complete and current. This stuff changes so fast so I can understand the lag in documentation… especially within a dev community where information can turn to assumptions that live only in the heads of the initiated.

I can only assume by eRecovery you’re referring to these dev builds which feature a recovery image. The stable builds don’t have this and it’s like you said… It’s not mentioned here or here or here, or even here where it probably belongs. The best I could find was this discussion that can (presently) only be viewed using googles webcache. (It’s not on wayback)

I too have an s9 that shipped with /e/ running Android 8.1.0. So far I’ve been able to flash a stock Android 10 Rom but when I side loaded /e/Q I got error 7, and some explanations that aren’t making sense to me

One helpful user told me that I had to reboot to recovery in between wiping the system, and wiping the system and data partitions. I didn’t see that in the docs either. One guide says it’s mandatory to install this patch and another patch ( The vendors side loaded ok but the other one related to encryption failed with error 1.

What I don’t know is:
1-Do I need to reinstall Stock rom using Odin or is there another way to install /e/Q?

2-Why does a stock rom need to be installed if it’s pretty much going to be blown away immediately using TWRP? Clearly installing the stock rom insures the sideloading of the /e/ zip file but I don’t understand the mechanics

3-Is the real reason why I went wrong because I didn’t use twrp recovery to (overwrite itself?) by installing the eRecovery variant?

4-Do I need to side load the vendors file and the file that kept failing for me (I did re-reboot to recovery in between)

There’s no lack of places to get lost. Getting lost is the price to pay for knowledge and I’ve been paying over the last week. I finally feel like I’m close and that there’s just one or two pieces of info that I’m missing.

Update: I followed the upgrade instructions after a little break and saw this
Since my device was not encrypted (I think… since I didn’t encrypt it) I proceeded to sideload the /e/Q zip file.

It installed! Rebooted, Then said encryption unsuccessful…It said I needed to erase all data… ok nothing to lose at this point… It rebooted into TWRP and I saw an error but it went too fast.

So at this point… this is the furthest I’ve gotten.

1-Do I need to wipe/format/repartition or do anything manually?
2- Does the “” need to be installed? If so… precisely when?

I re-ran the vendors zip file, rebooted into recovery, then tried to sideload the dm-verity and forced encryption disabler. It fails with error code 1 preventing me from booting into /e/ proper (I think).

I wiped the cache, rebooted to recovery and tried to sideload dm-verity again but like before it fails with error code 1.

Hi, else where I think you said you were using this phone in USA? I may be quite wrong … but you may need to consider if you are experiencing a Samsung Regional lock. There seems some uncertainty how this all works!

You might check what you are experiencing with posts by master USU /e/ Installer @egx470

Thank you for taking the time to comment @aibd
I don’t know if this authoritative but:

But I appear to be one of many with Error 1.

I don’t know enough to believe or refute what you say but does it mean anything that my S9 is an SM-960F purchased from the foundation and that I’m installing G960FXXSBETH2_G960FOXJBETH2_SFR (from via Odin 3.14.4 and that my TWRP recovery is twrp-3.5.2_9-0-starlte.img.tar?

Please wait for @egx470 to comment!

You got a European phone which has got round the USA cartel.

Things changed with pie, so do not rely on old stuff if thinking of upgrading to Android 10.

IMHO Android 10 mostly introduces increased “security” for them. What do you feel it will give you?

Hi @Kritischer . @aibd is having some fun. I am a newb compared to him. I have a couple of these star2lte’s up on Q but what a nightmare to get them there.

Can you tell me what your current RMM status is?

The reason I ask is after getting /e/Oreo installed (unlocked bootloader and TWRP installed) I had to flash a stock Q ROM. After doing this my RMM went back to “Prenormal” but I was able to get it to “Checking” after connecting the device to the internet and let the device connect to the Knox servers. From this point I enabled debugging and successfully sideloaded /e/ dev Q via TWRP & adb. I think you are almost there too simply because from my experience, once you get the bootloader unlocked and TWRP installed the RMM did not return to “Prenormal” permanently even after the flash from /e/Oreo to stock Q ROM.

Have you tried backing up then doing a clean install from the stock QROM > /e/Q, wiping /system, /data, /cache before the sideload?

1 Like

No, I don’t recall ever using this. Try without using it. I would try a fresh sideload after Factory Reset , then Format data / factory reset then wipe /system, /data, /cache

You can encrypt the phone from the Trust functionality in /e/ after flashed.

When I get home later I can check what TWRP version I used if needed, let me know if you need this.

Please assume I need this… if only for a sanity check.

I’ve been doing this over an over again doing things slightly different.

I have not done a factory reset at all during this… so that’s something new to try. I’m so ignorant though… when you do a factory reset where does it load the firmware from? Since I loaded a stock Q rom would that be loaded or would the original /e/ oreo version be installed? I’m assuming there is a partition for factory reset.

Sorry, all these commands are done inside TWRP just before the sideload. I assume what you are saying is a “factory reset” from inside the OS.

All these steps are to be done in TWRP right before you sideload /e/Q ROM via adb👇Ensure you are on a stock Android 10/Q ROM and you have USB debugging enabled in developer options before proceeding.

  1. Boot into TWRP. Now tap Wipe.
  2. Now tap Format Data and continue with the formatting process by typing “yes”. This will remove encryption and delete all files stored in the internal storage.
  3. Return to the previous menu and tap Advanced Wipe, then select the Cache, data and System partitions and then Swipe to Wipe.
  4. Sideload the /e/Q ROM .zip package:
  • On the device, select “Advanced”, “ADB Sideload”, then swipe to begin sideload.
  • On the host machine, sideload the package using: adb sideload

That’s it👆, done.

The TWRP on my star2lte’s is 3.5.2_9-0

I am in business! Thank you beyond thank you.