Anyone can give advise about how to deep flash mi Xianomi Mi A1 (Bricked)

Hello. I need advice cayuse my device got briked whe I try to flash the oreo flash after moving to Pie.

I’m readng about deep flash (EDL) but I need advice about it. Can anyone help me?

TIA

Hi @Erekoze if you can still access Fastboot mode or it is being detected in adb with your MiA1 then it is not bricked. Flashing Oreo even stock ROM on top of Pie can cause problems in a number of devices.
You can try this.
!. Download the latest Stock Pie ROM for the MiA1. This you will get from the Mi forum. Save this to your windows PC desktop
2. Download the MiFlash tool also from the mi forum. This tool works with a windows PC
3. On the phone hold volume - and Power button together . Let go of both buttons when you feel the phone vibrate. It will take a few attempt to get this right.
4. This will get you in the fastboot screen. A black screen with the image of a bunny rabbit like this mia1
5. Enable adb on your PC. That is run adb devices and it should start the adb service.
6. Connect your phone to the PC with its usb cable
6. copy the path to the stock Pie ROM from your browser and paste it in the MiFlash too. Do not try to browse inside the MiFlash tool. In some versions of MiFlash it causes issues according to their website.
7. If your phone is in fastboot mode on click of the refresh button in Mi flash it will detect the phone
8. There are 3 radio button in the lower side of the mi flash select the first one - Flash all
Do not choose the last option as it will lock your phone. We do not want that in case we are planning on flashing other ROM’s
9. Flash the stock ROM. It will take some time. Let it complete and do not unplug or remove the phone when the process is under way
10 . Once you see Success in the MiFlash your phone should reboot and start the setup process . Complete the process.
After the stock ROM is installed you can revert to other Pie Custom ROM’s .
Return to Oreo ROM’s will cause a problem in most phones.

Thanks a lot for your advise, @Manoj.

Sadly my device is bricked. Doesn’t start. I made some test and looks like I can solve the problem using EDL restore. (The device shows the code 4008 on windows control panel using Qualcomm controllers).

SO, my idea is to make a EDL cable and flash from there) Obviously I’ll flash /e/ Pie on it when recover it. :wink:

That’s why I was looking for a wise advise doing it. The tutorial is YouTube look nice and very consistent.

Can you provide the YT link @Erekoze?
I mean the link for the tuitorial

I read diferent links so don’t remember which one, sorry.
My PC gives me this when I write lsusb

So the device is in QDL mode I nned to flash from there

Have you tried using a different computer? Maybe a windows one? Sometimes works for me when I have had problems.

I failed. The cable I made does not work… surely cause I’m awful with these thing since the University…

I’m trying with windows and shows 9008 code for the device. There’s an option using the correct cable but, as I said, the one I made doesnt work. I’m gonna make a new one and try again tomorrow.

The URL for the tutorial (for another Xianomi model) is Recovering Xianomi 9008

As a last resort you can take it to the nearest service center. If in the warranty period they should flash the stock ROM for free. Given that it is in 9008 mode it would not be clear if it is unlocked or a custom ROM has been flashed. I had some issues with a weird touch screen behavior more than a year back after flashing LOS ( /e/ was not available then) got it re-flashed with Stock for free. That is but the last option.

I think you can bring it back to life with QFIL.exe, i used it once on my softbricked Leeco S2, also QualComm based. Read here the rom is Nougat, maybe you can find Oreo on the net.

I can’t download de rom :cold_sweat:

Which ROM are you unable to download?

The one @andrelam sugest. But I found it searching Qfil usable ROMs.

I’ll try it tomorrow. Wish me luck.

All the best. Do let us know how it went.

Did’nt work. even the device is now loading as Qualcom USB 9008 as it did. Now looks like USB storage. :cold_sweat:

I’m gonna need to send it to a Xianomi service center. :face_with_symbols_over_mouth:

I got my device as new.

Android 9 installed so I’m well.

Thanks a lot for your advice. It was an awful experience. :mask::face_vomiting:

Did you visit a service center? If yes was any idea what they did - just flashed the latest ROM or did they have to open it to fix anything,
Just wanted to check since we have not had many reports of phones getting bricked and requiring support center visits.

OK. Here goes the story:

I visited a custom workshop which worked with Xianomi, as it showed on it’s publicity. They did the trick in 24 hours.

Sadly Xianomi doesn’t have service center here in Mexico.

I did it again. DAMN.
The phone is stuck in recovery cause it ask for password but doesnt recognize the password I used to use.

Is the shop you visited online? What’s their website?
Thanks so much

And I’m really sorry reading this: I’m frustrated with you!

I’m sorry to say the workshop doesn’t have website.