App Lounge not working after e23 update

Hi,
Yesterday, I upgraded to e23 on my BQ Aquaris X Pro. All went fine until reboot. Then I launched the “App Lounge” (the new name for store app) and was asked to either enter a Google account, or use Anonynous mode.
I selected to 2nd choice, then (almost) blank screen appears : seems there are some icons but not really visible. Then I get “Connection Impossible ! Check your internet connection and try again” (translated) after trying Parameters button :
App_Lounge-1 - App_Lounge-2

Tried a reboot, still same. No more way to use App Lounge, install any app, etc… It is a bit annoying.
Thank you.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Are you running a test build? What exactly does it say for you in Settings - About phone - Android version (tap on it) - /e/ version?

The 0.23 release notes don’t mention the new App Lounge, and it was last said to be still in testing …

No test version as far as I know. Just regular OTA update.
/e/ version shows : 0.23-q-20220324173215-dev-bardockpro
App Lounge version is 2.0.0

1 Like

Thanks for pointing this out. Will have this updated.

1 Like

Found this was related to my DNS (PiHole). Two hosts to add to whitelist to make App Lounge working :

  • clients3.google.com
  • android.clients.google.com
    Well I am surprised to have to enable some Google’s domain to make it works. I am not using /e/ OS to have such requirements.

Can someone explain what is going on here ? Is there a document explaining this new App Lounge behaviour and requirements ? It seems to me not following /e/ promise, am I wrong ?

3 Likes

App Lounge now gets its non-FOSS apps direct (but anonymously) from Google’s Play Store, the most trustworthy source of Android apps. To do this, it needs to use Google’s services.

Previously the apps came via the anonymous cleanapk.org.The apps that cleanapk.org delivered almost certainly also came from the Google Play Store (they have the same signatures as the play store versions) although no-one at /e/ ever officially admitted that.

Is the App Lounge source code now visible to people outside of /e/?

1 Like

I may have to disable App Lounge. I’m not thrilled about seeing connections to Google’s servers. (As seen in Blokada 5)

You need them if you want to install apps from the Google Play Store (i.e. any non-FOSS apps). The Play Store is where those apps come from. In the past, cleanapk.org (presumably) did the connection to Google, and the old Apps store got the apps from cleanapk.

1 Like

Yes, I know. Other than F-Droid-sourced apps, I mainly just use Signal and ProtonMail, but I can get the apk from their websites.

If some other need arises, I’ll consider what I might tolerate.

1 Like
2 Likes

Thanks very much for the link

NextDNS has a “NoGoogle” blocklist that one can utilize, but I never have since I needed Aurora Store. When I get home (my work wifi can be hit an miss for updating apps) I’ll see if adding these two exceptions allows me access to the App Lounge while blocking the rest of Google.

I get the same result when opening the App_Lounge while connected to ProtonVPN with default settings. I’ve done nothing to block google with DNS. This even happens when just trying to access the settings tab in App_Lounge.

The App_Lounge can’t connect even when “Show only open-source apps” is selected.

It would be best if the google connection only happens when actually querying Play Store apps so it can be used for open source apps only without requiring a connection to the Play Store.