App stores not working

I’ve had a Murena FP4 with e/OS for 2 years. This past year, the default app store has not been working, i have had a blank screen when i open the app. I have installed Aurora and Fdroid instead. For some apps like Signal i have not been able to install updates. I always get a “app can’t be found” message when I try to install an update. Last time I had to uninstall Signal then install it again with Aurora. This time, faced with the same problem, I have tried to do the same but couldn’t. I have uninstalled Signal but when i try to install it from scratch with Aurora, the download stays at 0% and won’t move up (even with wifi). Fdroid doesn’t have Signal and the default app store still has a blank screen.
I guess the best option would be to try fixing the default app store ? Does anyone have any idea about how to do that ?
Thanks for your time

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

What 's you current version of /e/OS?

Thanks for your reply.

It seems to be 1.1-20220708202086 indicated as dating july 8th 2022 which seems quite old and could cause the problem i guess. It seems that i am not being asked to update my OS when a new version is out now that i think of it. When I try to find an update, it doesn’t work and i am being asked to check my internet connexion. I am using my wifi and have access to the internet with my browser. Could there be something wrong with my settings somewhere ?

You might try this first off Issues with the Updater and a solution.

That build seems a match with e-1.1-r-20220708202086-stable-FP4.

Thanks for your ansswer aibd. Unfortunately while MRTN message landed in my mailbox, yours didn’t for some reason and i didn’t see it in time so i haven’t been able to try your solution yet. In the meantime, i have tried to install an older update which was sitting in my update list. Which i probably shouldn’t have done.
Anyway, in the end of the process of the update, it restarts the phone and aks me to type my restart code, the one one types before the PIN. I have tried my usual restart code which i have used dozens of times previously without problems but this time it tells me my restart code is incorrect. I have tried twice and am afraid to block everything if i try a third time. Has this happened before ? Should i try a third time ? What happens if i block everything ? Do you know if there is a timer on how long i should wait before my next try is considered a first and not a third try ?
Thanks for your answer

I have been able to figure out how to start my phone and tried what aibd suggested. My updater says it has last checked for updates today but won’t give me the last update. I have to install the october 2022 update the i’ll access the november 2022 and so on. Is there a way to skip directly to today’s update or do I have to install first all the updates I missed ?
Have a good day

In Oct 2022, FP4 received the last (stable) build for Android 11(R), then received an OTA upgrade to Android 12(S), see here :

If you have switched to Android 12 (S), you can update to the latest build of 2024.

I think we’re there. I was able to update the march 2024 version of the OS, my appstore works again and i have been able to fix the first problem which was not being able to update my signal app.
Thanks a lot for your help :star_struck:

1 Like