Issues with the Updater and a solution

Dear all,

Since version 1.14, a few users have reported a crash with the system Updater whenever they try to open it. In that case, they won’t get notified of the next OTA system update. To solve this problem users need to:

  1. go to Settings > Apps > See all apps > 3 dot menu > Show system > Updater > Storage & cache
  2. Tap on Clear storage and validate
  3. Go to Settings > Updater
  4. Tap on the refresh arrow

And voila! 1.15 should appear among the available updates!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Thanks for the tip!

For the record, if your phone is in french, the app name is “Gestionnaire de mise à jour”, you won’t find “updater”.
Same for other languages, you have to check for the translation of “updater”.


This morning I had a notification for a new version (1.15, i’m still in 1.14). After deleting the app storage, the updater don’t find the new 1.15 version. When i click on the refresh button, it says that i’m using the newest version. Is this normal?

You can set the phone to English, follow the necessary steps, and then set it back to your native language :wink: .
Settings - System - Languages & input - Languages - (add English here and/or if it’s there but not in the first position just long-tap and drag it into the first position)

Touch the button a couple of times (4 atleast)

In German it is “Aktualisierungsprogramm”


I was searching for a solution since some days. Thanks for this great hint!

1 Like

I have a Fairphone 3 with version 1.14-s-20230815320616-stable-FP3 installed. Despite following your advice when I try to open the update section the app closes. Do you think there is a way to perform the update manually?

This topic was automatically closed after 7 days. New replies are no longer allowed.

Hi, did you really perform the steps as indicated? It should work if you do it correctly.
But you can also update manually. More work though.

Bought two new Terre Cubes here. I followed the instructions. But unfortunately had no success with it. Stay on 1.14.

Thank you Manoj, iyour advice worked out well!

I’ve got different problem with the updater: it seems its somehow blocked from the Internet? It can not check for the updates and the information about it is displayed for a few seconds, and that’s it, nothing happens. I’ve followed the advice from the first post, but it didn’t help.

1.17-t instantnoodle

If nothing works consider sideloading it, if that is an option for you. You would need to install adb and depending on OS on your computer also some drivers.

Did you try already with all Advanced privacy turned off ?


It helped, thanks. And its working after re-enabling adv. privacy. Any particular reason why adv. privacy is blocking its own updater?

I do not know a specific reason but quoting from Advanced Privacy

Advanced Privacy is using an implementation of the Tor project. We extracted the core functionality from the Orbot application, and added a user interface on the top of it.

… and goes on to mention some Side effects. I can imagine that the updater requires a “quality” connection to establish that the correct update will be delivered.

I imagine this is true if ‘hide real ip address’ is turned on? I only block trackers, so it shouldn’t be the case. Anyway, problem solved, thank you for your time.

This topic was automatically closed after 182 days. New replies are no longer allowed.