Application Update no more working

Since a couple of weeks, the app updates are no more working.

  • Updates are suggested
  • Upon Update All or selected application update
  • Instantaneous crash : “Something went wrong. Please try again later”
    Any clue ?

My device : Samsung Galaxy S7
Applications concerned : WhatsApp and Artifex SmartOffice

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I’ve just successfully tested the eApps Store.WhatsApp and Artifex SmartOffice downloaded and installed via eApps.

Samsung Galaxy S7 e-0.9-n-202005*
eApps version 1.1.6
WhatsApps version 2.20.189
Artifex SmartOffice verson 3.8.6

wa2 wa3 wa1

wa5 wa6 wa4

Note: I’ve read the error message you mentioned in numerous recent postings about different devices. I don’t know what is going on.

I have just successfully tested the eApps Store.WhatsApp and Artifex SmartOffice downloaded and installed via eApps.

Samsung Galaxy S7 with /e/ OS 9-Pie e-0.9-pie-20200530*
eApps version 1.1.6
WhatsApp version 2.20.189
Artifex SmartOffice verson 3.8.6

[UNOFFICIAL BUILD] Unofficial Pie Build for Samsung Galaxy S7 edge (hero2lte)

My Artifex smartoffice version is 3.4.13
I uninstalled it and tried to download the last version using e.Apps.
Still failed with same error message.
Looks that update ans install are facing the same problem.

The fact that the eApps Store often doesn’t have the latest versions of an app available is a rightly and often voiced /e/ user criticism.

Why your eApps Store doesn’t work, but my two eApps Store downloads do, is mysterious!

I just updated my /e/OS with the latest mid May release. Now, updates and installs are working fine.
Could be the reason.


unfortunately I can’t update any apps using the e apps store. Updates work fine using the aurora store though. I would prefer to use the e apps store if it functioned correctly. I don’t get any error message when trying to update an app. After I tap ‘Update’ the update presumable downloads, as I see the progress indicator progress to 100%. Then my screen goes black for a second and the e apps app closes and I am returned to my home screen. If I then go back into the e apps and look at available updates, the same updates are available. I thought earlier that some apps seemed to update, but now none of them do. I was however just able to install a new app ‘Currency’ using the e apps store without any problems.
Sometimes I get the popup message ‘Apps keep stopping’, but other times nothing.
I have version 1.1.6 of apps, running /e/OS 0.9-2020061158052 on a Fairphone 3.
I use TrackerControl too, but having that enabled or disabled doesn’t seem to change anything at all.

I’ve now found that through the /e/ apps store I can install and update most apps. It is a two step process though. First I try to install / update the app in the /e/ store app. Most often this leads to a download of the desired app, but not an installation or update. It looks to me like once the file has downloaded, the /e/ store app terminates. If you go back into the /e/ store app it will look like nothing has happened. In my downloads folder though, I find a new downloaded file. Mostly this file will be named appropriately (e.g. ‘Signal Private Messenger’) and have the type ‘Android Application’. If it has the type ‘file’, you’re out of luck. If it has the ‘Android Application’ type though, by tapping on it, and then opening with the package installer, this should install / update the desired app without any further problems.
You can then check again in the /e/ store app to see if there is still an update available, but hopefully you will not see the app in updates, or if you can, there is only an option to open it rather than update it.
I’m still running /e/OS 0.9-2020061158052 on a Fairphone 3.