Apps can't access the internet

After upgrading to Android 10 (/e/OS 1.4-20220923220853) I noticed severe issues when apps trying to connect to the internet.

LTE is online and connected. I can open websites with the browser. So technically it should work just fine.

However …

  1. App Lounge … Timeout fetching applications! Some network issue is preventing fetching all applications
  2. System updates … Update check failed. Please check you internet connection.
  3. Signal … Unable to connect to service. Please check network connection and try again.
  4. Threema … Unable to resolve host “”: No address associated with hostname

Aside from some cosmetic configurations, the system is basically running on default settings, after a factory reset.

Again. LTE is ON. WiFi is OFF (I don’t have WiFi). Is there some hidden setting that prevents apps from using LTE?

I could really need a hand here. I don’t know what’s going on and how to fix it.

  • do you have the Tor component of Advanced Privacy active? (disable it)
  • did you set a proxy server for apps?
  1. I don’t think I have Tor enabled. I can’t even find any settings for that. Where do I need to look, to be sure?
  2. Advanced Privacy is disabled.
  3. I am not using any proxy server.

As I said, basically factory settings.

Have you checked the current APN settings of your mobile data connection versus the specification of your provider?

I am using the default settings. Network selection is also set to automatic.

EDIT: I also tried older versions. However, the problem remains.

Understood: default, you did not change apn settings.
Not saying this is it but nevertheless it might be worth checking.
Update to v1.0 produced a somewhat similar sounding issue (not exactly though) in my phone that I could fix by adapting the apn settings.

Maybe it is worth checking out the Access Point Name (APN) used by your carrier. They are usually published openly, or usually you can ask the carrier to send the APN to your device.

Personal view, the carrier may expect the APN to be delivered dynamically, but /e/ may interfere with this process. There are a few posts in the #apn category.

The APN already existing on your device should be found in

Settings > Network and Internet > Mobile network > Advanced > Access Point Names

Scroll down to find the selected APN.

1 Like

I’ve tried all available options under [Settings > Network and Internet > Mobile network > Advanced > Access Point Names]. Nothing works.

Besides, changing those APN setting would make sense to me if LTE would not work at all. The web browser works fine. The issue is that everything else can’t connect for some reason. Before the upgrade (with Android 7) everything was fine. I think the hardware is ok.

I’ve tried all currently available ROMs for my device. None of them solved the issue. I don’t see a way to downgrade to my previous version (Android 7) again.

What are my options at this point?

So this is a phone which changed in one go from Android 7 to Android 10? Which phone?

Re Signal: S7/S7+ upgrade related issue

It’s a Samsung Galaxy S7. I had /e/ OS on it before. I don’t know which exact version, but it was an Android 7 ROM from (I think) 2021. I upgraded directly to /e/ OS 1.4 and got myself into this mess :frowning:

EDIT: I should add, that after the upgrade I did several factory resets, meaning. sideloading clean images directly on the device with adb, just in case the upgrade broke something. As I mentioned before: that didn’t help.

So in your case, with Samsung S7, Signal is a known issue as linked above.

App Lounge does seem to time out at busy times and in my experience particularly over the weekend. (In addition App Lounge will time out silently!)

No real idea about Threma, but if the recommended Signal reinstall is successful you might consider a similar approach with Threema?

A jump of three Android versions is quite unusual, so perhaps it is right to look at each issue separately?

I think at this point you can ignore the fact that I once upgraded the phone. I only mentioned it to point out that these things (app store, system upgrade, other apps, …) worked a couple days ago. Right now it’s a clean /e/ OS 1.4 after a factory reset (several actually), using default settings across the board. Also, right now I don’t even have any additional apps installed. I only rushed through the initial initialization using all defaults and for now I avoid any kind of configuration/customization. My test case is the App Lounge and the system upgrade feature. I don’t do anything else until I manage to get them to work.

Immediately after a reset, I enabled adb debug mode and let “adb logcat” running. Here are some interesting logs:

D SntpClient: request time failed: Unable to resolve host "": No address associated with hostname
E NtpTimeHelper: requestTime failed
D UpdatesActivity: Checking
E HttpURLConnectionClient: Error downloading file
E HttpURLConnectionClient: Failed to connect to
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at
E HttpURLConnectionClient: 	at$
E UpdatesActivity: Could not download updates list

Based on these logs I would normally assume a general network/connection issue. The app store is not working, same for the system upgrade feature, not even time synchronization (NTP). That raises the question: Why is the webbrowser the only thing that works? I can successfully load websites!

Is there some security feature in the way or something?

Interesting research.

You will know that the App Lounge (version 2 of Apps) arrived with /e/ v1.0. You might review or contribute to one of the Gitlab - Issues #App Lounge.

You might also review the Release notes found here Releases · e / os / releases · GitLab.

Regarding System updater there is Gitlab - Issues #/e/OS Updates.

If you have any difficulty logging in to the /e/ Gitlab there is guidance for new users here Report an issue.

According to the log, I’d try to check/change DNS settings.
Browser may use it’s own internal DNS mechanism …