Aurora Store not connecting after update

Hi erveryone,
I hope I am at the right place for my problem.

I recently updated the “Aurora Store” app and since then, I am unable to connect to the store which is really annoying.

When I launch Aurora Store, it says “You need to login first” and I have 3 options : “Google”, “Anonyme” and “Anonyme (non sécurisé)”. I tried options 2 and 3 and a turning wheel that keeps on spinning for ever. I tried uninstall and re-install the app but it didn’t change a thing.

When I install “Aurora Store”, I am not sure which “Installateur (Installer)” I should choose…?
“Session installer”, “Native installer”, “Root installer”,…

I have a FairPhone 3 with /e/OS 0.23-20220406176461 (Android 9)

I hope someone can help me…

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

This issue is with the Aurora store and not e/OS itself. Google has made changes, which effect Aurora anonymous accounts and are now ‘rate limited’. Everyone using Aurora Store in anonymous mode is sharing the same few Google accounts. To Google, it looks like there is a small group of accounts mass downloading the same apps (and a few random ones) over and over. Google responds by slowing down access to these accounts. The Aurora team is aware of this, however there are no solutions as of yet. The only thing that seems to work, is make a clean/dummy/throwaway gmail account and sign in Aurora that way. This ensures better stability and gives you the full potential with the features available in Aurora Store. This is the only known workaround so far.

Using the default session installer in Aurora is fine.

Is there any reason you are not wanting to use the e/OS App Lounge?

Other appstore options would be ‘uptodown’, ‘aptoide’, & ‘apkpure’ to name a few…

Obtainium is another option…
Video Overview

Obtainium allows you to install and update Open-Source Apps directly from their releases pages, and receive notifications when new releases are made available.


This is a known issue with Aurora and has been reported in Github

1 Like

Thanks a lot for the rapid and complete answer ! I now know what my options are.

There are 3 applications I can’t find within App Lounge (2 banking apps and one identification app)…

Another option would be to extract the APK from Google Play, then side load them to your phone.

How to Download an APK from the Google Play Store

You are very welcome. Hope something here helps you.

1 Like

Your version of /e/OS is completely outdated and hasn’t had any updates for over a year.

You’re still stuck with the old ‘Apps’ store that worked in a very different way from the new ‘App Lounge’.

I recommend you first upgrade your device to the latest /e/OS version with Android 12


The Aurora Telegram support channel is here:

1 Like

Thank you for your answer and suggestion. I haven’t updated my FP3 yet since the procedure scares me a bit… I will try to do it in soon after backing up my data.


This topic was automatically closed after 90 days. New replies are no longer allowed.