Auto Rotate works ... eventually

I have a Galaxy S7 Edge, one of the new ‘preinstalled, sold by’ phones.

My issue with auto-rotate is that it takes a variable (but usually, looong) time to kick in. That is, after I rotate the phone, anywhere from 10 seconds to well over a minute.

Is this just a config setting I’ve been unable to find (it feels like a battery-optimization thing), or should I file a bug report?


Please file a bug report with logs

I never did file a bug report. Started getting set up to pull log files, got sidetracked by the idea of rooting my phone, and …

Magically, my Auto-rotate has started working much better, with the screen rotating usually within 2-3 seconds, and often, in <1 sec. Possibly got resolved after a system reboot, though I’m not sure when it got resolved.

If the problem returns, I’ll try to catch it in a log and file a bug report, but for now, at least, it seems resolved.

Just a passing update … This problem has (mostly) gone away for me – tentatively, I think either a system reboot, or the actual process of turning on the dev options – mostly resolved this.

Unfortunately, it still happens 1-2x/week. It’s not a big deal for me, so I’m just ignoring it – mainly since the intermittent-and-infrequent nature of it now makes it extremely hard to catch an error log.

I have more or less the same problem. I have a Samsung s7 edge with /e/ os pre-installed on it, since 4 or 5 days. I have noticed that the auto-rotate function only works with few apps like “magic earth”
What should I do? How can I file a bug report ?

Same problem here with same device bought at, last update done

You can add a bug report here attaching logs as mentioned here

I dont know why but it finaly works for me.
Nevertheless thank you for your answers.

Thanks for the update @Thom definitely it was not fixed from our side :slight_smile: Looks like some config or setting change must have resolved it.