Auto update error on FP3

This morning I tried to update /e/OS on a FP3. On reboot I got the "Can’t load Android system… " message. Spent the last 4 hours trying to flash the /e/OS back onto the device but to no avail. Now I fear I have to reset to factory data. I fear I will lose everything I spent years collecting, contacts, notes, files all of it.

I have the adb fastboot tools installed on the same ubuntu PC I used to install /e/OS with the first time but any fastboot command I give results in . If I restart the phone in recovery, go to Apply update from ADB and do “adb devices” in terminal I do see the phone listed. Any Fastboot command still gives .

Sort of on the end of my rope here. I tried running fastboot as root this gave the same result. Am I totally screwed now or am I still missing something?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Did you try this?
fastboot getvar current-slot , its either a or b.

If it was a:
fastboot --set-active=b

if it was b:
fastboot --set-active=a

Then start again.

Thanks, yes I did. That gives me “waiting for any devices”, like all other fastboot commands. adb commands do seem to “find” the device.

from the recovery screen on the phone I see this in the bottom:
Android 9
Slot A
LineageOS 0.12-p-2020093076095-dev-FP3

Somehow the fastboot commands don’t seem to find a device to work on :frowning:

You did use the fastboot commands in fastboot mode right?
(By pressing and holding the power and volume-down button until the device starts into fastboot mode)

1 Like

yes the phone is rebooted in fastboot mode.

It seems I am one step further now. This whole time I started the phone in fastboot mode but then went into recovery mode and tried to flash from there>Apply update>apply from adb. It seems fastboot commands work wehn you stay in the fastboot mode menue on the phone.

Now however I see active slot is A but when I do

fastboot flash system system.img

I get:
Sending sparse ‘system’ 1/4 (522236 KB) OKAY [ 15.724s]
Writing ‘system’ FAILED (remote: ‘Partition flashing is not allowed’)
fastboot: error: Command failed

Then try this first:

Then press start.

Seems you locked the bootloader then you can’t flash, try above first…

yes, just did

fastboot flashing unlock

the phone asked me if I wanted to unlock the bootloader. said yes. Now the thing is restarting /e/ without me reinstalling the OS. It seems I have to reenter all my initial settings though…

thanks for your help, will keep you posted

That ‘fastboot flashing unlock’ command erases your userdata! Others with this problem, try to set the other partition active first before erasing data:
fastboot --set-active=b or fastboot --set-active=a

1 Like

thanks, but your warning was too late. It seems I have deleted all my data. I guess I am back where I was this morning. #fubar

if unlocking erases data why is there the fastboot -w command to start with. I hope I have a copy of my contacts from a year ago somewhere otherwise I am pretty much screwed out of all my previous data now. Also I have no idea how to prevent this from happening next time I get an update notification. Having serious doubts whether /e/ is for me.

The fastboot -w command is there to wipe userdata. Not all users unlock their phone because they may already had done this. So fastboot -w is meant for first install. In this case there was an incident the OTA was corrupt, and that resulted in a non booting phone as you experienced. Now the solution for this would be to set the other partition active again (the software before the update is still there).

Please consider this as an incident, i’m sure the /e/ team is improving their workflow. I don’t work for /e/ just a volunteer, but hope you stick with /e/.

1 Like


Where can I find the October 30 update? My phone is still on 0.12-202010376806 and preferences/System/Updater/reload doesn’t find any new updates (last checked: 1 November 2020 8:03). I don’t mind doing a factory reset. It is worth it for me to not have to have the new MicroG. It would be nice not to carry two phones to have the Corona Warn App along with me.

(hope it is ok, I’m cross posting from FP3: does anyone have a working October 30 update?)