FP3: does anyone have a working October 30 update?


as you may have seen, several people (including me) are not able to boot their FP3 after the update of October 30.

Did anyone perform the update on that date (or after that) and has a phone that is able to boot?
Or does anyone had the “Can’t load Android system” error, and manage to get out of it by switching the slot (for this update, not a previous one)?

I do not intend this Topic to talk about how to solve this (they are already discussions in other Topics), but simply to see if it worked for someone.

Thank you.


I have it working. A few odd things happened with VLC but I don’t know if the ‘October’ (shouldn’t this read September?) version is to blame. However I didn’t do a normal update. My phone is rooted with Magisk installed and I updated using the procedure outlined here: https://topjohnwu.github.io/Magisk/ota.html#devices-with-ab-partitions

Doing it this way updates the stock image, not the one you are using, and then uses Magisk to restore things as you want them. The check for corruption etc. of the image is done before Magisk does it’s work This suggests to me that if you update the normal way then either this test fails or something happens to corrupt the image.


Where can I find the October 30 update? My phone is still on 0.12-202010376806 and preferences/System/Updater/reload doesn’t find any new updates (last checked: 1 November 2020 8:03). I don’t mind doing a factory reset. It is worth it for me to not have to have the new MicroG. It would be nice not to carry two phones to have the Corona Warn App along with me.

The October 30 update talked about here does not include the updated microG.

Here it sounds like (to me) the October 30 update should be the fixed version of the former 0.12 update which got retracted, and it sounds like (to me) it’s being rolled out to a limited number of users for testing purposes.
But sadly it seems this supposedly fixed update could cause an even bigger boot issue than the original update did (bigger because switching the OS slot back to the prior version of the OS doesn’t seem to help anymore). We’ll have to see.

There’s a number missing in this, unless /e/ changed the naming scheme of the update files.

Thanks. You are correct; the version is 0.12-2020100376806

I think the OP meant the September 30 update.

No, I did mean October 30.
That’s why I tried to made clear I was not talking about a previous one, but I should have given a date (but did not know which date, because I think some people had an update early October, after the one of September 3).

Ok, In had forgotten the exact date to, but I knew it wasn’t 30th October!

Sorry, I missed this part of your answer.
So no, you should not read September, but indeed October 30.

Reading this version number seems to validate what I told in the previous answer: there had been an update for some user in early October (the 3rd apparently, for him). So that’s why I did not give a date for a “previous update”.

The version that I had (which is still on slot_b, but not usable neither) is 0.12-p-2020093076095-dev-FP3.

The updated version (slot_a) is 0.12-q-2020103081625-dev-FP3.
The “q” is really weird. Could that be the source of the issue?
Note that the new /e/ recovery screen does not display the exact version (Only “Version 0.12 ()”), so I had to go look into the log. I found this version number under those lines

[…] ro.lineage.display.version=0.12-2020103081625-dev-FP3
[…] ro.lineage.version=0.12-q-2020103081625-dev-FP3
[…] ro.modversion=0.12-q-2020103081625-dev-FP3

Plus, I have this line

[…] ro.odm.build.date=Fri Oct 30 10:23:57 UTC 2020

(same for ro.vendor.build.date and ro.bootimage.build.date

So you simply did not get the update I am talking about.
This is the new one (Oct. 30) that seems to have issues with all users, while the previous one (the one you have) caused only 1 unusable slot for some users.

“q” is Android 10 … perhaps you’re on to something there.

Yes I know it is for Android 10… That’s why I found it weird ^^
When you say I might be on something, do you mean that we could be pointing to the cause of the issue with this?

I don’t know anything about what Android version upgrades/ downgrades do to/ expect from the data partition, but since it looks like the retracted 0.12 updates from earlier were “p”, “q” updates would at least be an obvious difference to the earlier boot issue incident.