Automatic Network is always on, Manual Selection not possible, Fairphone 4

Hello All,
My Problem is, that with my phone ( Fairphone 4) i can not deselect the automatic network selection!
I need the manual selection of mobile networks to get the best provider or the best network quality.

I checked the APN settings, which are correct.
on my phone there is the Android 11 version,
i use e/OS:
0.23-r-20220404175826-FP4

does someone know the solution for this problem??

i found this old chat, that i opened after 2 years:

but no solution was given there!?!
the link within this chat: Manual network selection (#1673) · Issues · e / Backlog · GitLab
also gave no solution, but only was “closed” !?

thank you for your help and answers…

:slightly_smiling_face: :crossed_fingers:

Hello.
Couldn’t you upgrade from 0.23 to 1.x?, and from A11 to A12?
Don’t know if this will solve your problem but for me, FP4, 1.8.1 stable, A12, is possible to deselect automatic net selection.

Hi Jobal,
Thank you for your answer!

This was one idea i also had. Still i didnt have time to back-up my phone…

So i was trying to find out if this is a “general” topic - where others might have that problem too?
if an upgrade will be the easiest solution, then i will try your idea & do the update! - still after a back up :wink:

Hi Jobal,

I now followed your advice and updated to the newest e/os 1.5 - 202210

still i have the problem, that only automatic network selection is on. and its not possible to change to manual selection!

i am happy if there is more people around who could help with a solution!

best regards,

e

1 Like

Just to confirm that it’s not a UI problem …

  • You go to your SIM settings at Settings - Network and Internet - SIMs.
  • The “Automatically select network” switch is enabled, “Choose network” is greyed out and unaccessible.
  • You tap on “Automatically select network”, the “Choose network” page appears.
  • Important! You choose a network (tap on it, even if it’s the only one available), there will be no confirmation of anything whatsoever.
  • You go back to the previous settings page … “Automatically select network” is disabled, “Choose network” is not greyed out anymore and accessible.

No?

Another Elk,
its not like this.i am sorry…
here are the screenshots!
FP4_network01

1 Like

and then…
if i touch the area of “net automatic choosing” or if i touch the green / white slider.
i get to the following screen…
FP4_network02

1 Like

so i can only try to write a name and do the search, ibut i can “not” disable the automatic network!
if i go back, see the same screen as above!
thank you,
ey

1 Like