Background applications

Thank you for your answer @harvey186, unfortunately i cannot find the ‘developer options’ (I own a galaxy s9 with eOS -oreo).
I suppose I will have to wait until eOS - pie is supported. (unless I’m really blind)

You have to activate them in ‘About phone’
Push 7 times on ‘build number’

Than they will be activated :smiley:


OOOOOOHHH !! It’s Magic !!

Thank you @harvey186 !


Always welcome. Enjoy eOS :+1:

harvey186 In eOS -pie (not sure if it is also available in nougat) there is a setup in ‘developer options’

In /e/OS-nougat too.

1 Like

Can I also allow a app to run in the background with this option?

You can choose which apps are allowed to start at boot or run in background in

Pie : Settings > Security & location > Trust > Privacy Guard > long press on an app.
Nougat : Settings > Privacy > Privacy Guard > long press on an app.


Thanks for the help. I found the menu but I did not found an option to allow zo run in thr background. What I am looking for?

If the app doesn’t use this permission, it won’t be displayed.

Once you click on “Privacy Guard”, click on the 3 dots at the top right, then “Advanced” and swipe from the right to the left until the “RUN IN BACKGROUND” or the “BOOTUP” tab to directly see which apps are using those permissions. Click on the app you want to be able to modify the permission.

And if the app is not shown there thrnn it is not possible to run it in the background?

Would you know an other splution to allow a app to run in the backgroud or prevent it to go to sleep?

That’s what I understand.

Disable Battery optimization in Settings > Battery.

Unfortunaly, my business app is still going into deep sleap after a couple of minutes. This is realy bad for my business. I do miss important phone calls.

Anyone an Idea hoe to keep this app alive when it is in the background open?

So you issue is actually to receive notifications, right ?

If yes, can you send a screenshot of what you have in Settings > MicroG > Google Cloud Messaging please ?

I don’t realy know if it is a notification issue. Actualy it’s more like the app is going to “deep” sleep after a couple of minites. It has all rights to stay alaive but it dosn’t do it. No power management, has everything (I know) allowed, all messages possibilaty are allowed. etc…

I have no idea of microg, so I went for the first time in this settings options.
Here are my screenshots.

Business Telephony is actualy open in the background, but in the screenshot it say yesterday. I don’t know if this is relevant.

Good to know, even if it is buried rather deep in options. Even searching in Settings for “boot”, “startup” did not find it.

As a side note, what is toggled when short pressing instead of long pressing? The weird smiling icon without eyes changes from grey to blue, but there is no indication of what this means.

Another very useful section, buried even deeper.

1 Like

It activates or not Privacy Guard for the app.

Presumably grey is off? But that would mean Privacy Guard is off by default?

Very confusing, because the settings for an app can be changed regardless of the icon color/state. Normally the UI disables / greys out the row of an entry that has been toggled off, and would be indicated by a checkbox or slider.

Would something like this be possible on Android10 ? Can’t find anything about Privacy Guard there.
(It could be a solution to my Tasks problem.)