Emails sync settings with Mail app (end 2020)

After having had Mail sync problems on my stock S7 Samsung, bought from /e/, running Android Nougat 7.1.2 and just updated to system 0.13, I want to share my email sync settings.
I could not find a suitable and complete answer elsewhere on this forum.
Note: menu names may not be accurate as I am on a French language /e/.

Here you are, Sync must be activated at all 4 levels (!):

1. Mail app
mail app > “…” menu (top right) > settings > account settings > email retrieval (or collection?) > email syncro > set at “all dates” (or your choice).

2. Phone parameters
Phone parameters menu (swipe down from the top of the screen), Syncro icon must be activated. If you cannot see the Syncro icon, you can add it by clicking on the pen icon at top.

3. Phone settings
Phone > settings > accounts > /e/ > > “Accounts management” (“Gestion des comptes” in my French screen) > a popup propose to force sync. I accept > I am warned that forcing sync may reduce battery life. I accept.

(This last setting seems to have the same action as @Manoj proposed here but that do not work on my phone as Mail app is listed as “not optimized” and “Battery optimization not available”)

I just adjusted the Phone settings on my phone and it seems to sync OK.
But after restarting the phone, no sync again.

4. Open Mail app at launch
So, this is the 4th level: you must start the Mail app once for Sync to work (you can close it afterward).
You should be able to set Mail app to start at launch:
Phone > Settings > Privacy > Privacy Guard > click on the 3 dots at the top right > Advanced > swipe from the right to the left until the “RUN IN BACKGROUND” or the “BOOTUP” tab to directly see which apps are using those permissions (from here) > click on Mail app.
Hopefully, this should open a menu where you may activate launch at start.

Sadly, this last step brings me to an empty menu saying only “no available authorization to block”. :worried:

If all this can help someone. Great!
If someone can help me unlock that launch of Mail app at background, it would be great.

Note: I think that all this is not desired. Once the syncro in the Mail app is set, it should work right away or warn users that other parameters adjustments are required.


Well, it did not last long :weary:.
2 days later, with all settings still checked as above:

  • Mail app message retrieval set at “all dates”;
  • Phone “Syncro” still On;
  • /e/ account in Phone settings is still synced (last sync 2 minutes ago);
  • Mail app is still open;
  • No more popup available in /e/ account to force sync;
    I work in IMAP & Mail app build 5.600

But sync, underneath the Inbox title, is Off. And no “error” message shown (enhancement already asked on Github).

I close the Mail app window and Mail app immediately sync in the background and notification shows up at phone unlocking.

After searching, I found this

5th level of setting in Mail app > Settings > Network > Background sync. It is set at Always. Good!

6th level of setting
Phone > settings > /e/ > Account management > Gear icon Sync in Wifi only > set as On (which is fine for me as my phone do not have a data plan). But is seems this is not for emails but for contacts & calendars.

7th level of setting
Phone > settings > Accounts > dot dot dot menu at top right > Auto sync is set as On.

My Mail > debugging log is set at On, but I cannot find where are the logs.

Is there a 8th parameter to adjust?
Is this a bug that have been (should be) reported?

I see a similar bug on Github, but not identical as, when sync is working, message retrieval works fine for me.

Well, I now understand that K9 Mail app have many problems of sync that should be solved sometime in version 5.7 or 5.8.

I am just surprised that no information was given before about this buggy syncing. Particularly as there are so many parameters involved.
Having a “Beta” mention within the app, next to the Sync parameters, would go a long way to warn us.
(Well, anyway, I have been warned, /e/ is still in Beta, I suppose)

I’ll live with that or switch to another app. Thanks for all who work on this!

Pending resolution of these problems, I installed FairEmail which seems to work fine.