Banking app BCV crashes, 3-D Secure, FP3+/e/os 2.1


I use a Fairphone 3+ with preinstalled /e/OS (and regularly upgraded since).

I can use the banking app for a couple of operations without any issues.

But, as soon as I want to activate 3-D Secure on my credit card inside the app (e.g. for internet payments), the app crashes and keeps crashing since. I can not activate 3-D Secure on my desktop, it requires the app.

I contacted my banks’ tech support. According to them, my FP3 appears being a Pixel4 with Android 10… We tried to activate 3DS a couple of times together, but the app keeps crashing. For the tech guy, it looks as if the OS was corrupted, and therefore the app crashes (in order to protect my money).
This requires a full reset of the banking app and a quite long reactivation procedure by phone (reception of an activation key, validation via SMS, etc.).

This banking app works fine on my wife’s Google-spyphone from China, incl. 3DS.

Other banking apps work perfectly well on my FP, incl. 3DS (France: Boursorama, Crédit Mutuel). BCV Twint also works without any problems.

I only could find older issues related to BCV net (the former name of the app), none of them gave any relevant informations to the noob I am.

/e/OS 2.1-t-20240603406607-stable-FP3 (Android 13).
Banking app BCV Mobile version 14.3.0
Advanced privacy is disabled for BCV Mobile, (and yes, I cleaned the app cache and restarted the phone several times while on the phone with the tech support guy, and even before).

Any help will be appreciated. Many thanks in advance!

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone


If the app doesn’t bother with ADB debug being activated, a logcat may help.

Hi smu44,

just to make sure that the noob (me) understands you right :thinking:: I shall try to follow these quite mysterious tech instructions :exploding_head: and crash the app again and get myself locked out of my e-banking account again? :astonished:

Once I attempt to activate 3DS, the app crashes. From this moment on, the app is dead. I can no longer use the app, as it keeps closing before I can do anything.

But, this app also serves as a 2nd factor for 2FA for my bank account, this means that I am locked out of my bank account.

I need this app to work, at least for the 2FA part, reactivating it takes about one hour each time, even if I crash it with the technician already on the phone (yes, I spent > 2 hours on this yesterday, instead of working, as the tech support is only open during my working hours; my boss is already very angry).

So, I have to admit that my motivation to kill the app again and lose another hour on the phone explaining why and how this happened is quite low, and for reproducing the app kill a 2nd time, as requested, it is even lower. :face_with_raised_eyebrow:

I am not an IT/phone-specialist. I am a single noob-user and all I want is, that my FP, /e/-OS and the BCV mobile app work.

Anyway, I managed to install adb on my computer :exploding_head:, managed to activate the developer options, but I can not find “Android debugging” on my phone. This point is missing under Settings > System > Developer options > … :exploding_head: :exploding_head: :exploding_head: but there are too many other things.

For now:

adb devices
List of devices attached


Could you check your device registration:

Additionally, you could try and turn off Advanced Privacy for that app. Maybe some blocked trackers are issue.

Can you use the bank account only via app?

1 Like

How do I check the device registration?

Advanced privacy is disabled for BCV Mobile

And I still can’t find the Android debugging

And yes, the bank app is usable for e-banking (at least until I try to activate 3DS, I haven’t tried to change any other settings).

Device registration: Microg settings → device registration

bank doesn’t allow online banking?

1 Like

The bank allows e-banking. But, to do so on your computer, you have to use 2FA, the app is the 2nd factor (or, you also might use the app alone, which is very strange, because there is no 2nd factor any more, but this is not the question here).
If the app is dead (after attempting to activate 3DS), e-banking is no longer possible, as I can’t get the 2nd factor for identication.

Device Registration:

Hmm your ‘Google device registration’ is off :thinking: :thinking:
According to this documentation it is needed for notifications. Do you get any?

Can you check your SafetyNet:

Just run the test once. Not multiple times

1 Like

Sorry, I didn’t understand, from your initial post, that any further attempt will lock it.
Better solve the device registration first!

I get notifications from many apps (e.g. Signal, Mail, etc.), but I haven’t seen any from BCV mobile, yet.

WRT device registration, doesn’t this mean that I re-googelize my phone a little bit?

In earlier versions of microg I remember that if you miss on the ‘Allow notifications’ then you can^t change that.
If you wanna force that again you need to reinstall the app or clear storage, which means all data is gone.

About ‘re-googelize’ I refer to the link I sent. Everyone needs to know themselfs what they wanna do. I have it ‘ON’…

Not sure if this will help, since something changed over time. It worked before correct?

If I have to reinstall the app/clear storage, I have to go through the one-hour phone call with the bank again. So, I won’t touch it,for time being.

I don’t know if 3DS would have worked earlier, I was forced to switch from the offline TAN calculator to the app this month.

I see. I understand your stance. Not sure what to suggest you. Creating an issue … :thinking::thinking: you would surely need to send some logs then to the /e/OS developers.

Try to search for USB debugging, or just debugging.

May be an idea to practice taking a logcat and reading it without deliberately crashing the app.

1 Like

USB debugging is there :heart_eyes: and it seems to work.

Now, I managed to get the logcat.txt file and it even contains something that looks like the last app crash.

Once you have the logcat file please share it with the development team as an attachment to the Gitlab error .

How can I do this? Just send the content of this logcat.txt here?


To involve the devs you would Report an issue and include (part of) the log there.

The log is likely to be very large so you might experiment with pasting it to (for instance)

You might choose to copy your “pastebin” url here in case someone here can help you pinpoint the most significant part of the log.


I can not create an account there, my 2 mail addresses (my main e-mail address, I also use it for this account here and the “waste”-address) are refused. :exploding_head:

Capture d’écran_2024-06-28_11-40-21

I checked on Issues · e / Backlog · GitLab there seems to be nothing about BCV, yet.

I hope there is nothing too personal inside this log. Maybe somebody can inform the /e/ tech crew on my behalf? This would be nice.

Thanks to all for your help to the noob.

That looks a very useful log.

This happens to many and is covered in the link …

Getting an error message in new ID creation on /e/OS Gitlab? … as said there you should simply ask for help from

  • Just to help you to learn from the log … you might primarily study lines 1 - 61 … (unchecked, but I think you would then find a very similar attempt to open / run the app being run another 18 times.)

banking app seems to have some hard dependencies on parts of firebase - no way around it. Enable everything you see in microg settings.

these stack traces in the logcat took my attention: tchncs

E AndroidRuntime: Caused by: SERVICE_NOT_AVAILABLE
E AndroidRuntime:    at

because device reg is off I think:

W GmsGcmRegister: java.lang.RuntimeException: Checkin disabled
W GmsGcmRegister:    at org.microg.gms.gcm.PushRegisterServiceKt.ensureCheckinIsUpToDate(SourceFile:1)

there’s a bad auth error, but could be intermittent

W GmsAuthManagerSvc: Error=BadAuthentication
W GmsAuthManagerSvc:     at org.microg.gms.common.HttpFormClient.request(Unknown Source:372)

This is how alot of modern Apps get written these days. I kind of think it’s all about settings atm?

1 Like

This whole log is more than incomprehensible for me. All I can see is that the BCV app crashes quite often.

I don’t know if this is a log prior to the app’s last death (in this case, the first lines should be somehow different) followed by my vain attempts to resurrect it (at least for 2FA), or if they only show my vain resurrection attempts before re-installing it while on the phone with the bank tech guy after a total data wipe.

I now wrote a mail to these /e/OS giltab helpdesk guys (I thought the forum was here to get in touch with the /e/-engineering team, I never heard of the giltab helpdesk before). Let’s see if they think it is necessary to create me an account on this giltab helpdesk forum.

As any app crash (due to my attempt to activate 3DS) locks me out of my bank account, I won’t change anything now (it’s Friday evening, the bank call center is closed and I don’t want to be locked out of my e-banking, as there are bills to pay). :grimacing:

And, if I have to kill the app again, I would like to do so with someone from /e/ or giltab helpdesk being there to assist me to get the correct logs, preferably during the bank’s call center opening hours. :wink: