Best practice to add foreign caldav-account?

Dear folks

I’d like to add a foreign, non /e/ hosted calendar via caldav-connection.
I’ve tried adding a new account, but there are only three options: /e/-account, google-account, WebDAV.

How can I add a calendar from another server that’s neither /e/, google, nextcloud etc. but provides a caldav-address for synchronisation?

Thanks for your help!

To my knowledge you can add a “foreign” CalDav calendar with the “WebDAV” account type.

Thank you. I’ve just tried that, am able to add the account, but afterward the account manager only offers to sync contacts. Apparently it only discovers the carddav but not the caldav server. (the particular caldav-url works fine with thunderbird, so I suppose it’s not a problem of the url, but a problem of the account manager)

You can add DAV resources by using the excellent DAVx5 app (formerly DAVdroid) : available on F-Droid : :slight_smile:

I’m sure it had worked for me in the past and I just tried again.

I’ve added a “WebDAV” account (not “WebDav Address book”) and used “Login with URL and user name”.
In my case the URL needed to end in “/remote.php/dav/” and not just the root of my owncloud installation.

It then added two entries in my account list, one for calendar (shown as type “WebDAV”) and one for my contacts (shown as type “WebDav Address book”).

And finally I’m able to see my non-e-clound calendar entries.

Well, I’m on “test” with version of 2020-09-26 and I have 8 different account types to choose from. So maybe that’s the difference?

aha, interesting, I’m on /e/OS 0.12-2020093076095 (regular edition I suppose…)

I assume your version is newer despite the older date. Do you think I can just wait for the next system update, is it likely this feature will be updated in the regular edition?

(before trying out DAVx5, as Breversa had suggested).

I’m quite new to /e/ but I’d assume that features of the test branch usually make it to the regular builds at some point.

I guess it’s possible to add the account now with DAVx5 if you need it urgently and later switch to an “internal” account.

Have a look also here.

Thanks guys for all your help. I’ve tried installing dav5x and setting it up throught there, same problem. So it seems to be some underlying issue (as far as I know /e/ is using the dav5x-code for it’s webdav account management anyway.)

Ever since installing and uninstalling dav5x I’m having a lot mor account options too, by the way… (not that it would change anything)

It seems that the problem in “Account” is scattered through the various builds/devices. On some it works and in some not.