Black screen after computer stops during install with easy installer

First of all thanks to everyone who contributed to this great project. I already installed it on my previous smartphone and it worked like a charm, unfortunately it broke last week.

I bought a brand new Gigaset GS290 with the intention to run /e/ on it so I got it off the box, followed the instructions on the easyinstaller and went through the whole process until the screen that says “installation will be over once the logo disappears” (or something like that). That screen was on for at least an hour but my computer (old lenovo running ubuntu) decided to stop working at this moment for some reason. From then on : nothing, just black screen, pressing volume up, down up and down along with power button doesn’t seem to do anything and the phone isn’t recognized by the computer. Adb and fastboot say no device/emulator found.

if anyone has a solution to unbrick it, I’d be very grateful.

Thanks a lot for reading!


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi Antoine, welcome to /e/ land.

I am so sorry to hear another story like this!

You are one of many waiting for a fix for this sort of problem on GS290. Here is a search I did just now.

Your phone is only half-bricked. It will be possible to recover it. I hope that you will stay hopeful as you read the other links revealed in my search above.

I know that people are working on documenting a solution. Perhaps it will arrive soon. :slightly_smiling_face:

Bon chance

Thank you very much for your help! Good to know that there might be a solution. I’ll try again soon and will let you know if there are any improvements :slight_smile:


Hi Iain,

I tried unbricking my GS290 with SP Flash Tool and followed excatly the steps stated in this procedure (plus unticked the preloader

It said the download was successful but unfortunately, the phone still won’t start. Screen is black and it doesn’t react to pressing power and volume buttons.

Here is the code if it is of any help to understand the problem

QGtkStyle was unable to detect the current GTK+ theme.
QObject::moveToThread: Cannot move objects with a parent
support_dl_cert_to_storage: 0
Connecting to BROM...
Scanning USB port...
Search usb, timeout set as 3600000 ms






vid is 0e8d

device vid = 0e8d

pid is 2000

device pid = 2000

com portName is: /dev/ttyACM0

Total wait time = -1628241407.000000
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
USB port detected: /dev/ttyACM0
BROM connected
Downloading & Connecting to DA...
connect DA end stage: 2, enable DRAM in 1st DA: 0
DA Connected
executing DADownloadAll...
[4] WRITE TO PARTITION [ recovery ]

[16] WRITE TO PARTITION [ md1img ]

[17] WRITE TO PARTITION [ md1dsp ]

[18] WRITE TO PARTITION [ spmfw ]

[19] WRITE TO PARTITION [ sspm_1 ]

[20] WRITE TO PARTITION [ sspm_2 ]



[26] WRITE TO PARTITION [ boot ]

[27] WRITE TO PARTITION [ logo ]

[28] WRITE TO PARTITION [ dtbo ]

[29] WRITE TO PARTITION [ tee1 ]

[30] WRITE TO PARTITION [ tee2 ]

[31] WRITE TO PARTITION [ vendor ]

[32] WRITE TO PARTITION [ system ]

[33] WRITE TO PARTITION [ cache ]

[34] WRITE TO PARTITION [ userdata ]

download speed: 38.86MB/s.
Download Succeeded.

Do yo have any idea what went wrong?

Thanks again!


Thank you for this report, Antoine, and sorry it did not work for you.

On the face of it you did very similar to the report by @smu44 (this month’s GS290 heroic white knight) in this post.

/e/ installé avec easy installer sur GS290... le téléphone ne démarre plus - #17 by smu44.

I would first look there for any possibility you took a wrong turn. I am sure you read the hazards of using SP Flash Tool incorrectly.

Bon chance

Edit on reflection, @anto you do not mention the charge status of your phone. This can be a difficulty at this point. It is important to have full or near full charge before attempting any rescue.

1 Like

Yes I tried flashing the stock ROM using SP flash tool, on both ubuntu and windows 10, and none of them worked. The phone was fully charged and I tried with a bunch of different cables. Unfortunately I don’t have access to a windows 7 machine and I’m guessing using Windows 7 on a VM wouldn’t change anything. I also tried contacting Gigaset but they’re clueless.

So after many hours spent trying to unbrick my brand new GS290, I’m quite disappointed to have to buy another phone.

And as I’ve read so many threads of people bricking their gs290, I’m thinking it could be a good idea to have more explicit warnings about installing /e/ on it. That could save some money to users having to buy another phone after bricking theirs, but mostly prevent many machines from being unusable after a failed installation.

Anyway, thank you very much Iain for your precious help!


1 Like

Hi @anto ,

If you are located in E.U., I can propose you to try to unbrick your phone (no guarantee of success).
Please contact me privately.


Quick update to say that my GS290 is unbricked :smile: Huge thanks to @smu44 for his expertise on the matter and for taking the time and the energy to help me out. My phone now works perfectly on /e/ OS 0.17, apart from a few account synchro bugs and some wifi issues but nothing major! I’m really happy with it and can only recommend the /e/ os of the GS290. I’m just hoping no more phones will be half-bricked in the process so that @smu44 doesn’t have to help the whole of Europe unbricking their phones.

Apart from that, having tried SP Flash Tool with Ubuntu 20.04 and Windows 10, multiple USB-C cables and with the battery charged, Windows 7 seems indeed to be the best solution!

Thanks again for helping me everyone, from a happy /e/ user!


You’re very welcome :smile_cat:

Enjoy your /e/ GS290 !

1 Like

Hi, @smu44. It seems like I have very similar problem, is there any chance you can help me out too?

Wow, was able to revive it after some charging.
Still had fully black screen, but pressing both power + volume down allowed it to start flashing.

After that it was able to boot :cool:

Thanks everyone :slight_smile:

BTW, for the record:
This was on ubuntu, through parallels VM. So if someone would be stuck on mac - it’s still possible to recover it without windows.

1 Like

Congratulations, you managed to get it back to life yourself ! :clap: