Boot_a not getting flashed on OnePlus 9 (LE2115)

I have a One Plus 9 and I tried installing /e following these instructions. After I flash the recovery I always end up in boot_b instead of boot_a. If I go ahead and install /e, after the reboot it dumps me into fastboot menu and I cant get out of that until I set active slot as boot_b.

fastboot --set-active=b

What am I missing?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Not sure what’s going on there, but you shouldn’t be concerned about which slot to install to. Sideloading from recovery will always install to the other slot.

what os and version are you installing from and what eos version trying to install?

I’m Installing from Pop!_OS 22.04 LTS and installing e/ OS version 1.4 downloaded from here: /e/ image ROM download

I am unfamiliar with the the boot a/b architecture and how that works but I’ll take your word for it!

I didn’t frame my question very well! I meant to ask what os was on device before starting? OOS 11? Or something else?

I’m not sure, I think it was 11 but can’t remember for sure. I already wiped it, is there still a way to tell? I remember tapping on the OS version came up with a clock, does that identify the version?

I don’t know, but it should have been on 11 to install this version of e.
It sounds like (from your original post) that after you have installed eos and reboot it is not starting the os; just going to fastboot mode instead?

If that is the case, more info about the steps you have taken would be required in order to troubleshoot.

Yes that is where I end up. The steps are as follows:

  1. unlocked the boot loader
fastboot oem unlock
  1. Flashed recovery
fastboot flash boot recovery-e-1.4-r-20220923220394-dev-lemonade.img
  1. Rebooted to recovery (defaults to slot_b)
  2. Ran the Copy partitions command
adb sideload

At this step it says this at the beginning:

But ends with [OK]

  1. Factory reset. Output:
--Wiping data...
E:Open failed: /metedata/ota: No such file or directory
Formatting /data...
Formatting /metadata...
Data wipe complete.
  1. Flashed /e
adb sideload

Terminal says this:

adb sideload
Total xfer: 1.00x

Phone says this:

Now send the package the package you want to apply
to the device with "adb sideload <filename>"...
Supported API: 3
Finding update package...
Verifying update package...
Update package verification took 66.4 s (result 0).
Installing update...
E:Logical partitions are mapped. Please reboot recovery before installing and OTA update.

install completed with status 1.
Installation aborted.
  1. Reboot to recovery
  2. Apply update 2nd time
    Terminal says:
adb sideload
serving: ''  (~47%)    adb: failed to read command: Success

Phone says:

Now send the package the package you want to apply
to the device with "adb sideload <filename>"...
Supported API: 3
Finding update package...
Verifying update package...
Update package verification took 63.5 s (result 0).
Installing update...
Step 1/2
Step 2/2

install completed with status 0.
  1. Reboot phone
  2. dumps me right to fastboot.

Anything else I should mention?

Try booting recovery (phone un plugged)-> factory reset → reboot sytem

Interesting, now it hangs for about 20 seconds before going into fastboot mode.

I’m looking at your OP and trying to understand what was happening when you manually changed slots. You say it got you out of fastboot mode. How exactly? Where did you get out to?

Are you still doing this?

I think this may be at teh root of the problem somehow

Have you flashed the phone again since the screenshot you posted above?

When ever I would boot for the first time after installing /e, I would end up in fastboot mode and no matter what option I selected; START, Restart bootloader, Recovery mode, Show barcode, or Power off, I would go back to fastboot. I would then run the command fastboot --set-active=b from my laptop and then select Recovery mode.

I was thinking that was the only way to get out of fastboot but I was wrong, I can now select Recovery mode and get back to recovery.

I have not set the active slot since the last flash. And the last flash was that when I took that picture to answer your 2nd question.

OK, hang on , let me think…I have to go soon.

Can we try something step by step?
Power off the unplugged phone. Manually boot recovery by hold vol down and power (release poower when device turns on but keep holding vol down until in recovery. What slot is recovery on now?

Sorry, wrong instruction. Hold vol up and power!!

I still get dumped into fastboot.

And if you select recovery now, what slot is it on?

I’m still in slot b.

So you are in recovery , active slot b? Just to be clear. And there is little green dot with R on it to the left of the e logo?

I don’t want to suggest anything at the moment. There’s more to try but I’m getting worried about getting locked out of the phone if too many things go wrong and I don’t know how much experience you’ve had with that sort of thing on this phone.

Yep slot b and the green dot with an R is there. I have little to no experience with one plus so I understand your hesitation. Is there any way of looking at the logs while its trying to boot?