(bootloader) is-logical:recovery: not found after executing 'fastboot flash recovery e-2.1-r-20240606407290-dev-cedric.img'

I’m attempting to install /e/OS on a Motorola Moto (Cedric) upgraded to Android 8.1.

Executing ‘adb reboot bootloader’ boots the phone to the AP Fastboot Flash Mode (Secure) screen and ‘fastboot devices’ displays Motorolo Fastboot Interface. But ‘fastboot flash recovery e-2.1-r-20240606407290-dev-cedric.img’ produces the following:

(bootloader) is-logical:recovery: not found
(bootloader) is-logical:recovery: not found
Sending 'recovery' (11970 KB)                      OKAY [  0.377s]
Writing 'recovery'                                 (bootloader) Image not signed or corrupt
OKAY [  0.433s]
Finished. Total time: 1.275s

What does ‘is-logical:recovery: not found’ mean?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

I don’t know what it mean, but what I can tell is that it is not a problem :slight_smile: ^^

1 Like

/e/OS doesn’t install.

I might see the problem. I was following the documentation at Install /e/OS on a Motorola Moto G5 - “cedric”. Unless I’m just flat-out missing it there’s no mention of allowing “Non Vendor OS.”

How do I do that?

I should have been clearer in my earlier post. Step 2 seems to be covered by unlocking the phone and allowing USB debugging, which I’ve done. Is there anything else?

is not quite right (unless you renamed your recovery.img).

If your downloaded e-Recovery is named: recovery-e-2.1-r-20240606407290-dev-cedric.img

then the command indicated fastboot flash recovery recoveryfilename.img


fastboot flash recovery recovery-e-2.1-r-20240606407290-dev-cedric.img

You’re correct and I appreciate your attentiveness. However, I executed the command using recovery+[Tab] so it was correct. I made the error in typing the post.

Perhaps I should go back to square one with this problem. What does the recoveryfilename.img do? The documentation tells me to enter recovery using [volumedown Power] after flashing. I assume ‘enter recovery’ means RECOVERY MODE Unfortunately, after flashing the img file I receive ‘No command’ and can’t enter RECOVERY MODE. I can access RECOVERY MODE prior to flashing the img.

The next step in the instruction refers to the /e/OS Recovery Main Screen but the documentation lacks images.

e-Recovery (provided by e-Recoveryfilename.img) provides a simplified Custom recovery, it is a small and flexible utility useful for installation, updates and upgrades. The original Android recovery is particularly limited. TWRP (another more expert Custom recovery) is also capable of backup and other advanced tasks.

Replacing Android recovery as you are doing now has the effect of breaking the original so that the /e/OS “main download” ROM can subsequently be loaded (in the case of cedric) by means of

adb sideload downloaded_e-ROM_file_name.zip

Once you run

fastboot flash recovery recovery-e-2.1-r-20240606407290-dev-cedric.img

and get an OK response you still have to boot into your new recovery successfully (not always dead easy, it may take a few attempts!) … do not allow a normal shutdown / reboot cycle or else your new custom recovery will be overwritten and the phone will boot to Android recovery and e-Recovery will be permanently lost and you must flash it again.

From Info about Motorola Moto G5 - cedric we see to reach Recovery from Powered off with Volume Down + Power, then select “Recovery mode” using Volume keys.

However the trick (I am not certain of it for your phone) is to kill Fastboot back to a black screen immediately before hitting the above keys thus you interrupt a normal full reboot cycle.

  • (Aside, on a Samsung the technique is especially awkward and mentioned here.)

e-Recovery, set up to Apply update, by means of adb.


Perhaps check again that debugging is active and definitely authorised every time from your PC.


1 Like

Your reply considerably clarifies things - thank you. I made a change and no longer receive ‘No command.’ My steps and results are as follows:

Prior to ‘adb reboot bootloder’ I verify ‘adb devices’ displays a device.

‘adb reboot bootloader’ takes me to the fastboot screen.

‘fastboot devices’ displays Motorola Fastboot Interface.

‘fastboot flash recovery recovery-e-2.1-r-20240606407290-dev-cedric.img’ returns OKAY.

I next execute POWER OFF from the fastboot screen. Note: In prior attempts I powered the phone off with the power key. Apparently that change eliminated the ‘No command’ message.

[downvolumn power] takes me to the fastboot screen without the ‘No command’ message. However, choosing RECOVERY MODE takes me back to the fastboot screen. I don’t see the /e/OS Recovery screen. Trying five times produced the same result.

Is powering off via the fastboot option acceptable? The documentation states “With the device powered off” but doesn’t specify a method. What am I missing that I can’t see the /e/OS Recovery screen?

Sorry I don’t know your actual phone, but I wrote of the Samsung method which I linked, I can only repeat the critical advice not to allow a “normal” shutdown / reboot cycle, but that you try every possible permutation of button press to cause Recovery mode to start.

On my OnePlus for instance, Vol down + Power kills Fastboot, relax a moment as the screen goes black, then again quickly Vol down + Power to boot into Recovery.

So one would have to assume that e-Recovery was wiped or in some way not available. So you would have to flash the recovery image again before you retry (and try something different each time!) including of course direct use of the menu.

Everything is worth a try!

Edit I see that the Lineage page, Install LineageOS on cedric | LineageOS Wiki expresses it simply as

Now reboot into recovery to verify the installation.
Use the menu to navigate to and to select the Recovery option.

Success! I thought I should report this as it might help others.

I simply reverted to recovery-e-1.20-r-20240221382014-dev-cedric.img and things worked quite well. /e/OS is running on my phone.

Perhaps it’s irrelevant but the e-21 img is considerably smaller than the e-20. Where/how do I report the problem with recovery-e-2.1-r-20240606407290-dev-cedric.img?

Golly, another typo. I meant to type the e-2.1 img is considerably smaller than the e-1.20.

Before you Report an issue did you check the sha256sum of your download? Is it possible that your 2.1-r- image was corrupted during download; I just downloaded both, both reported same size and each reports correct sha256sum

sha256sum check
df4c6178eef8230bac26cbba9b5e5a664045b6d7664f08d62e0db94e8d25cb9a  recovery-e-2.0-r-20240509400072-dev-cedric.img

bfe95b11d2dec8114ee842b1563e6feced4b5b9a7be088a6d0777213bb3e0ac8  recovery-e-2.1-r-20240606407290-dev-cedric.img

:~/TEMP-cedric$ ls -al

12257280 Jul  3 20:20 recovery-e-2.0-r-20240509400072-dev-cedric.img
12257280 Jul  3 20:19 recovery-e-2.1-r-20240606407290-dev-cedric.img

:~/TEMP-cedric$ sha256sum recovery-e-2.0-r-20240509400072-dev-cedric.img 
df4c6178eef8230bac26cbba9b5e5a664045b6d7664f08d62e0db94e8d25cb9a  recovery-e-2.0-r-20240509400072-dev-cedric.img

:~/TEMP-cedric$ sha256sum recovery-e-2.1-r-20240606407290-dev-cedric.img 
bfe95b11d2dec8114ee842b1563e6feced4b5b9a7be088a6d0777213bb3e0ac8  recovery-e-2.1-r-20240606407290-dev-cedric.img

I didn’t verify the sha256sum but did download the e-2.1 file on two different days and did a diff that showed no difference. As an aside, I was going to report the img files lack of md5sum signatures. The zip files show md5sum and sha256 signatures.

I also show 12257280 for the e-2.1 but the e-1.20 shows 16056320.

I attempted to report this but receive “Email is not allowed for sign-up. Please use your regular email address. Check with your administrator.” when attempting to register. Huh? What am I doing wrong?

I should probably add that the sha256sum does hit for the e-2 img in question.

The report an issue link does include a mention of the “difficulty” in registering – please read on further in the link and ask helpdesk@e.email as explained.

cedric is now a MINIMAL_APPS build (a build flag), that would explain the size difference - Week 21 2024:Development and Testing Updates

1 Like