"Browser/Brave has stopped" download errors

Hi all,
First post.
I want to be an /e/ user but I’m facing an issue that’s been preventing me from becoming one so far. :stuck_out_tongue:

Phone: Samsung Galaxy S9 (starlte)
/e/ build: e-0.7-o-2019112632032-dev-starlte.zip

Not sure if it’s related to my main issue, but perhaps it’s worth starting with the note that after flashing /e/, right at the language choice config stage I’m getting “Calendar has stopped” error pop-up. Tapping dismisses it fine and I can finish the config with no further issues.

My main problem becomes apparent when I try and download files in browsers. During the download (can be right after the start or while it’s eg 50% in progres etc) the browser shuts donw and I’m getting “Browser has stopped - tap to reopen” error message plus a “Download error” notification. If I keep trying, I sometimes get “Browser keeps stopping” instead of “has stopped”. Downloads seems to be affected regardless of the browser I’m trying to use – I tried Browser, Brave and Firefox Klar. Non-browser downloads, eg in F-Droid, seem to work fine.

Googling :stuck_out_tongue: for a solution didn’t help. I wiped the device clean (SW-wise) and reinstalled, the same thing is happening. The issue does not occur when I install regular LOS (unofficial, as S9 isn’t offiicially supported anymore). Now I installed /e/ again to make sure that Download, Download Manager and Media Storage have Unrestricted data permissions, they do.

Has anyone encountered this? Any advice on what else I can check/do before I’m forced to switch back to LOS and wait for an /e/ build that will work for me?


Hi, welcome in our community :slight_smile:

This issue with the Download Manager has already been reported here, and will be fixed in the next update or the next one.

The solution is the use of another webrowser, like Firefox that doesn’t use the built in download manager. Sorry for the inconvenience.

1 Like

I installed FF now and I can confirm it’s working – thanks!

Here some thoughts about Brave browser. Why not Firefox as default browser

Brave is webkit, has nothing to do with Mozilla or Firefox. The issue with Brave-browser is that G00gl sneaks back in, and after that Brave can’t delete it’s history automatically anymore (the first symptom you’ll notice). Shortly after that it has update problems, it always wants to contact G00gl goolag to update. This happens in Linux and in Windows, on mobiles I never tried Brave. Brave browser was a nice try to create a privacy friendly webkit browser, but it failed. It will always fail on any Chromium-like browser. That’s why I only use Mozilla Firefox for default browser on mobile and on desktop.

1 Like

I can confirm that after today’s update I could download files with Brave fine – I’m assuming without further testing that the download issue has been fixed. Cheers.

Yes the 20191212 update solved it.

1 Like
  1. From which unofficial LOS version did you switch to /e/ build e-0.7-o-2019?

  2. When you first switched to LineageOS, which StockROM Android version was installed on your Galaxy S9 (starlte)?