Bypass the "Cannot load Android system" error without losing personal data?

I looked to find the solution here, but I am not sure what the cause of the crash was and this seems to be important in the solution, as I understood it. Also, the last posting I found was from 2020 so maybe there is a better solution without losing data now…

Also I very much need to rescue my data: I have an important interview recording on the phone which I was planning to save on my computer when the crash occured:

I was on a train and using the open wifi (maybe that was the problem?) when suddenly the phone shut down. When I tried to boot it again, the Fairphone-Screen came on immediately, but the point under the /e/ was very slow and irregular. It came on and off, and after a while a screen appeared that said “Cannot load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device.” My options were “Try again,” which took me to the same screen, and " Factory data reset."

I tried to find a solution online to save my data as it is very important that I keep the photos I took of the interviewpartner and the interview itself. I am angry with myself that I did not make saving the files on my computer a priority before I went online.

Does anyone have an idea or something I might try? I am not very comfortable with the technology, but I have found the recovery-menue and was wondering if and how to use ADB-sideload - I understood that this allowes to connect my computer to my phone in recovery mode. But is this worth trying? Or is it better (and data-safe) to use “Apply update” from the recovery menue?

Help is very much appreciated! Thanks in advance!
All best

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

If your recovery is TWRP or OrangeFox AND you can access /sdcard using their integrated file browser (either phone isn’t encrypted, or you succeeded decrypting within recovery), then you may try to activate MTP and copy files to a computer using USB.

In TWRP the MTP is usually in Mount screen, for some models you may have to activate twice, or deactivate/activate.

Don’t know about /e/ or Murena Recovery :frowning:

Don’t know much either about Fairphones, as I could understand they may missing an installed recovery, but you may temporary boot it from your computer: Fairphone 3

If your Data partition (not to be confused with your data : Data is for system & apps private storage), a “dirty flash” (just overwriting the OS) may not be enough.
You may have to perform a complete reset of your device including formatting Data partition, and restart the installation process fro scratch (see doc for your device).

Best of luck!

1 Like

Over simplified, sideload will only really allow the PC to add to the device. (Think of sideload as adding something alongside.)

Some of the ways you can interact with the device using adb are in this manual In your situation it may be impossible to make contact, I don’t know, but do not hesitate to ask again.

Good luck

1 Like

Thank you both so much! As I am a little insecure about the risks and lost data last time I tried, I decided today to invest in professional help - I really need those audiofiles I did not secure…

If they tell me what helped and I understand it, I will post it here to help others.
All best and have a lovely weekend - I am very grateful you took the time to respond and I will try and understand the procedures you described.


Hey, the data security guys said they looked at the platine but could not find a way to access the phone data. I don’t think they are experienced enough, because they did not know e/os.

Does anyone live in Berlin and would be willing to take a look - I would be willing to pay for this, of course? Or is there some place you can recommend that rescues data and is specialized in this?

All best & thanks

If you would be certain you saved the data in question on an SD card in the phone formatted as external/portable storage, you could take the card out of the phone and read it with a card reader on a computer.
If you are not certain about this, don’t start to experiment.

Which Fairphone are we talking about? 2? 3? 3+? 4?

You could try “Try again” more than one time.

That’s something, but will not help without proper expertise.

If this is about a Fairphone 3, this is only possible with an unlocked bootloader, which would not be the default state, and not a very common state of things on this phone.

This is the correct decision in this situation. I didn’t have to deal with something like this yet, so I have no recommendation on a company.

Just search the internet for “Datenrettung” in Berlin and contact candidates of your liking with the following info …

  • Phone model
  • You are running the LineageOS-based Android custom ROM called /e/OS.
  • You are stuck in the well-known Android “Cannot load Android system. Your data may be corrupt." - “Try again” / “Factory data reset” screen
  • Recovery mode works and most probably can give an ADB shell *
  • You need your user data.

(* At least it does on my Fairphone 3 with /e/OS recovery v1.2, but I don’t know how to safely proceed from there, as user data on the Fairphone 3 is encrypted.)

1 Like

I think it is significant … how did you make this recording?

Did you expect to find it in your “Home” folder or on your SD card …

or was it made with a proprietary app?

1 Like

the data is not stored on the SD card, I already took it out and checked.
I tried “Try again” about twenty times. It’s a Fairphone 3+
I don’t know how to boot it from my computer, unfortunately.
And I am not sure the bootloader is unlocked, I would have had to set it to that in advance which I didn’t, I’m afraid.
The company I looked up on the internet took out the platine and they say they don’t know what to do. On the phone they told me they know FP, also that they know e/os. Now it turns out they didn’t. That’s why I asked for a recommendation…

It is not on the SD card, I’m afraid. I made it with an app that came with e/os.

Thanks for taking an interest and replying, you guys. I am sure I tried everything I can, though, and I am looking to find professional help now - but I was hoping someone could point out a company that they can recommend as I didn’t get a result with the one I pulled from the big magic hat that is called Internet :wink:

Berlin has an active Fairphone Angel (community volunteer trying to help users), see 👼 The Fairphone Angels Program and Map (Local support by community members) - Local - Fairphone Community Forum.
You could ask whether they perhaps happened to come across a company to recommend.

1 Like

Thank you! That is very helpful, I just wrote to them. :)))

No reply yet. In the meantime I got my phone back from the data rescue guys. They said they took out the platine and rebooted the phone from a computer. Now it asks me to set up the system again (it is still the e/os-system but I have to fill in again which language it is and so on). The guy at the desk said that might mean it went back to Factory data reset. But he said the data still might exist on another fraction of the drive.

If the data is still there is it safe to give it a try and follow the instructions and set it up again? What do you recommend I do?

I connected it to the computer and it recognizes the phone but it says the file is empty.
I guess that is because it is not set up yet and I cannot allow access because the phone is not set up yet. (Usually a number appears and I have to use it for the computer to be able to see what’s on the phone.)

Help please… I am a little heartbroken now because I think they made a mistake and won’t admit it, to be honest.

All best,

That’s a clear indication of a factory reset.
The initial setup is presented again after a factory reset because the user data is gone.

An Android factory reset doesn’t touch the installed OS, despite the name. It mainly deletes user data as well as Apps installed by the user and their data.

I would be very interested in how he would like to back this claim with some source.
That could get really interesting, technically.

While the Fairphone 3/3+ is a so-called A/B device, which holds two instances of an installed OS (to be able to install updates in the background while the user still uses the phone), the user data partition is shared, there’s no copy of it.

If with your order you clearly gave them the priority to rescue the data and not for the phone to boot again (which the factory reset most likely would solve), I think so, too.
It really looks like they did the one thing they should not have done under any circumstance.

Got a lawyer? Like before, I have no recommendation.

Nevertheless you could contact professional data rescue services to make sure whether anything could be done, adding to your inquiry that most likely somebody did a factory reset.

1 Like

My sympathies that your data professional has been a disappointment.

Please be aware that I do not have experience of Fairphone or locked bootloaders.

I do not want to give false hope but when I make a recording with Recorder the recording is the found in “internal storage” > Music > Sound records.

Without a locked bootloader the action performed by Settings > System > Advanced > Reset options > Erase all data

will indeed wipe all data within your apps, for instance your browsing history and bookmarks will be gone but it does not wipe the product of apps like Camera and Recorder; this product has been saved to “internal storage”. (Stuff in “internal storage” is different from data!)

With a locked bootloader we expect the phone to be completely wiped if attempts are made to unlock the bootloader.

Did the proposed factory data reset necessarily erase “internal storage”? In answer, one would have to say “you should always have a backup”, but the question is asked here, but note the subject of the question is not “unlock bootloader”.

I suggest he is referring to “internal storage”.

I would recommend trying to get someone to continue to help you investigate the chances of collecting your recording(s). Even remote help, cautiously, step by step, might work if you are brave.

Maybe his actions have wiped your internal storage but I do not believe this is certain.

  • (If it is the case that a locked bootloader precludes Erase all data, then my optimism is misplaced, sorry in advance!)

Did you confirm this? That “erase all data” would leave Internal Storage alone sounds like a bug. Note that the XDA topic is from 2013.
I’ve seen myself that a “wipe” instead of a “format” of the data partition may leave the directory structure intact, but would delete all files in the directories.

What do you mean?
A factory reset wipes the data and the cache partition (or might format them, depending on how Android or the Android stock recovery or TWRP handle this).
The Internal Storage is a part of the data partition. Usually if the data partition is /data, the Internal Storage is /data/media, as far as I understand so far.

1 Like

(Apologies in advance to the OP if I am wrong for Fairphone) but in my experience … this from my Samsung A3 (2016)

$ ./adb shell
a3xeltexx:/ $ ls


cd storage
a3xeltexx:/storage $ ls

… there are “Android” links which make for added confusion … but in the above trace

sdcard = ~ “internal storage”
data = data
storage/809B-16F1 = My SD card

I have to say I was surprised the first time I did Factory reset (from TWRP in fact) and all my photos remained …

Later Edit. I had hesitated to edit this post while opening post error was unresolved.

In fact all my experience has been with TWRP where stuff in “internal storage” can be preserved.

These two pages demomonstrate the behaviour I expect using TWRP recovery.

The action by Settings > System > Reset options > Erase all data in /e/ Android 10 is clear in giving this description:

Apologies for creating uncertainty.


I guess looking into your “data” folder this way would give you permission denied, do you have Rooted debugging in your Developer options? With this enabled … (I will shorten the output a bit with […]) …

>adb shell
FP3:/ # ls
FP3:/ # cd data
FP3:/data # ls
FP3:/data # cd media
FP3:/data/media # ls
FP3:/data/media # cd 0
FP3:/data/media/0 # ls
XAPK\ Installer-release

If you want to see something interesting, then do ls -la instead of ls … this time with a non-rooted ADB shell like yours …

FP3:/ $ ls -la sdcard
lrw-r--r-- 1 root root 21 2009-01-01 01:00 sdcard -> /storage/self/primary

FP3:/ $ ls -la /storage/self/primary
lrwxrwxrwx 1 root root 19 1972-06-13 23:47 /storage/self/primary -> /mnt/user/0/primary

FP3:/ $ ls -la /mnt/user/0/primary
lrwxrwxrwx 1 root root 19 2022-08-24 21:18 /mnt/user/0/primary -> /storage/emulated/0

FP3:/ $ ls -la /storage/emulated/0
total 28884
drwxrwx--x 20 root sdcard_rw     4096 2022-01-10 22:06 .
drwx--x--x  4 root sdcard_rw     4096 2022-08-24 21:18 ..
drwxrwx--x  2 root sdcard_rw     4096 2020-11-15 18:31 Alarms
drwxrwx--x  4 root sdcard_rw     4096 2021-08-24 22:57 Android
drwxrwx--x  2 root sdcard_rw     4096 2020-11-15 19:21 Aurora
drwxrwx--x  5 root sdcard_rw     4096 2020-12-03 11:01 DCIM
drwxrwx--x  3 root sdcard_rw     4096 2020-11-15 19:22 Documents
drwxrwx--x  2 root sdcard_rw     4096 2022-08-19 22:47 Download
drwxrwx--x  3 root sdcard_rw     4096 2021-01-01 22:57 Movies
drwxrwx--x  2 root sdcard_rw     4096 2020-11-10 19:49 Music
drwxrwx--x  2 root sdcard_rw     4096 2020-11-10 19:49 Notifications
drwxrwx--x  4 root sdcard_rw     4096 2020-11-15 20:00 Pictures
drwxrwx--x  2 root sdcard_rw     4096 2020-11-15 19:23 PlantNet
drwxrwx--x  2 root sdcard_rw     4096 2020-11-10 19:49 Podcasts
drwxrwx--x  3 root sdcard_rw     4096 2020-11-15 19:23 QKSMS
drwxrwx--x  2 root sdcard_rw     4096 2020-11-15 18:34 Ringtones
drwxrwx--x  2 root sdcard_rw     4096 2020-11-15 19:23 TWRP
drwxrwx--x  3 root sdcard_rw     4096 2020-11-15 22:42 XAPK\ Installer-release
drwxrwx--x  2 root sdcard_rw     4096 2022-02-03 23:37 osmdroid
drwxrwx--x  3 root sdcard_rw     4096 2020-11-15 19:23 tesseract

There are more ways than one to Internal Storage. To compare again with rooted ADB shell …

FP3:/ # ls -la /data/media/0
total 28884
drwxrwx--- 20 media_rw media_rw     4096 2022-01-10 22:06 .
drwxrwx---  4 media_rw media_rw     4096 2022-08-24 21:18 ..
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-15 18:31 Alarms
drwxrwxr-x  4 media_rw media_rw     4096 2021-08-24 22:57 Android
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-15 19:21 Aurora
drwxrwxr-x  5 media_rw media_rw     4096 2020-12-03 11:01 DCIM
drwxrwxr-x  3 media_rw media_rw     4096 2020-11-15 19:22 Documents
drwxrwxr-x  2 media_rw media_rw     4096 2022-08-19 22:47 Download
drwxrwxr-x  3 media_rw media_rw     4096 2021-01-01 22:57 Movies
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-10 19:49 Music
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-10 19:49 Notifications
drwxrwxr-x  4 media_rw media_rw     4096 2020-11-15 20:00 Pictures
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-15 19:23 PlantNet
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-10 19:49 Podcasts
drwxrwxr-x  3 media_rw media_rw     4096 2020-11-15 19:23 QKSMS
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-15 18:34 Ringtones
drwxrwxr-x  2 media_rw media_rw     4096 2020-11-15 19:23 TWRP
drwxrwxr-x  3 media_rw media_rw     4096 2020-11-15 22:42 XAPK\ Installer-release
drwxrwxr-x  2 media_rw media_rw     4096 2022-02-03 23:37 osmdroid
drwxrwxr-x  3 media_rw media_rw     4096 2020-11-15 19:23 tesseract

A search hit I quickly grabbed from the internet explaining how this is the same … What is /storage/emulated/0/? - Android Enthusiasts Stack Exchange.

1 Like

Indeed I do not dispute your traces. Your Android Enthusiasts link draws attention to symlinks. To try to highlight symlinks one might also check with ls -Lal (ref The Open Group Base Specifications) but I am sorry I cannot provide any theoretical help on how Android behaves with these links.

To try to keep this a bit practical I think it is correct to say that if you delete a folder containing symlinks, you do not delete the “linked item”.

Edit, I am trying not to over generalise, we do not always know what sort of delete or format another person is making. Format data clearly does a specific job!

If one identifies a way to literally “Reset factory data” I do not expect the data partition to finish unpopulated, but to contain an “original” version of partition with symlinks provided if they were there in the original.

1 Like

Dear both,

thank you for your sympathy and the good intentions. I still can’t believe they did this… They reacted quite defensive, and I am still thinking about getting a lawyer at the same time knowing the data is probably gone anyway. And putting time and energy in just getting a few Euro back (minus the money the legal advice is going to cost) just doesn’t seem worth the energy I have to muster …

I haven’t heard from the Fairphone angel and I have put this aside for the minute, having to hand in some urgent work project next week.

As I am no specialist, I have had problems following your discussion, and also, I am quite defeated…

I wish you both the best - if some help comes up in Berlin, I will let you know.
Thanks for being so helpful and well-meaning!
Yours, Anne

1 Like