Camera and rotation hangs terribly on Teracube 2e - suggestions?

Hey, folks.

I know the Teracube 2e specs aren’t great, but /e/ seems to be causing some show-stopper use-cases with the camera and rotation features. For example, switching to rotation mode/landscape using the maps app will cause a ~60 sec hang. But worse is simply turning on the camera. Usually it just hangs for ~60 sec, but sometimes it goes for 2+ minutes and I have to reboot the phone.

Really love /e/ on the Teracube 2e, but hangs like this are show-stoppers for a daily driver IMO. Any suggestions?

/e/ build number e_2e-userdebug 10 QQ3A.2000805.001 eng.root.20210623.092031, stable-release

(should probably have more readable build numbers, too)

thanks

1 Like

Hi @yekibud welcome to the /e/ forum. Work is ongoing on the Camera. Perhaps try Simple Camera available in Apps, it may work quite well. :slight_smile:

Hi, @aibd. Thanks for your reply. I tried Simple Camera - which seems to help with the camera rotation consistently hanging the phone - but I still get long hang/reboot situations from rotation (such as putting the map app in landscape mode when I’m about to start a trip).

Hi @yekibud. Try FreeDCam and see if that helps.

If you are finding that you can isolate the camera issue from a more general severe rotation issue across the device, it would probably be a good idea to Report an issue.

should probably have more readable build numbers, too

If needed, you can collect your build number or /e/ version like this.

Settings > About phone > long press on Build number > copy to clipboard.

Settings > About phone > tap Android version > long press on /e/ version > copy to clipboard.

:slight_smile:
Getting Started on /e/

1 Like

@aibd’s suggestion to use SimpleCamera already seems to have solved the camera issue, but rotation is still a problem.

Yes, I can confirm use of SimpleCamera now now longer hangs the device, but general rotation is still a problem. I just switched enabled rotation and attempted to switch to landscape mode to view an email, for example, and the phone became unresponsive and required reboot. When I rebooted, the same actions did not hang the phone - so maybe some sort of memory leak?

I tried to report the issue on the Gitlab tracker but it appears to require an e.email account to register.

it appears to require an e.email account

I don’t think that xxx@e.email is actually a requirement but Gitlab is a bit over-selective, I think due to previous misuse.

I would send an email to support@e.email telling them your login difficulty, I am sure it will be sorted.

e.email is not mandatory, for the gitlab account.
Best Regards,
Shenol

@Shenol Have you tried signing up with a non e.shop email? Because something is definitely filtering out my email (opensourceit.org):

You might consider performing an OTA system update. I’m on /e/ Q v20210827.151134 stable with no rotation issues as you’ve described. Hope that helps.

Actually, I’ve already upgraded to e_2e-userdebug 10 QQ3A.200805.001 eng.root.20210827.151134 dev-keys,stable-release since my original post - which unfortunately it looks like this forum software doesn’t let you edit/update - and I still have the issue.

I think at this point I may need to factory reset and slowly re-add apps to see if it’s an app issue - which is super tedious and will take forever, but I’m not sure what else to check.

Not all domains are accepted by default, but we can add you manually.

I confirm the issue with stock camera and something like memory bug or something else with Teracube 2e brand new out of the box and the stock camera freeze and hang hard this device I have to reboot it QQ3A.200805.001 from 20211215.132156

Something happens too with Magic Maps I got “insufficient memory” warning and have to restart the apps