Camera not working anymore on FP3 since migration to v1.0

I checked right after I updated and just re-checked and can’t confirm, camera works for me on 1.0-q-20220527189323-dev-FP3 (Settings - About phone - Android version (tap on it) - /e/ version).

Did you simply reboot or did you turn the phone off?
Over the years I experienced that it sometimes makes a difference to really turn the phone off and on again (but admittedly more with networking hiccups than with the camera).

I have the same issue with my fp3+ and v1.0.
To get the occpupied camera back I rebooted the phone.
Then I started Open Camera again and got only a black from the camera. So I closed the app and started it again and now it was normal. This worked just once and now I have this problem again.
The camera icon seems to show you that the camera is in use. To let you know that an app is using it, even when you not intend to.
Also the reboot is not working right. The screen stays black and I had to push the powerbutton till the screen comes back on.
It would be nice if someone knows how to get the camera free without reboot.
Right now I tested it again. Same problem. Had to reboot twice and now the camera works for now.

Have you tried to empty camera app cache and data?
(Settings > Apps and notifications > App info > Camera > Storage & cache)

BTW, camera app data is NOT the photos :wink:

8 Likes

I got some news.

I tried today again to take some photos, and it was working. So since I have another issue (which is described here Can't make a call using Signal or WhatsApp since migration to v1.0), I also tried to check if it was still the same.

So basically I still can’t make a call with SIgnal and/or WhatsApp, and I realised that my camera is not working after an unsuccesful call. It’s like if my failed call with SIgnal makes the camera module unavailable.

After restarting the phone, and as long as I don’t try to make another call, looks like there is no problem with the camera.

My camera issues are also gone.
I did what @urs_lesse said and also resetted the in open camera settings.
Thx for the advice.

2 Likes

My FP3+ camera behaves the same: Sitting icon in the upper right indicating camera use, yet the camera app isn’ t running.
Starting the camera results in error msg saying that the camera is used by another app though I closed it after taking a photo hours ago.
Cleared the cache to no avail.

So, it seems the camera app annonces the use of the physical camera but seems not to release it again by closing.

1 Like

Issue still persist for me too. Initially clearing cache and data worked but now opening camera from lock screen almost always displays black screen. Have to then unlock and close camera app before it will work from home screen again. No issues prior to v1.0

For me the same. I had no issues before upgrading to e/OS v1.0. I found this thread when looking for a solution.
It is a FP3+ and I’m using Open Camera and Signal. I can usually only take one photo, then OpenCamera will display black screen and I know no other way to restore it than rebooting the phone. Once I could restore it by changing to the front camara and back in the app.
Where would be the proper place (issue tracker) to file a bug?

The back/front change worked some time for me too, not anymore.

If I firstly open the camera it works fine, even for multiple pics.
Closing the camera app means that I have to reboot, if I want to use it again: The icon sits in the upper right corner, and opening it, it says that the camera is in use by the camera app (only one allowed), though all apps are closed.

Also I have unseen high battery usage - fully charged it twelve hours ago and am on 22% now…

We have a nice German word for this kind of “update”: Verschlimmbesserung (worse making improval).

I just discovered that this affects the QR-code reading also, as the camera is “occupied” and requires another reboot to get to work…

Just a thought @mungo have you checked if Camera is using location permissions. My sense on a3xelte-r is that a small memory leak is being triggered by Advanced privacy. I am also thinking that Maps is inducing some sort of crossover link with Camera, Maps can ask permission for Camera. In my case if feels conceivable that even “asking for permission” might not be resolving nicely.

I find these things crop up “in general use” but difficult to reproduce after “close all running apps”.

All quite difficult to reproduce. I hope to open a gitlab issue soon.

For your information there is an issue here Camera not working after 1.0 update (#5555) · Issues · e / Backlog · GitLab

The camera app sure uses location permissions - if they are granted.
Which they are not on my phone, as well as for maps/Magic Earth.

To me it is futile to think about possible internal communication inside of my phone as I am not a programmer but a user (and in this case sometimes a WAU, turning out to be a real good bug finder…).

As the git-issue is already opened by @shenol I am contributing there.

Related?

 

I had the exact same problem. And @urs_lesse’s advice seems to have solved it :tada:

Have you tried to empty camera app cache and data?
(Settings > Apps and notifications > App info > Camera > Storage & cache)

3 Likes

For now it seems to work for me @urs_lesse (v1.0 FP3+)

Big thanks if it continues!

Have you tried to empty camera app cache and data?
(Settings > Apps and notifications > App info > Camera > Storage & cache)

2 Likes

I have the same problem here on my FP3+.

Emptying camera app cache and storage resulted in nothing, except all pictures and videos in Gallery are now black (unreadable on the phone).

Either only the camera app goes dead, or the whole system dies (black screen, no reaction to power button, I then have to take out the battery to restart my phone).

This is quite annoying.

Anyway, the app “vigilante” keeps showing the camera active sign, even if the camera app is forced to close (which apparently does not work).

This bug happens randomly, mostly when I try to use the camera directly (with the preinstalled /e/-app) or from within WhatsApp (which I am forced to use). I didn’t face this issue within Signal or Telegram.

The camera bug happens in my main Shelter profile and in my Shelter work profile (for WhatsApp).

I now update /e/ from 1.0-20220526188859 to the newest version and hope this is going to solve the issue.

Last Update helps :slight_smile: Very Thanks :hugs:

I support boospys information. Had some major problems with the camera as well, but after the e/OP update these days, everything went away and the camera is working fine and as expected.

Also after update camera app not working. I have installed open camera app - this is working.