Cameras not working

Hi everyone, I’m new to smartphones and got a new FP3 just a few weeks ago. Installed /e/ on it following the instructions on the website + latest update and everything worked fine for some time now. But a few days ago, both cameras (rear/front) have stopped working. They seem to be just gone from the system. I get a black screen with an error massage when opening the the open camera app (see attached) and cant even select between front and rear camera. Even the flashlight icon is greyed out. I tried all the standard procedures described on the fairphone support page (clearing camera app cache & storage, rebooting to safe mode), but nothing changed. I also tried several alternative camera apps, but same result. In Jitsi, at least the microphone works. It seems a bit strange to me that both cameras are gone. Its a brand new phone, so there should be no reason for a hardware problem. Thx for any advice.

Hi, welcome in the community :slight_smile:

Did the issue show up after an update ?

If you don’t find any solution, you can report the issue on our gitlab with some logs attached. (Reboot your device, open the camera and create the log file.)

Hi @fzwin which build of the /e/ FP3 are you using.
Strange not seen any other FP3 user on the forum raise such a complain about both the cameras failing.

Hi, thx for your replies.
@Manoj, I’m using /e/ on 0.9-2020061158052-dev build, last updated it on 06/11/2020 from 0.9-2020051454091-dev build.
@Anonyme, I’m not entirely certain, if the problem showed up after the update. Not directly, I guess. I haven’t used the camera very often lately, but the problem first occured on 06/14/2020 and I did a sucessful Jitsi video call with the device on 06/11/2020 after the update.

I’d like to mention one more thing, because I don’t know, if this might have something to do with the camera issue: I encounterd several black screens during phone calls, which left the whole device dead. I could only make my FP restart after taking the battery off, putting it back in and then pushing on/off button. That occurred three times on 06/12 and 06/13/2020. Since then, it hasn’t occurred again .

My guess is this is a hardware issue. If it was a problem with the Software it should have showed up across all FP3 users . You can raise a bug in Gitlab with logs generated after a camera crash. I can ask the developers to have a look at the logs. Alternately you can also try flashing the stock FP3 ROM to check if the issue occurs in that as well.

Hi @Manoj, I thought about that as well, but it is strange to me that both cameras stopped working at the same time. In my eyes, that looks more like a software issue.
OK, will go to github and share my log.

Hi, I have the same problem with my camera on FP4.

This only happens when I want to make a video. It crashes, but some buttons are still working, but no video was recorded. And I have to restart the app.

What exactly does it say in Settings - About phone - Android version (tap on it) - /e/ OS version (can be long-tapped and copied to clipboard since Android 10)?

My /e/OS version is.
But the issue came up with the previous version aswel.
I did not know about the versions, until I was looking for a fix for this. So the previous version was from dec 2021.

The issue comes up when I start recording, so I was playing, some settings, and I saw that, for some reason the recording speed was set to 0.5x. So I set it to normal, then the issue did not occur. Then I tested with other recording speed settings, and only the setting 0.5x generates the issue. So, not that big of an issue for me right now, but still, somethings is wrong.