Can’t find 'Keep Read Only' with Galaxy S9 (with Easy Installer)

In Easy Installer at Installation [step 3] the guide says “Tap on ‘Keep Read Only’”, but I cannot get a screen on my phone where would read ‘Keep Read Only’.

I guess that would be something to do with TWRP. I end up from the blue (turquoise colour) downloading screen to the standard Android recovery screen. I doubt that the option ‘Apply update from ADB’ could do the same.

My device:

Samsung Galaxy S9 SM-G960F
One UI version 2.5
Android version 10

Windows 10
Easy Installer – v0.12.0-beta

What I did different than Easy Installer guided, but assumed to be the same:

At Enable the Developer mode (Part 2)
USB debugging in stead of Android debugging

At Enable ‘USB file transfer’
‘Transferring files / Android Auto’ in stead of MTP mode

At Unlock OEM
When it says “enable ‘OEM unlock’” I switched it enabled in the Developer options and accepted Factory Reset.
next step says: You’ll have to keep pressing “power” & “Bixby” & “Volume Down” until you reach “Download mode” once your device is off. When you’re ready, accept Factory Reset.
I do not know what this is for, but I assumed it was just an optional way to do the previous step: enable ‘OEM unlock’. So, I skipped it.

At Installation [step 3]
On PC a black window pops up, and it seems to do everything successfully, and close after complete. After that there still reads “Downloading…” in the phone, and doesn’t complete. I do not see any error message in phone either PC.

What I have tried At Installation [step 3]:

Easy Installer says:
“Keep pressing simultaneusly “Power” & “Bixby” & “Volume Down” until device turns off”

At the same point my phone says:
“Volume Down Key + Power Key for more than 7 secs: Cancel (reset phone)”

I tried with both, and both restarted the phone.

When the screen turned black from blue (turquoise colour), I immediately started hold volume up + bixby + power buttons. I tried several times to ensure to be super quick to change volume down key to volume up key. I also tried to start the second combination couple of seconds later, after Samsung logo and at standard Android recovery screen. All tries ended up to the standard Android recovery screen, where I cannot find ‘Keep Read Only’. After every try I started the Easy Installer from the beginning.

I also tried to reboot the PC, reinstall Easy Installer, and factory reset the phone, switching back and forth ‘USB debugging’ and ‘Unlock OEM’, and Wi-Fi internet connected and not.

I also tried to hold volume up & bixby & power keys at the blue (turquoise colour) downloading screen, but nothing happens.

Here are topics with somewhat similar issues with other phones:

/e/ on Samsung Galaxy S8 can’t reboot into TWRP

geri /e/ user explained similar problem in replies with Samsung S8
Easy installer fails with Samsung S8 - Only official released binaries are allowed to be flashed

Easy Installer fails halfway through (Galaxy S7)

Samsung Galaxy S5 without easy installer:
Stuck at one of the latest points - I tried all I could on my own

I do not get this specific error message, but the same phone, and stuck about in the same place:
Samsung Galaxy S9 “only official released binaries are allowed to be flashed(RECOVERY)”

and the same as above with S9+

I would be grateful if I could get help with this, and I hope this will help other people to get /e/ installed, and to wish this is also helpful for improving the Easy Installer. Easy Installer is outstanding project.

Hi @Octopus8,
Welcome to /e/Land…

You have well read the topics about your problem, i cannot say other thing than press and hold the right buttons.
Someone propose the four buttons and release the finger on the « volume down » when the screen becomes black, and release the others fingers when you will see the two little lines (a blue and a yellow) on the top left of the screen as i describe in the guide i wrote :

Do you want to install build /e/ OS ‘Q’ (Android 10) or /e/ OS 'O’reo (Android 8.1.2) on your S9 SM-G960F?


I have the same problem with my S9+, it does not make sense to support a Samsung S9+ via your Easy Installer, because it is not working with this device.


It works, there are success-story… but it install the stable version witch is not the latest one, the dev version is more recent.

nice answer but but what does it help me with the installer?

I’m a little at a loss how to help here as I don’t have a Samsung phone and the install process for my Fairphone 3 is completely different.

Only a guess, but it might help to see a screenshot of the installer at the point where it doesn’t proceed properly plus a picture of the phone at the same time.
And ideally someone else could provide a picture of what the phone should look like at that step.

Plus, in general I think it would always help to provide the log file of the installer as described in Howto troubleshoot issues with the easy-installer

With Easy Installer I tried to update drivers, but I still ended up to the standard Android recovery screen.

SAMSUNG USB Driver for Mobile Phones (Android USB Driver for Windows)

Also I tried to select “Reboot system now” in the recovery screen, and then hold volume up + bixby + power, but no success.

Easy Installer page ( says that it supports Samsung Galaxy S9 – Exynos only. Samsung might have done an update that disrupts the Easy Installer after Samsung Galaxy S9 was tested and listed to be supported.

Thank you, SuzieQ for asking what OS version I want.

I found Manoj /e/ support message (11.1.2021) “The upgrade of the Easy Installer to handle Q is not done as yet.”

in the same topic deklemoli (11.1.2021) linked this for installing android 10 (Q) for Samsung galaxy S9+:
[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Above two comments from topic:
When will we be able to flash /e/ android 10 on S9 with the easy installer?

I found two warnings about downgading the OS from:
Install /e/ on a Samsung Galaxy S9 - “starlte”

“Warning: Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie or other OS can cause instability or at worst brick some devices”

“Caution:Before following these instructions please ensure that the device is on the latest Android firmware.
For example to upgrade to /e/ Q the Android firmware should be Android 10 and for /e/ Pie it should be Android 9”

Where can I find what OS version can be installed by Easy Installer, If I want to help more people to /e/Land?

In this topic piero said that the dev version is more recent.

I found definition for dev version from

I decided to try dev /e/ Q version for Galaxy S9 (Exynos).

I tried to load TWRP using Odin3. This time I saw a download bar in my phone at the blue (turquoise colour) downloading screen. I do not remember seen that with Easy Installer. Odin3 displayed in a green box "PASS"

Again I got troubles to get to the temwin screen (TWRP). The phone rebooted into the system instead of TWRP.

I tred several times and Odin3 failed to load TWRP, and it displayed a red box. Also the download bar did not appear in the phone (as well as with Easy Installer). I fixed this issue by factory reset the phone between tries, and got a green box “PASS” again in Odin3.

In this topic piero told that someone propose to hold all the four buttons to have the right buttons all ready pressed before the restart. This sounds like a handy concept, and may work excellently in some cases, but I tried a few different key combinations including this one before and also quickly after clicking start in Odin3. Unfortunately that did not help to get to the temwin screen (TWRP).

I was able to get to temwin screen (TWRP) by unticking the “Auto-reboot” box in Odin3 options. When I did that change in Odin3 options and clicked “start” I was long time stuck in a black screen with a blinking charging icon. I tried different key combinations with hope to get forward, and finally got to temwin screen (TWRP). I am not sure what I did finally, but I guess that I held volume up and bixby, then while holding I also pressed power key a limited time, and kept holding volume up and bixby after that, and finally got where I wanted.

I used Odin3 v3.13 and twrp-3.5.0_9-1-starlte.img.tar

I downloaded Odin3 from, but I am not sure is it a safe website to load that, but it could.

Perhaps that might help in Easy installer if it could bring the phone in the same state that Odin3 did with “Auto-reboot” unticked.

Ingo_FP_Angel asked to compare how it looks when it doesn’t proceed properly and what the phone should look like. I cannot say about Easy Installer because I was able to proceed with Odin3, but in my phone the blue (turquoise colour) downloading screen looked the same at the opening of the screen in all the cases (Easy Installer, failed tries to load TWRP with Odin3, and also the success with Odin3). No errors in the screen. The only difference was that a download bar appeared under the text “Do not turn off target” when passed successfully.

On PC the black window (wdi-simple.exe) that pops up with easy installer wrote:
Extracting driver files…
Installing driver(s)…
USB\VID_04E8&PID_685D&REV_021;&Modem: Resource already exists

The window disappeared after that. Maybe someone can compare should that window work longer. Note that this is taken from a try where I did not factory reset the phone after previous try, and that made an issue also with Odin3. I think I may saw a word “complete” as the last word with some of the tries with Easy Installer. Perhaps that appears when the phone is factory reset.

Massive thanks to everyone!

1 Like

Hi Octopus8,

I had exactly the same problem and eventually got through this step and SUCCESSFULLY installed eOS. You wrote:

"At Unlock OEM
When it says “enable ‘OEM unlock’” I switched it enabled in the Developer options and accepted Factory Reset.
next step says: You’ll have to keep pressing “power” & “Bixby” & “Volume Down” until you reach “Download mode” once your device is off. When you’re ready, accept Factory Reset.
I do not know what this is for, but I assumed it was just an optional way to do the previous step: enable ‘OEM unlock’. So, I skipped it."

I was stuck at this step for a long time. turning the phone off with the 3 buttons is NOT optional. On my successful attempt I did the following:

At the ‘unlock OEM’ step:

  1. I accepted the factory reset
  2. waited for my phone to complete factory reset step
  3. logged into my phone and checked that OEM was ‘unlocked’
  4. Then “Keep pressing simultaneously “Power” & “Bixby” & “Volume Down” until device turns off”
    *I let go of the buttons as soon as the screen went black

I was able to follow the rest of the other steps (sorry can’t remember exactly what they were) after getting the above steps correct.

FYI: I did download the latest Odin3 for windows, but I could only extract the zip file. I was not able to install the extracted file, so I don’t know if this actually had any impact on me being successful after extracting the Odin download on my computer? I think I was just getting the instructions confused?


I tried to install /e/OS on my S9 and I had some issues with the easy-installer on windows. When was time to reboot teamwin it rebooted to Samsung recovery.
So I decided to use the easy-installer on Ubuntu (I have windows and Ubuntu on the same computer) and magic happen! Everything went smoothly and e/OS/ is running perfectly.