Cannot Connect to using Nextcloud Desktop Client on Fedora 36 KDE

Hello Team,

I am currently on Fedora 36 KDE. Till yesterday I had no issues.
Today I got an error to reconnect my ecloud account.
As I entered my credentials, I got the error of “Access Denied. State Token does not match.”


I tried removing the account and adding it back in, then I got this certificate error.

Any help will be appreciated.
No issues on the Phone though.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I did get a few hits searching for the error

access denied state token does not match + nextcloud

Are you able to login with your PC browser?

Might one of these help?

Yes I am.

Thanks for the reply, Still finding a solution.
One of the solutions was, if I were using “Certify the Web”, is to wait 1 week for the expired certificate to renew. But all the above solutions are if the certificate has expired. Mine has not.
All other solutions are to restart the server.

Hello @aibd

Could this a solution?

If yes, who would need to update the certificate? Client side or Server-side.

The “untrusted certificate message” is coming from your side … I found this How to add trusted CA certificate on CentOS/Fedora | DevDungeon.

I do not have the certificate. So I cannot move it to the cert folder.
I tried the cert update command but to no success.

Hello @aibd

Just connected to Nextcloud.

Whenever I was using the address in the Nextcloud client, I was getting the error.
So out of curiosity, I entered the same address in the browser and it was taking me to
So I entered in the Nextcloud Desktop client and it granted me the access.

I think, you as an Nextcloud provider, will have to manually remove my IP, cert, hostname or something entirely different from server end if I want to use on the Fedora again.

Thanks for all the help.


From my end as an /e/ user there seems to be an automatic redirect from -> I guess the redirect failed for you.

But on a secure PC you might expect that “some url” should not be able to redirect you without your consent / knowledge.

1 Like

I will share this post on the issue that I created on Gitlab.
Hope this helps anyone with the similar issue.

Do you want any logs from my side to troubleshoot the issue?

Otherwise you can close this thread.

Did you use your address to login or your address?

I used the address. I do not have the other address.

1 Like

I am seeing the behaviour described in the original post if I try to create an account at Using as the server address works fine. My existing continues to work,

Using the MacOS NextCloud desktop client, my existing continues to work, but If I try to create a new account I see this error

I am also hitting this bug when using the NextCloud app on my phone running LineageOS for microG. When I try to add the account

  • if I use as the server address, then login fails as described in the original post. It fails with both my and my addresses.
  • if I use as the server address, then login succeeds for both addresses

Using the MacOS NextCloud desktop client, my existing continues to work, but If I try to create a new account I see this error

Looks like the problem is with /e/'s certificate

the cert is fine - my guess is it’s a nextcloud desktop client code bug that doesn’t expect a redirect on -> -> - usually the domain you enter won’t do domain redirects, so code trips up?


Just a thought … from memory similar issues have been put down to NextCloud version mismatch. Maintenance and Release Schedule · nextcloud/server Wiki · GitHub

Thanks guys, just had the “access denied” problem when I tried to connect via Nextcloud app to but with it worked!
My email adress is still a

1 Like

using instead of solved the issue for me as well.

Administrators should find a way to report to the users of the need to connect to “” now. I tried unsuccesfully to connect for 2 days before I found the solution here :slight_smile: