Cannot disable Wi-Fi

Hi! Today I tried to disable Wi-Fi but it did not work.

  • I firstly tried by typing the button in the notifications, without effect;
  • then I did a long press to open the Wi-Fi settings, tapped the sliding button, which changed its state, but the Wi-Fi was still on (when I went to another app and came back the button was green);
  • finally I activated the plane mode, but… the Wi-Fi was still on.

I rebooted and now I can switch Wi-Fi on and off. Was it a system bug? Was an app preventing me switching off the Wi-Fi? Any ideas?

/e/OS 0.9-2020051554229 — Samsung Galaxy S9+

Hi @come_744, on a different device all I need to do is long press on the wifi icon in the notification are and disable it. This behavior does not seem normal. Pl check if now you are able to toggle wifi activation normally or if you have to go through this whole routine. If it is not working normally add a bug report in gitlab with a log.

Thanks for the link. I will do it if the bug occurs again.