Cannot import Google mail or contacts or export photos or use app passwords

I recently received my Murena Teracube 2e. However after opening a Murena account,

• When I try to log in to an app I get an error message saying “Oops! something went wrong. Retry.” - this is before I get to the stage of entering my password or username. This problem only started after I opened the Murena account.

• I can’t see any way to upload the photos I’ve taken to Murena cloud, and I can’t share them to the photo sharing app I normally use because I can’t log in to anything.

• Despite having uploaded my Google contacts, mail etc to the Murena cloud, I can’t see how to get them to appear on my phone, and I can’t find the online page where I uploaded them in the first place.

Any help would be gratefully received, in normal user language if possible please.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

hey, I’ll enumerate your bullet points to answer each

  1. login fails to which app specifically, or are multiple apps failing?
  2. every photo you take will be synced in a time frame of 30min to the linked cloud account. There’s no immediate “share to” function last I recall. Sharing a photo on-device to a 3rd App should work, but I understand you’re blocked by the login issue to this 3rd party App
  3. you can see contacts Online at but not on your phone? your prior question made me think you didn’t yet setup the murena account in the phone yet. You can do this either at setup time or at a later time in Settings → Accounts → + Add Account as seen this video timestamp - - this adds the Contacts and Calendar - Mail is explained half a minute later at

Thanks for your help. I didn’t realise there was a Murena YouTube channel - I have now subscribed.

  1. The photo-sharing app I’m trying to login to is pcloud. When I click “Sign in” I get a screen saying “No supported browser found” and then it changes to “No connection to the service - Retry”, and then “Oops! Something went wrong - Retry.”

  2. None of the 100 or so photos I took at the weekend were synced to my account. When I go to the Murena dashboard and click “Photos” I get a white screen with the message “No photos in here”. With email I can only see the Murena email account on the dashboard, not my gmail account, which I thought I had imported into Murena.

I tried to send one of the photos from my phone to my computer via my email, but although the email appeared to send, the email with the photo has not appeared on the Murena dashboard webmail.

Eventually I gave up and downloaded the Google Photos app and I was able to get the photos off the phone that way.

  1. I am able to view my previous contact list online at the Murena dashboard, but not on my phone, despite having already set up the murena account on my phone. I set up my Murena account shortly after I set up my phone last week.

I wonder if this is part of the problem - when I was setting up the phone, I started the data migration import in late afternoon and it took several hours to complete. I had to go out for the evening so I left the computer on to continue the import. When I returned home, the import had completed, but it was late so I switched everything off, and I could not work out how to access that page again… I have now found the data migration page by searching my browser history, and I have initiated the Export process which apparently could take some time. Hopefully this will sort out at least some of the problems. I have bookmarked the data migration page.

When I switch on my phone, the front screen says:

Account Manager
Authentication failed (check login credentials)

Account Manager
Contacts ( Cw)
Authentication failed (check login credentials)

  • but when I click on either of these links I get a page saying “ZIP archive - Contains debug info and logs” with a share link - however when I try to share it by email to myself, it doesn’t appear on the dashboard webmail.

I have also tried transferring files by wiring my phone to my computer with a USB C cable, using Android File Transfer, but I just get the message “No Android device found”.

ok things hiccuped already at account setup. As that error message says, you should re-setup your account on the phone until credentials are accepted. You can delete the present account entry in Settings → Accounts and do it again as in the video.

Why did the credentials you use successfully in a browser with fail at the phone?

  • I’d guess a typo in the password or not full login ID (
  • or another common cause is - if you’ve enabled 2-factor-auth in the settings, you’d need to issue a dedicated app-password in the phone account manager

I could reproduce this, the gist - pcloud requires enabled Google device registration. You can enable this in Settings → System → microG (pCloud not working: cannot log in). Once I did this, I could login to the App (it used Firefox internally on the login page, but default Browser should work too as it is the intent was failing, not the browser)

Thanks again for your help.

The export migration has just finished, and the photo I tried to send by Murena email yesterday as a test has suddenly arrived.

Before the export migration completed, I double-clicked on an “Authentication failed” warning, and instead of getting the ZIP archive with debug info, I got an “Outgoing Server Settings” page that allowed me to check my password. It was the old password that I updated last Wednesday, and I received an email confirmation of this last Wed, but for some reason the update has not been recognised on my phone. It works on the Murena Cloud, but not on my phone.

I therefore updated the password on this Outgoing Server Settings page, but after I restarted my phone, the “Authentication Failed” message appeared again. I was once again shown the Outgoing Server Settings page, and it still had the old password.

When I updated it again and then restarted, I got another “Authentication Failed” message, and this time it was back to the it to the ZIP archive with debug info. At least I am now able to read the debug attachment, as it has been successfully emailed to my computer, but it makes no sense to me.

The password works on my desktop account, so I don’t understand why it doesn’t work on my phone, or how I can update it.

Also, on the Murena Cloud, my old Google photos have now been imported, but I still can’t get the photos I took at the weekend using my phone to transfer to the Murena Cloud.

Similarly I can’t get my contact list to appear on my phone, even though it’s migrated into the Cloud.

And I can’t get my gmail emails to appear either on my phone or in the Cloud. When I went to Settings - System - microG I got a message saying “This account already exists on your device”.

I did just notice that I don’t seem to have the latest /e/OS update from July 24th. I’m reluctant to click Apply Update, in case it just leads to more problems.

You updated your password on the web interface, but not the phone? reads like the root cause of your difficulties. Granted, updating the password on the device isn’t straightforward in-place, it’s easier to remove and add the account again as suggested.

Most likely you fixed the email outgoing password, but not the account sync. As said, I’d do the murena account dance (remove, add again) from the start.

I thought when I updated my password it would be across all devices. When I first established a password it went across all devices. It’s very confusing, and sad that there are no clear instructions. But thanks for your help.

there exist systems where if you change the password through the device that has the password/account manager present it can distribute it to linked and trusted secondary managers. But by default, there’s no such thing with a /e/ phone.

If you set a new password through a browser (via desktop or the phones browser), the phone account manager has no way of getting notified of that change and will retry the password it has stored - the old one. As said, remove and add that account to solve this. There are nested setting menus to do this in-place, but it’s easier to remove+add.

1 Like

Thanks, I’ll try that later.

This topic was automatically closed after 90 days. New replies are no longer allowed.