Cannot re-lock bootloader on fairphone 4

I just installed e/ on my FP4. It seems to work fine but I cannot relock the bootloader.
At the end of the official procedure (, , I got a message saying “Your device is corrupt. it can’t be trusted and will not boot”. Then I can only reach the bootloader options.
I can still unlock the bootloader, reinstall e/ and use it as long as I don’t try lock the bootloader again.
I checked checksum of the zip file so I do not think the problem come from here.

As the FP4 is sold as Murena, I though I would be able to lock the bootloader. Am I getting something wrong?

Any help would be much appreciated.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

What did the terminal say?
What did you do?
Did you confirm lock/unlock on your phone?

Did you search this forum? Seems other had this problem too and it could already been solved.
I found this, it may help you:


It is generally possible to relock the bootloader on FP4.
I suppose you’ll find all the details in the links mentioned above.
From what I’ve read and experienced I’d summarize it as follows:
As long as OEM unlock is enabled you’re safe and you can always unlock the bootloader as you’ve mentioned above.
It seems that the problem you’re facing occurs when flashing an OS with an older patch date over an OS with newer one. So maybe you came from a very up-to-date stock ROM. Secure boot (Android verified boot) doesn’t seem to like that. If this assumption holds true then you may be able to relock the bootloader after the next update (with a newer patch date). As said, always make sure OEM unlock is enabled before you try again.

1 Like

Thank you both for your answers. Guess I will just wait for a new e os release then :slight_smile:

Ok, but keep in mind.
If you use the phone in unlocked state and you lock it later, all data will be gone.
For security reasons unlock/lock the bootloader will erase all user data.
As far as I know.
I just tried it on my fp3+. Had it unlocked, did some changes and fotos. Then locked the bootloader. Now I see the welcome wizard and only default apps without any data are there.
I guess on the fp4 it’s the same.
Maybe search the web for some information about how insecure it is to let the bootloader unlocked.

1 Like