Cannot save mail attachments

I cannot save mail attachments with the standard mail application.
If I try, I get the error message “Unable to save attachment to SD card”.
I double checked the storage permission is granted to the mail app, so this can’t be the problem.
The standard saving location (under Settings->Miscellaneous) is set to /storage/emulated/0/Download If I tap it to change it, the app crashes.
I can, however, open the attachment and view it.

I have a Fairphone 3+ with freshly installed e-0.12-q-2020111084008-dev-FP3

Does anyone else have this problem or knows how to fix this?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

cannot save mail attachments

Thank you, I added logs to the issue, we’ll see if they can help.

Hi, having same issue regardless of attachment file type (pdf, odt, png).

If I go Mail > settings> account settings > storage > storage location > the default is ‘regular internal storage’, I change to ‘external storage (SD card)’ then I exit settings and Mail crashes with popup saying “mail keeps stopping” which choice of ‘app info’ or ‘close app’.

Now if I check storage settings again, it has reverted back to ‘regular internal storage’.

If I go Mail > settings> global settings > Miscellaneous > the default is ‘save attachments to /stoage/emulated/0/Download’. If I click on that setting the window switches back to my email inbox without a chance to change it.

I don’t know how to check logs, I do not have adb or any such environment setup (yet :thinking: ).

Using GS290 purchased from /e/.

GS290 build number

For anyone still having this problem, what solved it for me was using a different email app. Using K-9 Mail (found in Apps) works great and attachements can save to internal storage or SD card without problem. The version I am using is K-9 Mail v 5.733, updated 2021-03-30.

On a side note, a weird thing happened when searching for email apps in Apps. When I searched for ‘Email’ it gave an error “something went wrong please try again later”. But when I searched for “mail”, it provided a list of email apps as expected (with K-9 being the first result).

There are 2 issues open on gitlab regarding the default mail app issue, hopefully they will be solved when devs have the time :smiley:


I used the same workaround for the problem. My thing is, that I want to deactivate the notifcations of the /e/-mail app…
is there a sleek way to do it?

cheers and thanks

Do you mean getting ‘email’ notifications from /e/ mail app?

When I got my email account set up and working on the K-9 mail app, I then removed/deleted my email account from the default /e/ mail app and have not had any notifications from it since as it is not doing anything to notify me about.