Cannot send photos in texts

Are your photos stored in internal phone memory, or on a SDCard ?

On the Internal phone memory

Maybe you can try to reset Message app, it is simple and quite safe.
Go to Settings, Apps, open Message settings. Then Force stop, go to Storage, clear cache then storage.
Then launch the app again from your launcher, it should synchronize against Android database (if it doesn’t, you can trigger a manual sync in app’s Settings).

Still sounds like a provider thing. Can other people send images over this provider? (Or: Can you receive images from other people?)

1 Like

Some interesting reading here: MMS don't seem to get sent · Issue #1528 · moezbhatti/qksms · GitHub

Very often the problems of sending photos by MMS come from a bad setting of the APN.
There are a lot of topics about this on the forum:


Yes, I think they can. I’ll have to check though.

Thank you for the info. Unfortunately this does not work either

qksms / Messages allows to set a file size limit it will try to reach with compression - a user suggested to go with conservative 600KB and go from there - Default Message SMS app fails to send photos - #2 by tcecyk

1 Like

Hi Tcecyk, thanks for your message. Just tried 600kb and even 100kb photos but unfortunately it doesn’t work. The info in the photos I try to send still reads:
Back to the drawing board I guess. Thanks again

then I can’t think of another reason as my previous repliers -

bad setting of the APN

or the provider outright declining MMS attachments


Thank you again.

Best wishes


because noone asked yet - could you state your carrier / provider network and current /e/ version from the about phone menu ?


My network provider is 3 uk (Smarty Mobile) and I am using the latest (June 2023) e/OS version.

Smarty offer this advice I suggest you check the settings against what you find at

Settings > Network and internet > Mobile network > Advanced > Access point names.

The details must be an exact match !

There is a support channel mentioned in the above link. There is also a Smarty forum where your issue was raised

You already tried radically adjusting image size but a limit of

the limit is about 300Kb

is specifically mentioned.

Good luck


Iain you are an absolute star.

I changed the APN details as advised and now - after so many, many months - I can send attachments and photos via text.

I can’t thank you enough Iain … but thank you so very much.

Very best wishes


Thanks tcecyk, you were correct re bad APN setting. Email from Iain later suggesting changing APN setting with instructions on what to. Now I’m able to send attachments and photos via texts. Thank you both very much.

Problem now fixed. Bad APN settings for my provider. See the last post from Iain in this thread. It may work for you.


cool this got finally settled! mms still seems to be helpful.

Do you remember in what detail your settings differed before changing them according to Iains link?

the apns-conf.xml settings /e/-R has atm aren’t much different from that link - is resolved to the ip though. I wonder if you have a different mcc/mnc pair that didn’t choose that profile, or it did choose it, and the apn name attribute ‘’ was the issue:

<apn carrier="3 MMS" mcc="234" mnc="20" apn="" proxy="" port="" user="" password="" mmsc="" mmsproxy="" mmsport="8799" type="mms" />

Finally, yes thanks to you all!

For some reason there was not an option to view or to edit the APN settings. The only options allowed were to go back to default settings (still didn’t work) or to create new APN settings (all blank fields) which I did, so I don’t know what they were originally.

For a long time I was able to send attachments via the same messaging app on this phone, but for some unknown reasons the APN settings must have changed. I’ve been with my current provider for many years, so that hadn’t changed.

Sorry I haven’t got the info.

1 Like