Cannot upgrade microG Services Core

I have a Galaxy S7 with pre-installed /e/. I have enabled the work profile & Shelter.
Whenever I try to upgrade microG Services Core from Aurora it tells me that a “conflicting package exists”. I have duplicated the ‘A’, Aurora and FDroid repositories in my work profile, so I wonder of that’s the reason.
All other apps upgrade OK.
How can I find and remove the conflicting version of microG Services Core? I have not tried uninstalling it in either main or work profile in case I break something.

This has to be well thought out, because as a system relevant application mircoG is updated via the /e/ OS Update.

Currently /e/ OS uses the version microG Services Core

Which version does your S7 “herolte” use and especially - which version of microG Services Core should be installed via Aurora?

Looking in System > Apps, I see microG Services Core listed twice:

  1. Version (0047182) using 524 KB in internal storage and 20MB avg memory
  2. Version (0047182) using 896 KB in internal storage and 20MB avg memory

Aurora wants to install (0047182) 19420021

Forgot to add, version 1 above has the work profile security icon, whereas version 2 has the plain microG icon.


So, what’s your recommendation? Have I gone wrong by installing microG Services Core from Aurora?
BTW I’m familiar with Linux systems, but have no in-depth knowledge of Android or /e/
Thank you for your interest and advice.

I would not change the default settings of the /e/OS ROM.

Why you have reinstalled microG Services Core from Aurora is not clear to me at the moment …

you can’t upgarde MicroG manually. It should be done by sytem upgrade. And mircroG works over the whole sytem. No difference between work or private profile.

The ony way is, you remove GMScore from system via TWRP. Tha you can install it via Aurora.
But I wouldn’t do that. Is there any reason you want / need an upgrade of MicroG ??

No reason I want to upgrade except that it’s offered, and I try to keep everything up to date.

I got my /e/ phone last summer, and clearly I fiddled about too much. Lack of understanding of the different repositories available (‘A’, Aurora, FDroid) has obviously led to unneccesary duplication on my phone.

I shall try disabling microG Services core in Aurora (one at a time, and disabling, not uninstalling) and see what happens.

How remove microG of /e/ os? We’ve discussed this topic before, @harvey186. You remember now.

Apart from the fact that even I wouldn’t intervene in the system without compelling reason, manual removal is also possible→ via ADB commands.I hadn’t noticed any negative effects at that time.

To me it was also confusing that Aurora offers an MicroG update. However I never tried to update it since it’s part of /e/ and on my previous phone part of LineageOS+MicroG. It’s a bit too late now but for future reference, there is a setting in Aurora to blacklist certain apps. I’ve done that for MicroG so it’s not listed in the Aurora update list anymore.

1 Like

That’s an excellent idea. Thank you for pointing that out.

Not every new is the best :wink:

‘A’ = apps store with a mix of FOSS and Non-FOSS apps
Aurora = Client to get access to Googlag Play Store anonymus
F-Droid = FOSS apps without trackers (should be always the first place to search for an app)

Yes it is, but I prefer the manual way direct on phone. I can move the GMSCor.apk to a secure location and when something goes wrong I can move it back. From my side of view, it’s the easiest way

So, if microG Services Core is part of the system, have I replaced the system version by installing it from Aurora or just duplicated it? I would guess the latter, as it has allowed me to install two copies, one in the main profile and one in the work profile.

From what @harvey186 said earlier, microG Services Core works across both profiles and doesn’t need two copies. So I’m guessing (!) that I can uninstall both Aurora versions, and there’ll still be a copy built-in to the system. Will I brick my phone?

Thank you. That’s very helpful.

No, you have isunderstood. There is only ONE MicroG on your system and you CAN’T remove it via Aurora.
As Archie has written/linked, there is a way via ADB or as I prefer, via TWRP to remove the GMSCore.apk.
After removing this apk, you have no MicroG on your system, not in own profile nore in shelter profil (because it’s only onetimes in your sstem)
If you have removed MicroG from your system, THAN you can istall it in main profile via Aurora and THAN you get it back in shelter. No need / way to install it only in main profile or Shelter profile

OK. Thanks. The phone works OK, so I’ll just ignore the fact that Aurora offers it as an upgrade. Playing it safe.

1 Like

That’s the best solution :+1:

1 Like