Can't install /e/ on Oneplus 6


After reading this all and spending lots of time trying to install TWRP, Lineageos and /e/ on my Oneplus 6 I’m rather confused and not successfully. :sweat:
After buying this phone I was successfully with installing Lineage on it. After trying to install /e/ on the device was in fastboot loop so I had to send it to the service department of Oneplus. It is functional now again but I don’t like the whole google stuff.
It seems to me that there is changed a lot what makes that it does not work for me now. I was successfully with my FairPhone3, this device runs well on /e/.
But Oneplus is to difficult for me I think.
Device is unlocked, runs Q, “fastboot devices” sees device but can’t find any file .img for starting twrp
Is there maybe the possibility to send my phone to somewhere/someone for installing /e/ on it?
Thanks in advance!


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @rex I have a similar A/B device and I would suggest (if you don’t know already) do not use the fastboot flash recovery command given /e/ install instructions for temporarily booting custom recovery. Use the commands given on LOS installation instructions. They worked for you before.

I’ve just looked at twrp instructions for the op6 and you can see there are issues with mtp, and suggestions for alternate ways to flash it.

Actually I would follow the Lineage instructions completely only subsituting /e/OS for sideloading (obviously) and twrp as the custom recovery if that is what you want.

I can’t think why not temporarily flash Lineage recovery for wiping & sideloading? When it comes to rebooting system at the end, the new eOS will overwrite it just like it would with twrp. Although I haven’t tried this step; might be better to wait for someone more experienced to comment. :wink:
EDIT: just noticed that q dev comes paired with e recovery on the download page; using that combined with LOS instructions should be straightforward, no?

Hello chrisrg,

Thanks for your message,
I already did what you are suggesting.
The problem is that I don’t know where I have to store custom recovery.img. So that’s why fastboot can’t find it I think.

It’s a short list, but check it out…

Thanks for the list.
But I’m living in the Netherlands the nearest member on the list 280 km away from me.
I’ll send him/her an e-mail, perhaps I can send my device.

Hi all,
Problem solved,
Set Oneplus 6 back to standard android, locked it and give it away to my daughter

Regards, Jan