Can't login to Guardian App account

I am using @harvey186’s Pie GSI (from here) on my Xperia XZ1 Compact (lilac) device. Everything is running pretty much OK as described in this post

I ahve encountered one more problem: I cannot login to my account in the Guardian newspaper app (installed from Aurora Store). When I try to sign in to my account, using correct username and password (I have checked several times) i see an error message saying Sorry, an error occurred signing you in.

This has worked fine on other devices, and other login’s on this device (including banking apps) are working fine. I’ve tried uninstalling and reinstalling, clearing app data and cache still no joyAny ideas what may be causing it, or how to get round it?

which OS ? Also eOS ?

Other devices running eOS. Including Z5 Compact running nougat unofficial build, Z3 Compact running nougat unofficial build.
However, I have tried again with these devices and they are now failing too, so this isn’t specific to the Pie or GSI build. It may be a problem with the Guardian web site, or the app. I’ll try to find a non-eOS device and see if that fails too

[Later] Same error on my wife’s Moto E 2015 (surnia) running Lineage4MicroG 14, so it’s not specific to eOS. Maybe to do with MicroG. I no longer have any devices running ‘normal’ Android, so I can’t test that.

Thx for that update. Bad for you, but good for my GSI build ; )

Flashed stock firmware, went through setup wizard, signed into my Google account, installed the app from Play Store and…
exactly the same error!

So it’s nothing to do with /e/ or MicroG \o/. Now I’m hoping for a reply to my email to

1 Like

Just got the following reply

On 16/08/2020 10:36, Userhelp wrote:

Hi Pete,

Thanks for getting in touch and sorry to hear you are having issues with
the app.

We are currently experiencing some technical difficulties with sign-in
on Android. In the meantime all readers can sign-in on,
while we rectify the issues on Android.

Thank you for your patience as we investigate the problem.

QA/Test Analyst (Mobile apps team)

I like such Blah blah blah answers

May I ask whether your received any further news from the The Guardian since then or have you been able to make the app work somehow? I just installed /e/OS and have the same issue.

We exchanged a few more emails then it went quiet, without any resolution.

However, I now know what the problem is. I recently set up a new phone for my wife, that unfortunately is stuck on stock Android. I installed the Guardian app and tried logging in. After entering my user email and password, the app uses a Google reCaptcha (see to check it’s a human logging in, not a bot. Unfortunately there is no way (or no way that I have found, and I’ve looked quite hard :slight_smile:) that reCaptcha will work on /e/, because it relies on Google resources and APIs that are not functional in the deGoogled OS. So instead of the reCaptcha images being displayed, the sign-in appears to hang, until you exit the sign-in page .

My workaround is to use my web browser instead of the app. I use Firefox, but the same should work with the built-in /e/ browser.

  • Open the Guardian home page
  • Sign in with your user email and password (which works fine, no reCaptcha is displayed)
  • Then, from the browser menu, choose ‘Add to Home Screen’ and drop the shortcut wherever you fancy in your Launcher / Home Screen (if you are using a normal Android launcher like Lawnchair or Open Launcher. I have no idea how it works in Bliss: I suspect the shortcut will be added somewhere really inconvenient :wink: )

This workaround is good enough for me: I get the stuff I want to see, without the screens nagging me to become a subscriber, that the app keeps displaying to users who aren’t logged in. The only thing missing is the ‘Compact view’, but I can live without that.

A similar workaround has helped me with the small number of apps I want that don’t work without Google services. They all have web access to the same - or very similar - functionality, so I install a shortcut to the relevant page instead of using the app.

I hope that helps you.

I will email Guardian support again, explain what I have found out, and ask them to use something other than reCaptcha, but I won’t hold my breath for things to change.


Thank you for the fast and comprehensive reply! Your approach worked like a charm and your explanation regarding the cause of the issue sounds about right: Google’s reCaptcha, once again the culprit for broken functionality. When I used the desktop browser to test my login, I had to enable all the script resources for reCaptcha, too, i.e. even there I wasn’t able to log in at first.

Sending them another mail sounds good, at least they will know more about the root cause and hopefully that will make them do something about it.

1 Like

I am having the same issue with the Guardian app - however I do not wish to read the Guardian in the browser. I have paid for a subscription (on my older Google Android phone, so in Google Play) and wish to use the features of the app that I like such as following, editing my home page.

So I have raised it as a support issue - after all for accessibility reasons they should offer more than one way of authenticating to sign in to the app.
Will feed back here in the unlikely case that the Guardian address/fix the issue.

The Guardian login is working for me now. I believe this is because microG now supports reCaptcha. I use a custom /e/ build which uses the MicroG from the official repos, and currently has version I’m not sure which version of microG is in the /e/ ROM you are using, but if it doesn’t work currently, it should start working when you pcik up an /e/ ROM with an up-to-date(-ish) vertsion of microG

1 Like

Thanks for the update.
However weirdly I am on a more recent version - (87caebf) and it doesn’t work.
I wondered if the bug had been re-introduced in the newer version so tried adding the F-Droid repository - microG Project repo and to downgrade to - however it won’t install on my ePhone. I think it may need to come with an OS update.
Will look around for some other way to do this though I wonder if the issue may be something else.

Update - today I was able to log into the Guardian app.
The Guardian app still made me use reCaptcha but it worked, not clear what changed to resolve this but I am glad anyway.