Xperia XZ1 Compact lilac & GSIs


  • Pie-based /e/ GSI is running fine. It can be flashed, on top of stock ROM, or another GSI, even a non-booting Android-10 one.

  • Q (Android 10) GSIs don’t boot on this device (when flashed on a Pie-based firmware).

In more detail

  • Starting from Android 9 Stock Firmware version 47.2.A.11.228. The device is working fine: service tests all pass, it makes and receives calls, and does pretty much everything you would expect. I didn’t try the fingerprint reader because I don’t want to use it. And I didn’t fully setup and sign in to Google account, but we can assume the phone is OK.

  • Installed TWRP (twrp-3.3.1-0-lilac-pie-5.img), and re-ran a subset of the above: the phone is still working as expected.

  • in TWRP, backed up stock system, data and boot partitions, and wiped and formatted the data partition.

  • Installed @harvey186’s minimal A-10 Arm64 A only, GSI LeOS_Q-20200805-Mini_arm64_avN from here, unzipped, and flashed using fastboot

  • When rebooted the device boot-loops: shows the standard Sony ‘Unlocked bootloader, Your device cannot be checked for corruption’ screen, followed by the Sony Startup screen, then powers off and reboots. This sequence repeats until you hard power down (hold Volume switch & power button until phone vibrates once, then again three times).

  • Restored the stock system, boot and data partitions. and tried a few more times with some variations (format, but don’t wipe data partition, don’t wipe system, some others) to install the GSI. Same results - boot-looping every time. On one occasion (after wiping system, cache & date before flashing) I saw a different ‘Your device is corrupt screen’ which stayed for a while, then screen went blank & started boot-loooping again

  • After the last attempt, I didn’t restore the stock system. I wiped and formatted the data partition, then flashed @harvey186’s Pie-based GSI e-pie-20200613-JoJo-treble_arm64_aeN.img from here on top of the Q GSI.

  • When rebooted, the phone stayed for a long time at the Sony screen (maybe 4 or 5 minutes - it felt very long), then the new ‘Your device is corrupt screen’ appeared and stayed for a while, followed by the ‘Powered by Android’ and ‘Xperia’ animations. Finally, the /e/ setup wizard appears and the phone is ready to go \o/

  • I made some basic tests, including making and receiving calls, which worked fine.

  • I’m going to make a backup wth TWRP, then spend some time setting the device up to be my ‘daily driver’ (installing apps and a different launcher, setting up home screen and accounts, etc.)

  • I will stick with Pie on this device until there’s a Q/A-10 ROM (official, unofficial or custom) for this device, or a Q/A-10 GSI which has been tested to at least boot on this device.

  • I have another XZ1C - the original which won’t make or receive calls, and on which the screen is starting to come away from the body. Apart from that it does everything else pretty well. It is also happily running the Pie-based GSI. I am happy to use that as a testbed to try out new builds - GSIs or device-specific ROMS - as and when they become available.

  • While I was trying to make the Q GSI run on the original device, I also tried phhusson's [AOSP 10.0] [2019-12-06] Quack Phh-Treble GSI from here (thanks for the tip @harvey186). It showed the same boot-looping symptoms as the /e/ Q GSI, which makes me think it’s a problem with Adroid 10 and this device, rather than any problem with @harvey186 's GSI.

  • I haven’t tried installing the Pie GSI on top of the stock ROM on the new phone, but I’m confident it will work as it’s worked a few times on the original device. I may try that later, when I have a good backup of the new phone, but for now I just want to use the phone :slight_smile:

If you need any more information about any of this, please let me know. And thanks again to @harvey186 for building the GSIs and answering all my questions. I really appreciate it!


Thx for this post. I’m playing since 2 days to get the Q-GSI running on my daily driver (MiMax3 nitrgen). Pie_GSI was working without any issue. But When flashing ANY Q-GSI my Camera isn’t working any more . And on some Q-GSI the Wifi is also not working.

Regarding my Q-GSI:
I think the Mini-Version has an issue — I’m just building a new version.
The Full-Version will also be refresh soon. I have (partital) fixed the Wifi connection issue.

After setting up and using the phone for a day, some more information

  1. The device was very slow to start up - around 2m50s from pressing power to launcher home screen. To fix this I reflashed the stock firmware using ‘flashtool’, then flashed the Pie GSI. Startup time was back to normal
  2. In the stock firmware, the dedicated camera button will a: start the Camera app if it isn’t already started, or take a picture / start video recording if it is running. In the GSI it does nothing. This is not surprising since the camera button is device-specific.
  3. With ‘Advanced restart’ enabled in Developer options, Restart | Recovery doesn’t work. Instead the device restarts as normal. Restart | Bootloader does work, so long as the USB cable is plugged in. If it isn’t the device restarts as normal, which is waht you would expect
  4. When I first inserted the SD card (containing theTWRP backup of the stock system as well as other things), the software claimed it was corrupt and needed formatting. I checked the card in other devices which read it with no problem. Eventually I formatted the card in this device (after copying the stock backup to a computer) and it’s been fine since (in this and other devices). I recall this happening when I first installed this Pie GSI on my earlier broken device. Other SD cards were recognised with no problems.

Apart from these points everything is behaving very nicely. I have a few more apps to install, and a lot of music to copy to the SD card, then it will become my daily driver.

I tried installing the new version (LeOS_Q-20200808-full-treble_arm64_avN.img) over the stock system, and got the same boot-looping symptoms as before - sorry!

yeah, it’s really bad. On my main device I’m getting often bootloop or stuck on MI boot logo when using Android Q firmware. With Pie firmware it’S booting but no camera available. :frowning:

A few more details

  • I’ve tried using most of the apps and everything seems to work pretty much as expected.
  • An exception is the Ebay app, which causes MicroG to crash when the Ebay app starts up. This issue was first reported last year in this post. I tried the recently (June) posted workaround but no joy. This app has been working fine for me on other devices: on z5c suzuran (nougat unofficial build) and z3c (pie - test build) I did not have to apply a workaround on these devices. The only difference I can see is a small difference in the MicroG version number (68c4e0d) on the working versions, (2e3ec1d) on this non-working one. These two versions were released 3 days apart in October 2019 - see The diffs are here It might be worth pulling the later one into your build.
  • I installed the latest (updated yesterday) LineageOS 17.1 Unofficial Build on my slightly broken testbed phone and it is all working fine
  • I also tried phh’s AOSP Vanilla Q GSI system-quack-arm64-aonly-vanilla.img again on both devices. It’s still boot-looping

Now I’m stopping for a couple of days holiday, when I hope to use the daily driver - particularly the OS Maos and OsmAnd+ apps - while walking and running in the Lake District. I’ll report back :slight_smile:

1 Like

enjoy the holidays. I think the bootloop has something to do vbmeta. the is a which could/should solve that issue

you can try nexttime with bot zip’s after flashing GSI … or before … can’t remeber

Tried both ways - still no joy.
Not to worry - I’m happy using the Pie GSI (from here until there’s an official device-specific build for this phone.

I have read in other post, that you not so happy :frowning:

A couple of minor bugs aren’t going to make me unhappy. :slight_smile:

An update on this.
Today I tried the latest Q GSI from I flashed LeOS-Q-20200917-FULL_arm64aeN.img but still boot looping. Re-flashed the Pie GSI (e-pie-20200613-JoJo-treble_arm64_aeN.img) and everything is working fine.

(This is on my spare device which does everything except make and receive calls. My daily driver is now running Havoc-OS, with NanoDroid and MicroG, which implements the Apple/Google Exposure Notification API needed by the UK’s soon-to-be-released Covid track and trace app)