Can't read mails anymore

But you can have as many mail accounts as you want in a mail app. There’s no need to have more than this one mail app. And there’s still no mix at all, the servers will keep the received and sent mails very well. But this mail app should work then reliably.

Yes I hnow well I can do that thanks. Would you please let me organize my data as want ?
You seems to take all questions as an attack agains the project ! It’s not the point.
The fact is that there is a major bug on a major app it just has to be fixed.
Our community goal is that we can recommand eOS for any user as soon as possible, isn’t it ?
With such update issues it’s simply not even possible. With 700 Euros Phone it’s a pity (not in my case hopefully)
I do really like eOS I use it on my personnal and professionnal phones and I want them to work always better


No, not at all. Read what I wrote. I use the project and am happy it exists.

Yes, would be good. But in the last more than two years fixing bugs in forked apps has never been the most important thing here. I made several cases, about ten, a single one of them has been fixed, and not by repair but by reforking. Most of the others have been closed meanwhile “because of inactivity”.

My solution of these problems would be to remove these forked apps generally. There’s no need for them at all. Instead there should be a proper website which lists (and suggests) free, well known and well working apps for the basic categories (internet browser, mail client, calendar, messaging, navigation, multimedia, privacy). These forks have several evil disadvantages: they tend to be outdated, they bind people (I mean developers, testers, support) onto tasks they probably don’t understand in every aspect, and the benefit for the user is indeed absolutely zero.


OK as you explained it I understand your position yet. Thank you ! It’s more a debate with the project’s leaders I guess. I still believe that normal users simply expect the default app working well… It’s confusing when you receive a mobile device with preinstalled app you’d rather not use !

About the further back described issue, it’s suddenly working great again after a shutdown and restart (reboot did’nt fix) mail app on FP4

are you in a position to capture a debug log from the moment the Mail App switches/flickers back to the list view? I haven’t got a device I can upgrade to 1.18 atm to do this myself. I guess it’s easy to reproduce for anyone on 1.18. In any case I’d edit the issue title to describe how Mail misbehaves for people looking into the bugtracker later to see the behaviour is reported.

1 Like

Happy Christmas to all, and thanks to those who develop and document. I’m a year in with the OS, and it suits my needs pretty well. I did need a better camera, and will probably want to switch back to AT&T soon, so I upgraded to the Pixel 5.

Since my (clumsy) migration, I seem to have only one app that misbehaves. The default mail app will flicker, then return to the inbox view when I try to open an email. I tried deleting several old emails, which put things to rights for awhile, but the behavior started again.

I also attempted a “force stop” and a restart of the phone, which did not accomplish anything.

My Murena account works fine on the Windows dashboard and through a browser.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

you’re struck by a bug described at Can't read mails anymore - the easiest workaround being setting up upstream k9mail

Ahh, thank you for the link. Ill look into the workaround. Or just grab my murena emails from my desktop for awhile.

Well, there was not much exploration to be done. All set up with k9mail.

Is this issue impacting all emails like gmail, etc. or is it specific to certain emails only?

I have combined two similar mail threads here to make it easy to track this issue.

Manoj, in my case it was only my emails.

Pl can you create an issue about this on gitlab. In case you do not have an account on gitlab use this guide

1 Like

Hello @Manoj,

The issue impacts both my mail accounts (GMX and

There is already an issue on Gitlab:

I have tried to capture a logcat and added it to the bug report (BTW, thank you for pointing out LogFox, I did not know this app!)

Well, I have not created the bug report so I cannot edit the issue title (I think).

1 Like

Glad the issue has been opened. I started to, I thought GitLab was going to accept my GitHub login, then it wanted a cc number or phone number.

Thanks for pointing this out. Discussed the issue with the dev team yesterday. Thanks for the logs and details attached to the issue.

(if you want to reformat your posted log in triple-backticks: line-break on the timestamp. You can do this retoractively in an external editor by using the beginning of the timestamp “170” → “\n170”)

The error you show happens when k9 tries to load account images and complains their dimensions not being > 0. Maybe the bumptech library can’t read the image format or it hiccups on there being none (both being a bug).

Did you add a contact image to your own contact that has the <removed> email? as workaround I’d remove it and check if it works. Also: if you don’t have an contact image, add one

W Glide   : Load failed for [AccountImage(email=<removed>, color=-15756042, tag=PROFILE)] with dimensions [158x158] 
W Glide   : class com.bumptech.glide.load.engine.GlideException: Failed to load resource 
W Glide   : There was 1 root cause: 
W Glide   : java.lang.IllegalArgumentException(width and height must be > 0) 

Didn’t really find a 1:1 issue in k9 bugtracker, in general it’s about the feature

1 Like

Hello @tcecyk, thank you for your suggestion. I have added a contact for <removed> with a contact image, and the exception seems to have disappeared. However, the problem with the non-readable messages persists.
I have stumbled upon the following error that seems to appear after a while when a message could not be read:

1703651268.538 10110 14423 14423 E chromium: [] Renderer process (2677) crash detected (code -1).

So there may be a webview problem. (Interestingly, the error message does not have a stacktrace.)

EDIT: My phone is rooted so that I have installed an alternative webview. I will investigate the bug if the /e/OS webview is used. (However, I assume that most users that have reported the problem do not use an alternative webview.)

I had also this issue during 1 week on my xiaomi mi mix2 1.18-t-20231209360971-dev-chiron
I have a mail on ovh
Since yesterday, it’s ok i don’t know why :face_with_monocle:

Edit: I just deleted app cache and I retrieve issue ! I’m happy :smiley: :joy:

Edit2: I found a workaround. I read old mails on some directory. After that I can read those on my inbox :v:

Merry Christmas :evergreen_tree:


Well, it is much easier to create an account on gitlab through the Murena dashboard. Sorry about the confusion.