Car sharing app Miles uses wrong location

The car sharing app Miles shows the correct location on the map (mapbox), but it does not use the correct location. The effect is that pressing the button to center the map on my location, it goes some hundreds of kilometers away from my location, Unfortunately, I cannot rent cars this way, because the app doesn’t belief me that I am standing right next to the car, although it shows me so on the map.
I’m using FP3+, location works very well with all other apps, including other car sharing apps. Has anyone any suggestion what to do?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

(sorry to be the microg issue bot, no offense) - it’s recorded at

what is you’re /e/ version? helpful to compare to microg version used

the last poster wrote…

The location that is used by the application as the center of the map and also is used for business logic seems to come from the cell / IP location info or something similar. It is static but changes over time (days). The marker on the map however comes from GNSS and is constantly updated (live).

“center of the map” → celltower or ip location? - wrong for you
“map marker” → gnss (gps) → correct

did I get this right?

It’s hard to believe MILES to take ip location into account, something could go wrong easily, ip location info has varying degrees of fidelity. Do you use VPN or have the Advanced Privacy hide-ip / Tor thingie enabled?

2 Likes

Thanks a lot for your helpful reply! Your description is correct.

I use /e/OS 1.2, and I told the phone to use my correct IP in the Advanced Security Settings.

I tried to switch between data connection and Wifi, and I also tried with VPN on, but nothing changes with the “center of map”. This is weird, I think, since the IP should change with the provider and VPN, right? So, maybe it is not the ip location?

In this context the Exodus report makes interesting reading

:exclamation: ACCESS_COARSE_LOCATION access approximate location only in the foreground
:exclamation:ACCESS_FINE_LOCATION access precise location only in the foreground

The icon :exclamation: indicates a ‘Dangerous’ or ‘Special’ level according to Google’s protection levels.

but the reporter was right - if I change providers of an IP, the map center jumps accordingly… maybe this is some fallback when something else fails. They can’t rely on IP.

I pinged MILES support with the microg issue link - likelihood of someone testing this I guess is low.

Mobility Apps can be a frustration with non-standard phones - If my old device doesn’t pick up GPS in time as I’m out and about (no wifi or a-gps), bicycles refuse to open (as I’m too far away).

1 Like

@vossi - for curiosity… is db-ip.com close to what MILES shows for your IP? (no need to disclose the location)

I confirmed with more ip routes it really is the IP info that is used… I guess it is a fallback full-gsf appdevs never saw or some anti-fraud mechanism - I can’t imagine this is used for the general public, it would never work.

In my case, Miles always locates me somwhere in Münster (Germany), independent of the IP I’m using. I tried to look up the IP location info in db-ip.com, it gives me the correct location if I log on via VPN, but tells me that there is no location information for my IP for data connection and Wifi, since these are private network IPs…

1 Like

I recognized that my phone only shows me my “internal” IP in the case of Wifi and data connection, and I have no app to look up the external IP. However, I just tried to get a random IP from Austria via the Advanced Privacy tool - still Milles insists that I’m in Münster …

(I wonder how the Robben&Wientjes App performs with microg)

I guess the way it’s supposed to work is… scans visible wifi networks, lists celltower-ids it sees → queries database to get approx. location → if it agrees with gps-location → continue (with rental) - and somehow this fails.

I don’t know if it’s due to UnifiedNlp itself or the backend used, you could try different providers (you can find them through applounge as most are on fdroid). If the descriptions are proper, by default, /e/ mozilla nlp db queries celltower-ids - not visible wifi networks.

Not sure if for marketing purposes or used for this location logic - Exodus says it’s placeiq (now precisely) sdks that can do location intelligence in that App (it’s scary stuff but… I digress)

1 Like

I open a browser and go to http://icanhazip.com and clouldflare reports back my ip4 or ip6 address.

1 Like

I checked my IPs, and they seem to be located in Bonn. I installed three more backends and tried different combinations of them. Unfortuantely, nothing changes, I’m still located in Münster …

I think it is well known that Google employs highly developed WiFi triangulation in order to deliver “better” delivery of consumer services to the customers of the Google advertising agency. Here is a Google help page Control access point inclusion in Google's Location services - Google Maps Help.

In my view the full insidiousness of this activity is expressed euphemistically in most official documentation.

I think I would expect MicroG to be able to interrupt some of this, especially where we see apparent third party activity as:

With the new Vivid service "Carsharing,” Vivid customers can find a vehicle directly and conveniently via the Vivid app. In the app, users simply go to the “Rewards” tab and find the new Vivid service right next to "Hotels,” “Car rental,” and “Taxes”. An interactive map appears in the app with all available vehicles around the current location as well as filter options and a search field for checking cars at any location.

1 Like

I think it was non-sense of mine to muck around with IP routing from my desk, I was curious how they do the center-mapping. But MILES cares only about the mobile data connection - they don’t need to get random residential isps or datacenter ips right, “using the app during wifi-only OR without mobile data conn” is not a use-case for them.

For the mobile connections of mine (tested vodafone and telefonica) they placed me in the proper city. So when you write…

I checked my IPs

you mean those of the mobile data conns?

If they get this wrong for you, I guess a simple support request of yours could get this fixed - tell them the IP and mobile operator and that center-map never works for you.

1 Like

Just a short update: I contacted the Miles support, they answered very fast and friendly. However, they told me that GPS often is a problem in Fairphones, so I told them that this is definitely not the problem. It seems that now some members of the product team have to take a closer look …
Moreover, yesterday my phone reported the crash of the UnifiedNlp Module for the first time - I didn’t use Miles in that moment (since it doesn’t work anyway). I restarted the phone, now it seems to be running again without any problems …

I have very similar problems to @vossi, when trying to use Miles with FP4 and /e/OS 1.3. I sent a message to Miles in case this can help motivate a solution from their end… :upside_down_face:

1 Like

Unfortunately, Miles stopped talking to me. The new update of Miles didn’t change the situation …