Chromecast functionality

Hello all,

After having known of the /e/ project for about a year, I finally flashed /e/ instead of my rooted Lineage rom on my Mi A1. I’ve now settled in nicely, found some necessary replacement apps and have gotten used to them, and am actually greatly impressed by how smooth it all runs. Good job! Nicely in line with my ambition to get rid of as many Google (and other big tech companies) apps as I can.

There is, however, one thing that has complicated my life slightly: the absence of managing to establish a connection with my Chromecast. It might not be in the spirit of a de-Googled os to want to use it, and I am open to alternatives (I also have a Wetek 2 running Libreelec/Kodi), but now that I’ve still got one, I would like to make use of it. And from what I understand onthis forum Chromecast functionality should actually work.

On my Mi A1 I see the Chromecast icon in the applications I use the most: Netflix and NPO Start (Dutch public broadcasting application). I can also find my Chromecast and click on its name, but from there it starts to endlessly try to connect and then fails to establish a connection.
I installed those applications via the Aurora Store and I’m running 0.7-o-2019121233832-dev-tissot, Android 8.1.

Any ideas?

P.S. I’ve seen other threads, but none of them dedicated to this topic specifically as far as I can see(update broke Netflix and Spotify, multiroom audio, etc.)

1 Like

@marijnrombouts

I use a Motorola G 2014 fully updated and experience the same error.
Looks like a problem with some devices only because others can use it nicely.
I gave up on this since I only use it at home with another phone (Lineage OS on a Samsung SIII).
If you will, you can get a log from your phone (check how here) and submit it to the /e/ team via Gitlab (this matter is being treated here).

I think running Chromecast will need original play services. I never have heart, that it is working with eOS. MiroCast Yes, Chromecast No.

@Manoj has stated in Dec 17 2018 that he could cast Youtube to Chromecast (see it here).
But he was the only one I heard of so far :slight_smile:

perhaps it would be good if we could guide people on a good Chromecast alternative; i think many people will face this same issue. Mirocast is an alternative i understand? Perhaps Kodi also? Others?

Yes, but 2 posts later he agree, that only youtube is/was working.
I agree, there should be full test of mirroring device screen on tv

MiroCast is an alternative protocoll. There a a lot of devices which working with MiroCast.

Kodi is a MeduaCenterApp which work with airplay for example

I’m more into using cables (HDMI) in a non smart TV.
As soon /e/ can be used in a tablet this will be my solution.
And did Miracast evolve? I heard it was not reliable.

I’m using a RPi with LibreElec for watching Netflix, YouTube and movies/music/pictures from NextCloud Server

I’ve never heard of this and loved the idea. I was about to purchase a RPie just for the fun and now I have a goal.
Thanks @harvey186. Glad you stick around :slight_smile:

2 Likes

I’m using also raspberian and kodi in a RPi4-4.
When I have some time left, I will install also Matrix or XMPP Server in it.

If you suceed, let me know.

1 Like

I also have the same setup - a RPi B+ with latest LibreElec - works for Amazon Prime, Netflix. YouTube works very well. Tried OSMC but found LibreElec better.
The RPi I have is an old model Maybe on newer versions the performance is better.

1 Like

i’d like to restart this topic: what do people use for streaming content from their phone to their TV? Eg Netflix when you do not have a smart TV? And which of those options is also suitable for ‘moms and dads’?

VLC or YouTube app ( I know it is not to be mentioned on this forum) work and let you cast to a non - SmartTV . I tested it some time back. Netflix app does not work on /e/ not sure if it is a MicroG issue or app issue. I tested on a Pie build.

1 Like

do you mean VLC and youtube work with Chromecast? Or another form of casting?

It worked with Chromecast

VLC is the only app that see my Google chromecast and works.
I’m using a Xiaomi Redmi 3s. I have tested both /e/ os and microg ROM.

Ähhm, eOS is a microG rom, or better it’s including microG. So what do you mean ?

Sorry. I discovered 2 separated projects.

  1. /e/ os which is the e fundation ROM including microg. However, for my redmi 3s the ROM is actually delivered with Android 8.1

  2. lineageos microg ROM. Which is a lineageos ROM including microg instead of gapps. For my redmi 3s, the ROM is delivered with Android 9.0 but without all the /e/ apps.

I have chosen to use this last ROM for now.
Drowback…no ways to sync /e/ account.

So, you’ll better continue to use the /e/ os ROM.