Cloud Contact Issue

Created an email address for a specific individual in the Contacts on Murena One. The email address does not sync with that individual in the Contacts in the Murena Cloud.

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

That may be a simple question of sync-settings (interval for sync with cloud) or you may want to doubleckeck the default account for new contacts @ phone (needs to be set at murena, not “phone”), see settings of/in contacts-app.

obacht
on my phone “Accounts” there are two accounts.

NAME@murena.io

Contacts (NAME@murena.io jA)

which one to choose? Any idea what the jA means?

OK (we need to avoid mixup)

Theres accounts in system settings.
That´s where you define e.g. the sync interval of your phone with your murena account.
I assume that´s where You find those two accounts, right?
It is normal that there´s an “extra” account shown for contacts/adressbook - due to the specifics of CardDAV-protocol I guess (which is probably the “contacts”-account in your case - I use a different provider and in my case the suffix of that “adressbook-account” is “qg”, no clue why…)

And there´s the settings in contacts-app.
That´s where you define the default account for new contacts on the phone.
In my phone there´s phone (which is the strictly local adressbook) and my online-adressbook account. Default account should be your online adressbook. Otherwise it won´t sync from phone to cloud…
My assumption was that your setting might for some reason be phone

I think there is still confusion ! :slight_smile:

This issue is also discussed Confusion with many WebDAV address books.

I cannot find a useful reference Edit [1], but I think we were warned that Webmail is now capable of running its own Address Book which is capable of diverging from the phone’s Contacts.

These two Address books appear on my phone like this (fortunately with enough information for me to tell them apart!)

[1]

@jes I guess you see the equivalent of the top two lines of my image.

As said by @obacht (for each of us) the top line refers to “My account with Murena”, and the second line refers to “Contacts”.

I think that the quote above indicates that there may be an extra level of sync involved sometimes when adding an email address, depending on settings.

Does running the above “Refresh Address book list” act as a fix?

1 Like

Hello obacht
Yes there are two accounts. One is my murena.io for the Cloud and the other is for my Contacts.
The settings in the Contacts-app is not set for phone but for Contacts. Also like yours in MY phone there’s phone and my online-addressbook account which is the Murena.io Address book is default. It is not set for phone. I am not sure what else to check at this point. Perhaps there is a bug.

Thanks obacht

1 Like

aibd
thank you for your input. There are only two accounts for me, one is for murena.io and the other is for Contacts. I do not have a webmail account.

I have followed every item by obacht and yours aibd and still the contact added to the Contacts on my Phone does not add it to the Contacts in the Cloud even when I sync all items suggested. I am thinking perhaps there is a bug.

1 Like

I did try to replicate such a bug “Edit contact on phone; contact is not updated in Contacts in Murena.io and did get a negative result at first but the contact did update correctly after this:

I checked the status of Address book in Account sync and found Sync is ON, but Last sync was 23/09/2023. I switched Sync off and on again – Sync proceeded successfully.

Perhaps try: Settings > Accounts > Murena A/C > Account sync > Address books.

Does the “Address books” line show a recent "Last synced date ?

Edit Of course the above will be dependent on whether
Settings > Accounts > Murena A/C > Automatically sync data is set to ON or OFF.

1 Like

aibd
Finally I found why I could not sync a Contact from my phone to the Cloud’s Contacts. It does not make sense to me but perhaps it is in some documentation which I missed.

Evidently when adding a contact requires a LAST name. Since I was adding my wife I only added her first name which did not migrate to the Contact’s Cloud. Once I edited the Phone contact including her last name and did a manual sync…BINGO.

Prior to this finding I implemented your suggestion above but that did not resolve the issue.

Thanks for your suggestions aibd.

1 Like

interesting finding and good you have that synced now!

I cannot reproduce with my phone-provider (posteo) combo (a contact with only the first name is synced flawlessly) so this might be a murena-specific issue (?)