Congstar App - flackert

Aloha!

Ab und an brauche ich sie doch, die App von Congstar, wenn ich zwischendurch - z.B. im Garten - kurzfristig ein paar Extra-Gigas (HiSpeed-Volumen) benötige.

Leider flackert die App beim Start (Bildschirm ist überwiegend schwarz, die vorgesehene Anzeige blitzt immer nur mal kurz auf, sehr kurz!). In den Griff bekomme ich das meistens durch Aufrufen der App-Liste (Anwendungsverlauf), kurz zu ner weiteren App (z. B. Kontakte) umschalten und dann wieder zurück zur Congstar-App, dann steht das Bild still (so dass man den angezeigten Bildschirm auch gut ablesen kann).
Wir haben vermutlich noch Zeit bis zum nächsten Sommer, dieses Problem zu lösen :wink:

Habe ich die Möglichkeit, durch Einstellungen (bei den Entwickleroptionen ???) die Bildschirmausgabe dieser App zu stabilisieren/optimieren?

Gigaset GS290, /e/ 0.19, zus. 64 GB per SDcard (integriert statt als sep. Datenträger)
Quelle der App: Bei /e/ mitgelieferter App-Store
Das gerade eben auf die Version 3.5.5. durchgeführte Update brachte keine Besserung.

LG

-==[Schubsi]==-

1 Like

Hi Schubsi,

das Erste was mir dazu einfällt: WO ist die App her?
Weil - wenn die auf Google-Dienste zugreift, dann wird’s schwierig.
Wenn möglich - am besten mal beim App-Hersteller nachfragen.

LG
Dietmar

Hallo Dietmar,

ich habe Deinen Rat befolgt und eine e-Mail an das Entwicklerteam gesendet. Falls und welche Antwort als Reaktion kommt, werde ich hier zum Besten geben.

@ all
Es wäre interessant zu wissen, ob ich der einzige Congstar-Kunde i. V. mit dem GS290 bin oder ggf. der einzige, der dieses “Problem” (?) überhaupt hat, um ggf. auszuschließen, dass es sich um einen Defekt meines Gigaset GS290 handelt. Also einfach mal melden, bitte …

Meine erste Vermutung war, dass es sich um eine “Optimierung” (?) bei /e/OS handelt, mit der die App nicht klarkommt. Bei meinem Nokia 6.2 und bestimmt bei ganz vielen anderen Smartphones läuft die App mit Sicherheit unauffällig… Der von @db91595 Dietmar vermutete fehlgeschlagene Zugriff auf (nicht vorhandene) Google-Dienst-Schnittstellen ist aber auch plausibel!

Danke!

LG

-==[Schubsi]==-

Das “Problem” bei eOS (wenn man es so bezeichnen will) ist ja man der Verzicht auf Google.
Zu dem Vorteil des Verzicht bekommt man ja den Nachteil das nicht ALLE App’s darauf laufen.
Der “Standard” ist Google (AOSP) - also entwickeln die Programmierer ihre App für das System.
Alles was neben AOSP entwickelt wird (LOS, eOS …) hat leider z.T. kleine “Probleme” gerade
mit den App’s. Da gibt es keine allgemein gültige Regel.
Somit hilft nur App installieren und schauen ob sie läuft.
Wenn nicht bei dem App-Programmierer fragen ob er helfen kann.
Der kennt sich in seiner App ja am besten aus.

Etwas Zusammenhang: AOSP ist die Basis; eine Custom-ROM wie LOS baut darauf auf; LOS with microG ist ein Fork von LOS; eOS ist ein Fork von LOS with microG.
Wobei der größte Knackpunkt ist “hat der Programmierer der App Goggle-Dienste einprogrammiert?”.

Natürlich kann es hier in diesem speziellen Fall an Problemen mit diesem Phone liegen.
Deshalb ist die Frage nach Erfahrungen anderer User dieser “Phone & OS Kombination” berechtigt.

Ich benutze /e/OS auf einem OnePlus 6 und habe das gleiche Problem in der ja! mobil-App. Bei der App müsste es sich um die Congstar-App mit einem etwas anderen Skin handeln, denn ja! mobil ist ein Reseller von Congstar.

Es scheint also nicht am Gigaset-Gerät zu liegen, sondern an /e/OS.

1 Like

Ich habe ernüchternde Neuigkeiten vom Congstar-Entwicklerteam erfahren:

Ich hab mal Rücksprache gehalten und hab leider keine sehr befriedigende Antwort für dich :
Bei einer Custom-ROM können wir leider nicht garantieren, dass die App richtig funktioniert und haben auch keine Möglichkeit, da etwas zu testen / zu verändern.
Das tut mir super leid :frowning:

Tja, die Fehlerbeschreibung war meiner Meinung nach ausreichend ausführlich.

Wir (Congstar & Congstar-Reseller-Kunden (Ja, Penny, ggf. weitere)) werden also wohl keinen Support erhalten.

Meine oben beschriebene Vorgehensweise (sobald es flackert: Hometaste → Anwendungsverlauf (ich sag immer Taskmanager dazu) → zu einer anderen App wechseln und dann zurück zur Congstar-App) funktioniert bei mir, d.h. ich kann die angezeigten Inhalte lesen und in der App navigieren.

Immerhin …

PS: Wer ne bessere Idee hat (irgendwelche besonderen Einstellungen), der möge bitte sein Stimme erheben :blush: :vulcan_salute:

LG

-==[Schubsi]==-

Was soll congstar auch andres sagen? :wink:

Der “Standard” sind die Betriebssysteme der Smartphone-Hersteller, die auf AOSP basieren und dann mit Google-Zertifizierung die Google-Dienste und Google-Apps mit eingebaut bekommen, die die meisten Nutzer immernoch erwarten (leider). Und dafür werden die meisten Apps entwickelt, zum einen weil diese technische Basis eben der Standard im Android-Lager ist, zum anderen weil die Benutzung der Google-Dienste die App-Entwicklung zum Teil auch vereinfacht.

Genau so ist es.
Würden alle Apps so programmiert, dass sie tatsächlich auf AOSP lauffähig wären, hätte kein darauf basierendes Custom ROM irgendwelche Probleme mit irgendwelchen Apps oder anders herum.

2 Likes

Stehe gerade vor dem selben Problem. Mit Gesture Navigation bleibt tatsächlich nur der Neustart - die App lässt sich nicht mehr schließen oder verlassen.

Mein Vertrag bei Congstar ist noch nicht freigeschaltet, deswegen kann ich meinen Workaround noch nicht abschließend beurteilen. Aber scheinbar bietet die die Kundenumgebung auf der Congstar Webseite exakt die selben Funktionen wie die App, wenn auch nicht ganz so gut strukturiert. Ich habe sie mir nun als Shortcut aufs Desktop gelegt. Das ist meines Wissens nach sowieso besser, als die App herunterzuladen, weil man sich damit keine permanenten Tracker installiert.

Mein Vater nutzt das GS290 mit eOS und daher kann ich euch von den gleichen Problemen berichten, die Congstar App funktioniert nicht wirklich darauf. Ich nutze hier selbst ein Samsung Galaxy S10 und da geht’s so halbwegs, wenn man mal in die Appübersicht und zurück schaltet - so ein gefrickel. Die Website hat ähnliche Funktionen - das ist also dann auch eine Alternative, vielleicht nicht die bequemste, aber so ist das halt.

Das wäre wünschenswert.

Genau dieses Statement habe ich an den Kundenservice von Congstar weiter gegeben…

Reaktion: Keine!

Leider haben Penny und Ja!mobil Kunden keine Möglichkeit mehr, das Web-Portal zu nutzen, das wurde irgendwann letztens abgeschafft und auf die App verwiesen…

LG

-==[Schubsi]==-

Eventuell kommt man um den Neustart herum, wenn man das Smartphone sperrt (also normaler Druck auf den An-/Aus-Schalter), dann das Quick-Settings-Menu öffnet und auf das kleine Zahnrad unten rechts drückt, um die Systemoptionen zu öffnen. Meist folgt die Bitte, das Smartphone zu entsperren. Oft musste ich das mehrmals wiederholen, aber meist hat sich bei mir am Schluss doch das Einstellungsmenü geöffnet. Dort bin ich zu den Apps gewechselt, habe die Congstar-App ausgewählt und das Beenden erzwungen.

Manchmal hat die Congstar-App auch funktioniert, wenn man mehrmals zwischen der App und z.B. einer anderen App oder dem Sperrbildschirm gewechselt hat - das funktioniert aber eigentlich nur mit der klassischen 3-Tasten-Navigation, weil man mit der Gestennavigation und der flackernden App m.E. keinen Appwechsel vornehmen kann.

Die fraenk App läuft auf einem Lineage4mg ohne Probleme.

Da fraenk auch nur congstar ist, kann es gut sein dass die App aus dem gleichen Haus mit den gleichen Quellen und Libs kommt. Nur die Optik verändert wird.

Ich habe jetzt trotzdem die congstar App über den aurora Store installiert.
Aber ich komme über den Initialen Bildschirm in dem ich den Trackingmechanismen der App zustimmen soll, nicht hinaus.
Der Bildschirm reagiert nicht. Friert für ein paar Sekunden ein und dann beendet sich die App. Es kommt zwar kurz ein Fehlerbildschirm. Aber so schnell wieder weg dass man nichts lesen kann.

Also bin ich froh dass meine Frau fraenk benutzt und diese App unter LOS4mg auf einem OP6 läuft.
Die fraenk App hat weniger bis gar keine Tracker. Da musste man am Anfang auch nicht zustimmen.

Congstar kommt ja direkt als erstes auf dem Welcome Screen mit der Meldung dass die App voll Tracker ist und man das bestätigen soll. :frowning:
Ich denke das spielt microG einfach nicht mit.

Also, kurzum, wird das kein /e/OS Thema, sondern ein microG Thema sein. Gegencheck gelungen. Beweis erbracht.

Glück gehabt :wink:

(Wenn einer wechseln will. Ich kann gerne ein Einladungslink versenden :wink: )

Das dürfte jetzt aber am von Dir eingesetzten personalDNSfilter oder an anderen Mechanismen (?) liegen, die Du wie selbstverständlich einsetzt aber bei “Normalos” erstmal so nicht zum Einsatz kommen.

Ich vermute, dass es doch voran gehen würde, wenn Du Deine Schutzschilde runter fahren würdest :wink:

LG

-==[Schubsi]==-

Schubsi, den Gedanken hatte ich bereits.
Auch komplett ohne Schutzschilde keine Chance

Der Threaad ist zwar etwas älter, aber auch ihc habe das Problem mit der Penny-Mobil-App. Früher ging es mal, ich habe aber noch nciht die passende Versionsnummer ruassuchen können, um zu sehen, ob die noch lauffähig ist…

Ich habe vom Support die gleiche Antwort bekommen, mit dem Hinweis auf datapass.de für die Restlaufzeit bzw. das Rest-Datenvolumen und Tarifwechsel über den Kundenservice…

Ich habe nun zuletzt zu Penny-Mobil (6-Monats-Paket) gewechselt, weils meinem Nutzerverhalten 100% entspricht. Auch hier tritt wieder das bekannte Flackern auf, aber auch die Penny-App gibt irgendwann auf: Meine oben beschriebene Vorgehensweise (sobald es flackert: Hometaste → Anwendungsverlauf (ich sag immer Taskmanager dazu) → zu einer anderen App wechseln und dann zurück zur Congstar-App) funktioniert bei mir, zwar nicht gleich immer, aber nach ca. 3-4 Versuchen hat das Flackern ein Ende…

Ich hab die aktuellste App-Version in Betrieb. Ob ältere Versionen besser waren, kann ich nicht sagen, hatte keine “bessere” je in Betrieb.

LG

-==[Schubsi]==-

Aloha!

Inzwischen habe ich das Smartphone gewechsel, konnte auf dem ostasiatischen Markt (HK) ein Nokia 6.1+ ergattern. Weil “LOSmG” aktueller ist (Android 12), habe ich dieses mal kurzerhand installiert.

Zusammenfassend: Android 10, 11 und 12 bereiten bei der Constar-App das “Flackerproblem”. Es ist definitiv nicht gerätespezifisch.

Mit dem neuesten System jetzt in der Hand habe ich folgende Vorgehensweise entwickelt (funktioniert zumindest mit der klassischen 3-Button-Bedienung):
App startet - flackert - rundes Symbol für Homescreen tippen - bis 3 zählen - quadratisches Symbol (Appverlauf?) antippen und dann die Congstar App wählen - Bild steht !

Falls das bei Euch nicht so funktionieren sollte: Früher verwendete ich eine simple App wie “Telefonie” oder “Kontakte” als Zwischenstation, das führte immer zum Erfolg.

Die hier schon vielfach erwähnten Googledienste scheinen das Problem zu sein: Ich mutmaße, dass erfolglose Kontaktaufnahmen mit dem “Mutterschiff” (welches auch immer das sein mag) zum mehrfachen Neustart dieser Routine führen und das optische Flackern nur das Symptom ist und nicht die Ursache (z. B. Initialisierung der Bildschirmausgabe).

So wie es jetzt nutzbar ist, kann ich damit leben…

LG

-==[Schubsi]==-

1 Like