CUSTOM BUILD - Android 10 (Q) eOS GSI

Can you make a EoS twrp flashable zip for the Redmi 4A Rolex Please

There is no eOS TWRP for any device. If you will need a recovery, search the web for it. on XDA or

For flashing a GSI no custom recovery needed

1 Like

How to flash GSI Redmi 4a

Without custom recovery, you have to format / erase userdata via fastboot -w or fastboot erase userdata
tahn you can use this howto [HOWTO] install eOS GSI on a Treble device - new GSI added June 14th


So I’ve checked my Dipper device, which is compatible.

It is currently encrypted, has TWRP and current /e/ os on it. So it’s as easy as flashing from TWRP after wiping the data partition?

You have to FORMAT /data. wipe is not enough, because it is encrypted. Don’t forget to reboot in TWRP after format data. Otherwise you can’t push the file to your device

You can unpack the zx file (be sure you are using the right one (a-only or a/b)). Push the .img on your device and flash it via TWRP

If you are running into a bootloop flash vbmeta as here described [HOWTO] install eOS GSI on a Treble device - new GSI added June 14th

1 Like


A only

I’ll see about getting it done in the next few days.

Seems like a good way forward to push /e/ adoption on more recent devices.

hi @harvey186, thanks for this.
I installed on my S9+ Exynos device and it installs fine, but 2 issues.

  • doesn’t connect to wifi
  • reboots randomly

Any ideas what to try?

The message you are getting is ‘fake’. The wifi connection is working

Reboots? ?? Never have had that issue.

But your device is an exynos. could be that that’s the reason for both issues.

Have you tried any AOSP Q GSI ? Only for testing your issues?

Sorry, in my case it doesn’t ask for the WiFi password, the WiFi toggle just switches back off .
No haven’t tried AOSP yet, since this is my primary phone takes a while to recover after failed attempts :slight_smile: . Maybe will give it shot over the weekend.

This wifi issue I also have when.using the android 10 stock vendor firmware. When using Androud 9 stock firmware it works with the Q GSI. It’s crazy I know.

How does one format using fastboot (no TWRP for Android Q)? Is fastboot -w a “format” or just a “wipe”? (This is for a pixel3a.)

I’ve tried to make this GSI image work on a Pixel3a and so far no luck. The furthest I’ve gotten is to the rainbow peace sign shown at boot and it just sits there for at least 20 minutes. How do I get some debug/log to see what’s wrong?

Here are my steps:

  1. Factory wipe (I forget where I did that, probably the sargo-recovery-eng-4.img or fastbootd)
  2. Install factory Android 10 from ( script)
  3. Boot up, enable developer settings, enable USB debugging (my bootloader is already unlocked, dunno whether this step is necessary)
  4. Restart into bootloader
  5. Flash vbmeta.img and LeOS_Q-20200808-full-treble_arm64_bvN.img (see transcript below)
  6. Reboot: I first see the Google boot screen, then Che dissolving into the rainbow peace sign and it just hangs there

I followed exactly the same steps but flashed the official Android 10 GSI downloaded from (bottom of page under Android 10 GSIs) and that worked without a hitch. So something is wrong with the LeOS image…

Here’s the actual transcript:

> ls
LeOS_Q-20200808-full-treble_arm64_bvN.img  LeOS_Q-20200808-full-treble_arm64_bvN.img.xz  vbmeta.img
> fastboot reboot fastboot
Rebooting into fastboot                            OKAY [  0.026s]
< waiting for any device >
Finished. Total time: 16.180s
> fastboot --disable-verification flash vbmeta vbmeta.img
Rewriting vbmeta struct at offset: 0
Sending 'vbmeta_a' (4 KB)                          OKAY [  0.001s]
Writing 'vbmeta_a'                                 OKAY [  0.004s]
Finished. Total time: 0.079s
> fastboot erase system
Erasing 'system_a'                                 OKAY [  0.285s]
Finished. Total time: 0.287s
> fastboot flash system LeOS_Q-20200808-full-treble_arm64_bvN.img
Resizing 'system_a'                                FAILED (remote: 'Not enough space to resize parti
fastboot: error: Command failed
> fastboot delete-logical-partition product_a
Deleting 'product_a'                               OKAY [  0.059s]
Finished. Total time: 0.059s
> fastboot flash system LeOS_Q-20200808-full-treble_arm64_bvN.img
Resizing 'system_a'                                OKAY [  0.006s]
Sending sparse 'system_a' 1/5 (524284 KB)          OKAY [ 18.301s]
Writing 'system_a'                                 OKAY [  2.700s]
Sending sparse 'system_a' 2/5 (524284 KB)          OKAY [ 18.062s]
Writing 'system_a'                                 OKAY [  2.701s]
Sending sparse 'system_a' 3/5 (524284 KB)          OKAY [ 18.226s]
Writing 'system_a'                                 OKAY [  2.787s]
Sending sparse 'system_a' 4/5 (524284 KB)          OKAY [ 18.190s]
Writing 'system_a'                                 OKAY [  2.780s]
Sending sparse 'system_a' 5/5 (306352 KB)          OKAY [ 10.584s]
Writing 'system_a'                                 OKAY [  1.886s]
Finished. Total time: 96.280s
> fastboot -w
Erasing 'userdata'                                 OKAY [  0.680s]
Erase successful, but not automatically formatting.
File system type raw not supported.
Erasing 'metadata'                                 OKAY [  0.049s]
Erase successful, but not automatically formatting.
File system type raw not supported.
Finished. Total time: 0.738s
> fastboot reboot
Rebooting                                          OKAY [  0.000s]
Finished. Total time: 0.301s

Update: Aha, LeOS_Q-20200805-Mini_arm64_bvN.xz does come up! So what’s wrong with the Full_arm64?

For me wifi always shows “no internet”, which is a PITA. I’m also wondering to what degree it affects routing via wifi vs mobile data. Is there a way to fix that?

It’s a ‘fake’ message, because the capative login is cut off. Wifi will work.
I’m working on removing that message

Why can’t you make the captive portal detection stuff work normally?

because it’s a goolag server. Have changed to and now I’m getting the message that I should log in

by the way, you can hide that message by pushing long on it. The wifi is working that’s what we want :slight_smile:

Given that only the minimal image works for me, how can I install all the default e apps? (Sorry, new to /e/)
In particular, how do I install the /e/ app store?

I only have an a-only device. So I can reproduce your issue. My a-only full version is working fine

Mail = k9
Account manager = DAVx5 from f-droid
Calendar = Etar from f-droid
Maps = MagicEarth from Aurora
Browser = Bromite from f-droid

But for calendar / Contacts / light / Gallery I prefer using Simple Mobil Tools from F-Droid

Aurora store is also available on f-droid

1 Like