CUSTOM BUILD - Android 10 (Q) eOS GSI

This GSI is NOT working on devices which where shipped with Android 10 ‘superpartition’. You only can flash it if you can access your system partition via fastboot !!!

Here is an eOS Q (Android 10) GSI minimal version (without e-default apps)
A ‘full version’ is now also available

My builds are arm64 a-only and arm64 a/b versions

What did I do:
I took the ‘alpha’ sources of eOS, applied several patches of AndyCGYan and PPhusson and removed several goolag calls. And modded a bit here and there.

After a few hours of testing I found no problems on my Xiaomi Redmi Note 6 Pro. There is only one thing:

Wifi issue is solved and I will upload new versions on weekend with the fix

Otherwise, as always: Use at your own risk. Please post problems only here, not in a telegram group. Because this is really a ‘custom’ rom.

Then have fun.

German translation:
Hier ist eine eOS Q (Android 10) GSI minimal version (ohne e-default apps).
Eine ‘Vollversion’ wird in Kürze fertig.

Was habe ich gemacht:
Ich habe die ‘alpha’ Sourcen von eOS genommen, diverse patches von AndyCGYan und PPhusson angewendet und diverse goolag calls entfernt. Und ein bisschen hier und da gemodded.

Nach ein paar Stunden Test habe ich keine Probleme auf meinem Xiaomi Redmi Note 6 Pro gefunden. Nur eine Sache gibt es:
Wenn man sich am WLAN anmeldet, bekommt man den Hinweis, dass man verbunden ist, aber kein Internet hat. Das ist falsch, Internet funktioniert einwandfrei. Diese Meldung kommt durch den cut zum goolag server. Ich weiß noch nicht, wie ich diese Meldung weg bekomme, aber ich arbeite dran :wink:

Ansonsten, wie immer: Nutzung auf eigene Gefahr. Probleme bitte nur hier posten, nicht in einer telegram gruppe. Denn das ist wirklich ein ‘custom’ rom.

Dann viel Spaß.

August,30: New builds added

August, 31: New Mini version uploaded – Wifi issue fixed

September, 3: New FULL version uploaded – Wifi issue fixed

September 17/18: New versions with latest sources.


Thanks a lot, I will continue to look at my futur ‘trebled’ phone :wink:

Do you need to have an Android 10 stock ROM, or will this run on a device running Pie?

I have tested it on a pie device. It was a Redmi Note 6 pro with Miui Android 9

Running stock ROM/ firmware or a Pie /e/ ROM?

Stock Rom. …

1 Like

Maybe because the device looks for Captive Portal Login.
As you wrote one doesn’t need it.
AFAIK you can get rid of it only as root user.

But you can redirect it to another privacy-friendly server / service.
You can find an explanation here, unfortunately only in german: Captive-Portal einstellen [Einsteiger]. But it’s self-explanatory and should work without root access. You need adb.

I have redirected it to same way as in original eOS is done. But could be that I have overseen soemthing

Is there a list anywhere of the default apps you left out of the minimal version?

The screenshot in first post is showing ALL installed apps. All other apps are gone


OK, issue found. I have used but it has to be :frowning:

I would never understand the naming from The app is edrive. Everyone is chatting about edrive. Issues are assigned to edrive, but the domain is ecloud :roll_eyes:

1 Like

I can’t make either of these Q Arm64 A GSIs work. (LeOS_Q-20200805-Mini_arm64_avN and LeOS_Q-20200805-Full_arm64_avN

I’ve tried flashing them on a Stock ROM and on your earlier Pie GSI (e-pie-20200613-JoJo-treble_arm64_aeN.img). I use exactly the same steps as I do to flash the Pie GSI which then runs fine.

The only things I can think of are

  1. The Pie GSI has a .img suffix, the Q ones don’t (I don’t really think this would make a difference - it flashed with no errors)
  2. The Pie GSI is encrypted I think

Time to call it a day I think. Good night!

Have you unpacked the .xz files? ? xz is a compressed format. ; )

Yes I unpacked them. The extracted files were around 2GB and had no suffix

Mhm, ok, will check files.

Don’t know why the don’t boot on your devices, sorry.

Today I will upload a new full.version

No worries. I’ve only tried on one device so far, which has some known problems. The new device arrived yesterday, but I need to spend time testing the functionality of the stock firmware before I start installing /e/

1 Like

Yesterday one user has first flashed AOSP vanilla from phh. After that was working he made a factory reset and flashed eOS Q GSI successfully

Where can I find that?

1 Like

Allso for FairPhone 3?