Device doesn't mount on PC with USB

Hi !
I’m using /e/ with a Xiaomi Redmi note4.
Since few weeks, my device doesn’t mount on PC with USB. It was working well before.
I can charge my device but no more… nothing appear on my screen, I can’t choose MTP when I plug the device. I try to choose MTP in USB setting but it doesn’t work…

Do you have an idea ?

Did you try a different cable?

Yes. And it’s the same cables which were working before.

I have the same issue in Ubuntu and windows… so I guess it come from my device.

If your host machine works with Wind°ws or macOS, update the “Android Xiaomi USB Drivers for Wind°ws and Mac”.

Try a current version of the Android SDK Platform Tools version 30.0.0 (April 2020)

do you have had any eOS update in last time ?

I have the last update of eOS. I can’t say if the issu appeared just after an updating…

If you are using Windows, here’s a generic driver/ adb/ fastboot repair …

  • Disconnect the phone from the computer.
  • In Control Panel - Programs and Features:
    Uninstall everything with “MTP” or “ADB” in its name.
  • Reboot Windows.
  • In Control Panel - Device Manager:
    Enable View - Show hidden devices, and then uninstall every possible ADB, MTP and smartphone device, hidden or not.
  • Reboot Windows.
  • Connect the phone again

Windows should then install working MTP drivers again automatically.
If this doesn’t work, the problem is probably on the phone’s side (*).

If you had adb and/or fastboot before, they might have gotten uninstalled now if they originated from a formerly installed package like “Minimal ADB and Fastboot” or something similar, so (and it’s better to use the following anyway) …

(*) At least if MTP access to the phone worked before. Just as a reference … If there would have been a problem with MTP from the start, it could have been due to a Windows N version. (“N” = without Media Player, result of an old antitrust case)
A Windows N version would need the “Media Feature Pack” before it can do MTP. This should be installable via Settings - Apps - Apps & Features - Optional features (or something like that, German locale here) in current Windows 10 N, for older Windows N versions there were dedicated downloads …


Hello community and especially to you, AnotherElk. Nice to see you also came here from the Fairphone forums.

I have installed /e/ on my Fairphone 3 exactly following the official guide and the pages linked inside it, including installing the adb platform tools as linked there: For the install I’ve used my HP laptop with Windows 10 Pro 64 bit. However, when I connect the phone to it in order to exchange data or something, it only shows the phone in Windows Explorer when I have enabled ADB debugging mode and choose PTP mode (camera mode) in the phone’s USB settings. And that limits me to seeing two folders on the phone (I can work with that, but it’s not convenient).

In all other USB modes at most I get the sound Windows makes when a device is connected, but nothing shows up in Explorer. Letting the “other device” manage the USB connection (whatever that would do) doesn’t work either, since then the phone says “couldn’t switch”. Restarting the laptop and phone hasn’t helped.

Two other PCs have worked, interestingly: A Win 10 Pro PC and a Win 7 laptop. There I have not installed any adb platform tools. And my Fairphone 2 with LineageOS 16 does show up on the Windows 10 Pro laptop that won’t show the FP3.

So do the platform tools interfere with the connection and I should remove them (since I don’t need them anyway now)? But if they interfere a warning in the guide should be in order, no?

The current Android SDK Platform Tools the install guide links to don’t interfere with anything on Windows because you don’t install them. You just unzip them to somewhere and then they just sit there doing nothing, until you perhaps use them.

What I found interfering in the past with MTP were a bunch of driver packages, sometimes including adb and fastboot commands (e.g. the somewhat popular “Minimal ADB and Fastboot” package comes to mind). I installed several of those while testing different things over time, and somewhen MTP stopped to work for me when TWRP was booted … until I got rid of every possible driver trouble with the procedure given above.

In the /e/ guide in the section about adb there’s a link to the LineageOS site ( which says under “Installing adb and fastboot” and “On Windows”: “5. Install the universal adb driver, and reboot.” This ultimately links to I have of course installed it during installation of /e/, since I followed the guide. Should I try to uninstall it?

You are right, I only read until “Download the Windows zip from Google.” and thought all right, this should work, I didn’t expect drivers to come later on :innocent: .
Usually Windows 10 manages to install the necessary drivers automatically once you connect the phone for the first time.

Worth a try.

I uninstalled the driver via “Add or remove programs”, rebootet the laptop and attached the FP3. No change. Still only visible in PTP mode.

I’ll go through your whole guide in post #8 then. That may do the trick, since right now I still see Kedacom USB Device > Google Nexus ADB Interface in my Device Manager. I’ll keep you posted. But we should keep in mind to maybe add a hint in the official install guide after this is solved, I think.

This has worked. I now have access to both internal and SD card storage on the phone from the laptop. Thanks!

For people with the same problem: There were quite a few relevant entries in the Device Manager and some of them hidden, so search well. When I clicked on “uninstall this device”, I also ticked “uninstall driver for this device”.