Directly flashing Magisk with /e/ recovery on complicated device?

Hi guys,

I’m currently using a OnePlus A5000 on Android 12, flashed one or two years ago with /e/OS (currently 1.17-s-20231111351092-dev-cheeseburger*).

Few things to know first :

  • my usb connection seems totally broken (could be hardware), and no computer can now communicate with the phone by cable. As far as I don’t solve this problem, no possible adb sideload for me.
  • my TWRP had been replaced by /e/recovery few month ago, and I didn’t pay too much attention at that time.
  • my phone is not rooted anymore, and I really can’t remind what and how the hell I did that in the first place.

So, here is the matter I would like to ask you about : I actually need to re-root my phone in order to break a licence check for an app I’ve already purchased (SkySafari), using Lucky Patchers (not even sure it could work, but I really want to give it a try and it asked for rooting) :

As I can’t use adb sideload and TWRP to flash Magisk again on my phone, could I directly use /e/ recovery to do so ? And if yes, how can I proceed ?

Sorry for the messy issue, I hope we’ll find a solution out of “redo everything from the start”

Thank you for your help

could be the contacts in the connector. Bit of alcohol and pressured air? also cycle cables

if you’re on a dev build (check the version string) you can enable adb root… you can do adb via wifi, so that should give you the flexibility needed to install some persistent root solution

1 Like

Thank you for your help.

I cleaned them up with a needle few days ago, but I could give a little dissassembling to see if everything is properly plugged inside (note the phone is still charging by cable).

We can adb sideload by wifi ? I didn’t know that, my build number is “e_cheeseburger-user 12 SQ3A.220705.004eng.root.20231111.060949” Is that what you’re talking about ?

that should be the build string, version string see [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc

adb sideload via wifi… I’d guess no, never tried. When the OS is fully booted, via adb root you can alter the filesystem to your liking. I was never a Magisk user, but I’m sure there is a guide out there explaining how to go from a shell with root permissions to what you want

Oh, my bad, I then assume that version string should be: 1.17-s-20231111351092-dev-cheeseburger.
Is that okay ?

Honestly I wanted to use Magisk because I used it before and it worked quite well, but I’m not a stubborn about it. if there is faster and easier way, I’m up to it :slight_smile:

If I understood well, I can use Magisk soft to directly root my phone, as soon as I can extract the boot.img from my /e/ OS. I also find it on that website: 1.17-s-20231111351092-dev-cheeseburger

Do you think I can use that image to root the phone ?