[discontinued] [UNOFFICIAL BUILD] Pi/e/ test ROM for the OnePlus 5T - "dumpling"

EDIT 28th August 2020: discontinued because pie got official. You can dirty flash official over this unofficial ROM in order to switch.

Unoffical/untested Pi/e/ ROM for the OnePlus 5T - “dumpling”. It receives weekly OTAs.

Please note this build has not been tested so fa (build blindly) so please leave comments here with your experience (The OnePlus 5 - “cheeseburger” is working very stable [discontinued] [UNOFFICIAL BUILD] Pi/e/ test ROM for the OnePlus 5 - "cheeseburger").

In case any one wants to test the build you can download it from the link given below.

Before you proceed with the flashing and testing please read the warning given below very carefully

  • Please note this is a test build.
  • Please take a backup of your data before your proceed.
  • In some devices we have noticed that return to Oreo or Nougat builds after flashing the Pi/e/ ROM is not possible
    If you are Ok with these warnings then you can download the Pi/e/ image for the OnePlus 5t - “dumpling” from here: https://eota.digitalkr.am/builds/full/unofficial/cheeseburger/ , use latest file for initial installation

Feedback and comments welcome.

If you end up with error 7 during flashing check out firmware flashing instructions of “cheeseburger” and act accordingly for “dumpling” (do NOT flash cheeseburger firmware just do the same things with necessary replacements):



Thanks for the build and the work done. I have a problem with the manual network search for my phone operator. impossible to change networks when I select the network I want its load has infinity and not possible to change it. do you have a solution ?

nice day

Hello, no. Sadly not. I have not noticed it so far admittedly as I never tried to do it manually because my SIM is anyways only connecting to its home network (unless roaming).

tkt not it is not serious I have one can look at but for the moment there is no solution appart to modify the build but I don’t know r I had found it tell me what you think about the last comment ?

Hi !

I have install your build this morning and to me it works great.
Therefore to install it via Recovery, of course I had to flash Firmware v9.0.11 but I needed to remove the zip “compatibilty” inside the zip of the ROM to be able to move from official Oreo /e/ to your Pi/e/ build.

Is there any place we can give you feedback alongside we use your build ? This thread maybe ?

Thank you for your job !

Hi @Anthonycgnt, you can share your feedback on this same thread.

hello. any news about an OFFICIAL rom for dumpling in Pie??


I don’t have much technical knowledge either but if you want to boot into recovery TWRP, just remove any pin, or any locking method you use. Then when you are done put it back.
Not convenient but it work for me so far.

Hi guys,
I am running twrp 3.2.3-1 but getting:
Zip Treble compatibility error

A quick search showed me that updating twrp should do the trick, but here comes the next problem.
I flashed twrps latest version (3.4.0-0) and upon reboot into recovery I just get a black screen. /e/ still boots normally, just twrp doesnt work
when I flash my old version of twrp it works again, but I can’t upgrade the os.
Did anyone else run into this and what version of twrp are you guys running?


Honestly I never tried upgrading with twrp 3.4. So I always deleted “compatibility.zip” located inside the zip of the rom and flash it with twrp 3.2.3-1 . In that way the error never showed up.
Thanks to this I have been able to upgrade from dev version to this one.

Yesterday night I flashed the new TWRP (3.4) but actually it worked for me just by flashing via adb.
Probably you tried to flash TWRP 3.4 while you were still under dev version of /e/ ?
(It looks like your recovery is not detected)

So i would recommend to :

  • Getting back to TWRP 3.2.3-1
  • Remove Compatibility.zip from zip folder
  • Flash the rom
  • Flash the TWRP 3.4

I can’texplain why it worked for me, so I guess it should work for you

1 Like

thanks, I’ll try that!

Cool so removing the compatibility.zip definitely did something, but getting error 7 now and need to update firmware to proceed.
Going through the updater-script atm to apply the changes @thilo did
In the instructions he mentioned to just remove the system and vendor lines, but i can see a few more changes:

  1. should I get rid of “package_extract_file(“boot.img”, “/dev/block/bootdevice/by-name/boot”);” ?
  2. It also looks like you got rid of the ifelse() statements in the radio update section can I confirm that that’s safe to do?


I am too newbie to know how to extract the firmware … But I found a other way via XDA developer forum.
I use this link : https://sourceforge.net/projects/crdroid/files/dumpling/6.x/firmware/

And I download the firmware required and mentioned on the first post (Firmware v9.0.11 currently).
It will be much easier I guess :slight_smile:

I hope it helped !

Thank you for the build.
I just wanted to report that everything run’s fine after installation using TWRP 3.3.1, firmware 9.0.9 and the latest build 0.10. The ROM is stable although the Apps store is not really functional (many apps page won’t load), but I don’t think it is related to the ROM anyway.