Do not see the eOS update anymore

Hi all

Last week I saw that 1.1 update was available but now I do not see it anymore when I try to update my 1 version. I use the stock eOS Teracube 1 build 1st batch from eOS

Any clue welcome

Teracube 1st batch eOS 1

Did you try to refresh the updater manager?

By refresh you mean the little round arrow upside 8-/? Sure

You could always do a manual update, but while on this idea … would you like to try this, as it is a fix I seem to have to use for troublesome apps.

Settings > Apps and notifications > See all … apps > 3 dot menu, top right > Show system > Updater > Storage > Clear storage | Clear cache

Then restart the phone.

Be aware Clear cache is the gentle option. In the case you want to clear a defect, then Clear storage/data is likely to be required. This will delete settings within the app, so you are likely to need to re-enable “Check daily”.

Unfortunately there is no any “Updater” after showing system… I have “update manager” and I applied what you said reboot its the same

That is strange. Perhaps you feel like adding to this issue.

You might add the full details of build (that is dev or stable).
The best way to share this in Android 10 is

Settings > About phone > Android version > /e/ version > long press to copy to clipboard.

I do not have any account to log in or post there…

e_2e-userdebug 10 QQ3A.200805.001 eng.root.20220526.101310 dev-keys,stable-release

So if this is a purchased phone you could report the issue by email to

Meanwhile you can follow this guide should you wish to participate Report an issue.

Yes Its purchased e/OS Teracube phone via their website…, I will write them but not sure this will help… Thanks for your time/help.

Answer from e/OS support helpdesk :

Thanks for your message.
We encountered a bug with the update and that’s why we removed it.
A developer is checking it, and we hope to have a fix by next week.
Best regards.

I would have liked to know that rather than wasting my time for a week trying to update but it is better late than damper …lol

1 Like

Thanks for posting, I was having the same problem.

I will say in response to your “not sure it will help” feeling about tech support, that I have found support at /e/ to be very responsive, if a bit slow. My interpretation of this is that they are competent and dedicated, but understaffed.

Hi, @janolapino did you ever get resolution of this issue? The response of support implied that it was a problem with the update itself, but I also see that there is a problem with the updater? @Manoj , are these items related? What is the recommended best practice for getting v 1.1 (or 1.2 now?) if we are having either of these problems?

My specific problem is that I have a 2020 version, where the updater still does not show any update beyond v 1.0 (like initially shown in this post). Also, like janolapino, I saw the update 1.1 when it initially was released, but then it disappeared a few days later.

I would second this question. I also have a 2020 T2e and no 1.1 or 1.2 update.

This has been way beyond a week (21 days?) and there is still no new update. I saw on the /e/ announcvement email that v. 1.2 is out. When will we get that? I have a terracube 2e phone purchased from the foundation and need an update. Since v 1.0 came out I cannot get my phone location to work. It thinks I am in taiwan.

I am feeling very abandoned right now, especially given that the 2e is a Murena device. I feel like we should have some sort of priority. This has gone on way too long.

The Teracube 2e update to newer build versions is held up due to this issue.

Well, yes, and there is progress. But it does not seem there is any urgency to fixing it (Priority 2), and there’s no real projection of when it will be fixed. I just figured for a problem with one of a very few hardware products that you sell, there would be more concern.

Update on Gitlab – we may have to do an ADB sideload to update. This would be the same general process that you have been through if you have ever installed a custom version of Android on your phone. Please post instructions and an updated version of the OS so we can get this done.

1 Like

Welcome to the forum @uzi1

You have picked up an older, “Solved” post ! :slight_smile:

As I understand it, the “issues” are marked closed as the fix should have been rolled out in the form of an offer to customers to have the fix sent on an SD card.

I do not have the device, #2e, but here is a significant post from a time since this post got marked solved.

If you look at it, the post just slightly rephrases the text it quotes. It’s exactly the same statement as the quote … adding an unrelated link at the end.
Flagged as spam.

1 Like