Download purchased apps doesn't work

Hi I hope this hasn’t already been answered I did have a look for about 30 minutes on the forum first. I want to install busybox pro on my rooted e/os Galaxy S9 I have purchased the app already quite a while ago. I am signed into the AppLounge with the same google account that I used to purchase the app. But it still has the price on the app and when I click it I get the notification that it will take me to the play page to purchase however when I click confirm the dialogue is dismissed and nothing happens. I have tried clearing the cache and storage and signing in again with the same google account but it doesn’t work. I had the same issue with any other purchased app before rooting so it isn’t something to do with the root. Does anyone know what I am doing wrong? Thanks


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

As you got no reply I thought I would add this link. Many of the issues are worked though here.

Maybe others have written of downloading the paid for app on say a PC then attempt to transfer it to their /e/OS phone, I have no personal experience.

I have no issue downloading paid apps but I use Aurora Store to do so. Although in the past, for testing purposes, I don’t remember having any issue with App Lounge either.

As far as busybox is concerned, you can install busybox via Magisk. More recent. Not sure how well the old stericson app works nowadays.

1 Like

Just the thing!

I was just wondering if, by creating a google account on a 100% google phone and buying the in-ap option I’m interested in, if I use the same google account on my own /e/OS phone, can I get that option back in the app?

It seems not, and I wonder why?

In-App Purchases and license checking requires the real Play Store as it handles those functions.
Sadly there is no way around that.

You do remember I explained all of that in your old thread linked above.

I had the exact same problem. I was not able to update a paid app on Applounge, then uninstalled it and then I was not able to install it again. Aurora store resolved my problem :slight_smile:

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.