/e/ on Samsung Galaxy S6 Edge SM-G925F (zeroltexx)

@enesuzun2002 | Enes Uzun
Samsung Galaxy S6/Edge Developer on https://github.com/enesuzun2002 | on XDA-developers
TWRP 3.3.1-0 Modded for OTA support
G925F/FD/I/S/K/L = zeroltexx
Flash this TWRP incase you want to install updates for LineageOS 16.0 through OTA app.

Tried without success. TWRP 3.3.1-0 Modded for OTA support - it did not work with my device …

  • not even with @enesuzun2002 LOS 16.0 build.
  • not even with LineageOS-for-microG 14.1 zeroltexx.
  • not even with /e/ OS ROM e-0.7-n-

The new OTA of 13.01.2020 is properly downloaded and verified.

However, “Apply Update” isn’t executed. “Press OK” shows no reaction.

So the update has to be installed manually again like in the previous month.

With TWRP “Install” in the directory /data/lineageos_updates the file e-0.7-n-2020011337416-dev-zeroltexx.zip can be installed.



/e/ for zeroltexx * dev (nougat) e-0.8-n-2020041149224-dev-zeroltexx

gitlab.e.foundation → S6 edge zeroltexx reboot when locking

Samsung s6 + /e/ 0.8 du 11/04/2020 : reboots intempestifs

/e/ sur Galaxy S6 : récupérer les contacts enregistrés avec Smart Switch

gitlab e.foundation issues 1164

After booting the phone I unlock it Use it as usual but when trying to unlock it when pressing either home or power button the screen doesn’t turn on and if I keep tapping the power button the device reboots with the notification light stuck on white (all colors on)

13.04.2020 Same bug since the beginning


Relevant screenshots

e-0.7-n-2020021541379-dev-zeroltexx - works

Subject: e-0.9-n-2020051253544-dev-zeroltexx.zip


e-0.9-n-2020051554230-dev-zeroltexx_1 e-0.9-n-2020051554230-dev-zeroltexx_2 e-0.9-n-2020051554230-dev-zeroltexx_3

After installing the /e/ OS ROM, everything seems fine.

However, if the SM-G925F is attached to the host machine via USB 2.0 cable for slow unloading, the phone will reboot constantly. The LED color in the upper left corner changes from green to bright white. A few seconds later, the LED changes back to green. It only takes a few seconds, then the “endless reboot loop” starts again.

Unfortunately, the “endless reboot loop” also works if the phone is just lying there unused without any connection. The glaring white LED lights up premanently, which means it won’t go off at all. Only the phone is switched off completely to end this scenario. Debug messages such as S6 edge zeroltexx reboot when are greeting you …

WPhone¹ based on /e/ OS ROM e-0.7-n-2020021541379-dev-zeroltexx doesn’t know these bugs

wphonearchje wphone2 wphone3 wphone4 wphone5 wphone6
¹WPhone ROM for Samsung Galaxy S6 G925F

Hi there
I am new here and new to custom roms.
I installed e-0.9-n2020051554230-dev-zeroltexx on my galaxy s6 edge SM925i and
got the same problem.
The "rebooting " (it takes about 10 seconds or so) seems to happen after I stopp using the phone. As long as I kept it awake, all seemed to be well.
Have to use LOS for now, but want to come back

Hi Piet, welcome in the forum :slight_smile:

Or you can use the latest “e-0.7-n-” version. That’s the last working version for this device.

The Samsung Galaxy S6 Edge SM-G925F (zeroltexx) is optically such a nice device. Also technically excellent, because it is very fast. But the /e/ OS firmware -n(ougart-7) unfortunately does not do justice to this device.

Since there is no official 8-Oreo or 9-Pie offshoot of LineageOS, we will’ve to wait a very long time for significant improvements. The to-do priorities at /e/ are in other areas.

Custom ROMs based on ASOP 10 with current security leases have been the only everyday alternative for months. I regret this as /e/nthusiastic very much!

1 Like

Hi, @archje

I am curious about that I doesn’t known
¹WPhone ROM for Samsung Galaxy S6 G925F

Is it a way for Nokia phone ?

In my estimation - no.The WPhone ROM only shows what creative people with technical know-how are capable of.

The WPhone ROM for Samsung Galaxy S6 G925F is based on /e/ OS ROM. It got a launcher that imitates the user interface of Wind°ws Phone and some additional features like root with Magisk and several apps.

After the first /e/ OTA-Update the whole spook is gone except for some small things and the /e/ BlissLauncher is back.

On older Nokia devices from HMD Global the bootloader is locked. On newer models this should not be the case anymore. Nokia’s with Android-One-Label could have a chance on custom roms, maybe also via GSI.

I can’t say anything more precise, because I only have one Nokia 3330, which is out of competition, but still works. For nostalogers, the cult mobile phone Nokia 3310 can be found here.

1 Like


does anyone still have a link to the latest 0.7 version?

I installed the 20200413, it does not work either, reboots all the time.

Thank you :slight_smile:

So try to download

1 Like
Sorry, my mistake

Hello @anon26953564,
on my “zeroltexx” the /e/ OS ROM e-0.7-n-2020021541379-dev-zeroltexx works.

Here the about 732 MB ZIP file from my private archive for download


In March 2020 there was no OTA update for the “zeroltexx”, as the following screenshot shows …

e-ROM latest dev build downloads SM-G925F

The last reasonably working version was e-0.7-n-2020021541379-dev-zeroltexx. All versions e-0.8-n were faulty The first two versions of e-0.9-n- aren’t suitable for daily use …

1 Like

@piero, you’re right! I apologize for my mistake.

Before I had this link => https://images.ecloud.global/dev/zeroltexx/e-0.7-n-2020021541379-dev-zeroltexx.zip tried and got an error message

Hy Anaonyme
you guys just made my day!!!
Not just did I get a response to my problem, but got a easy solution as well.
After a week of downloading and trying custom roms ( with varying success) I tried the
link to the e-0.7-n- download and installed e-rom.
This is all I would have dared to dream of. The rom is great and and I am a happy chappy.
There is just one thing, about my phone, even e-rom did not fix.
When I make a call, the other party gets a echo of there spoken words. On my side, the call
quality is great. I tried cleaning mic holes, recording a voice massage on the voice recorder (works just fine), running phone in save mode and tapping on the mic holes to hear that they are ok. The only way I found to get good call quality on the other end is using plug in ear phones ( with mic). At XDA- developers is a post with the suggestion to change the code in the call software. I would probably try that as a last resort, but needed to learn how to navigate the software system first. The thing is that the noise suppression software in Android might cause these echos. This software is a enhancement but, in some cases, causes trouble and one would be better of without it. I found people who wrote that one can turn off noise suppression in the call settings of Android. Unfortunately I can’t find this setting. Can it be that it was there in older versions and not anymore in the newer ones ? Or is it maybe somewhere
else and I’m just not locking in the right places ? Why would this function not be in the newer distributions ?
Any suggestions anybody ?

Hello !

I flashed an unofficial updated (2020.09.26) Oreo build for the Samsung Galaxy S6 Edge, thanks to @itsclarence who kindly updated it.

After a day of testing, here’s are the results. The main good news is that it is not affected by the “Reboot when locking” problem which plagued most builds after e-0.7-n-2020021541379. It is not yet perfect, but is, to me, a progress compared to Nougat.

I flashed the build using ADB. The flashing process completed to 100% on TWRP, but showed a progression at 47% on the computer screen, even though the flashing was completed on TWRP. This did not seem to affect the quality of the flashing.

What works

• The phone boots normally, no bootloop, no restarting when locking it.
• The SIM card is detected and I am prompted to enter its PIN.
• The Bliss launcher works, the main screen has visible icons, no crashes.
Wifi works, I can add/remove wifi connexions.
Bluetooth works. It didn’t work on Nougat, so that’s a big plus for me.
Mobile data works.
Messages : I can send and receive SMS.
/e/ account : I added my username@e.email account successfully.
Weather app is working fine
Browser works too.
/e/ App store works
Music app works

What does not work

Camera : I can take pictures with front and back camera, I can take videos with the front (selfie) camera, however the app crashes when I try to start a video with the back camera.
Phone : I can make and get phone calls. The person I speak to can still hear an echo of their voice, which was already happening on Nougat. I solve this problem by using headphones.
/e/ Notes : Notes do not sync with the username@e.email account. It displays Synchronisation failed, server connection is broken.
/e/ Mail : /e/ I can receive emails, but the app crashes when I try to type the recipient address.
eSpeak : I get a notification that eSpeak has stopped, usually after a camera crash. No idea what it means. Maybe someone more knowledgeable can tell me.


Compared to Nougat, on which it was most of the time impossible to install apps, the /e/ App store runs smoothly.
Some /e/ apps (mail and notes) do not work properly, but it is not a problem to me since I do not use them.
The camera app crashing when using it to capture a video is indeed a problem. It can be solved easily by installing the Open Camera app on F-Droid, which runs smoothly.

Do not hesitate to let me know if I forgot something important. If you want to test it, be sure to make a backup first. The build can be downloaded here : https://ecloud.global/s/627roJggCMLQYDa


Important : During my testing, I forgot to try to encrypt the phone. After attempting it, it results in a bootloop. It can be fixed with a clean flash, the phone is now back to normal.

1 Like

@itsclarence made a new eOS-Q-build for the Samsung Galaxy S6 edge (zeroltexx), which I have tested. Everything works really well, except :

  • the camera app mostly works, but crashes when trying to record video with the back camera, which can be easily fixed by using another camera app, such as for example FreeDCam.
  • There’s still an echo in call, but with @itsclarence advice, I was able to fix it, and now the calls are normal. See linked post for the fix explanation. Feel free to contact me if you need assistance.