/e/ on Samsung Galaxy S6 Edge SM-G925F (zeroltexx)

The installation based on StockROM Android 7.0 was uncomplicated.


Notiz: [UNOFFICIAL BUILD] Samsung Galaxy S6 Edge (zeroltexx)

The December update e-0.7-n-2019121734423-dev-zeroltexx is here.

Text snippet changelog

  • Merge branch ‘v1-nougat-sprint_cordoba’ into ‘v1-nougat’
  • [MicroG] Release e-v0.2.10.19420

“e-v1-nougat” update is foreseeable. Thanks to the /e/OS Build Team!

A well-known error has unfortunately been reported again.
OTA-Update will not be installed automatically.

Source → The state of the LineageOS-based /e/ ROM in December 2019

The Android security patch level is November 5, 2019, according to the settings. As mentioned above, Google dropped support for this ROM and didn’t release any security updates for Android 7 in November 2019. We don’t know why the patch level is November in this case. It should be October 2019. The current patch level is December 2019.

What should the user think of it?

Update by Manoj Nair /e/ support & community leader

/e/OS Update → e-0.7-n-2019122535327-dev-zeroltexx.zip



Note: This feature requires a compatible Recovery or updates will need to be installed manually.

@enesuzun2002 | Enes Uzun
Samsung Galaxy S6/Edge Developer on https://github.com/enesuzun2002 | on XDA-developers
TWRP 3.3.1-0 Modded for OTA support
G925F/FD/I/S/K/L = zeroltexx
Flash this TWRP incase you want to install updates for LineageOS 16.0 through OTA app.

Tried without success. TWRP 3.3.1-0 Modded for OTA support - it did not work with my device …

  • not even with @enesuzun2002 LOS 16.0 build.
  • not even with LineageOS-for-microG 14.1 zeroltexx.
  • not even with /e/ OS ROM e-0.7-n-

The new OTA of 13.01.2020 is properly downloaded and verified.

However, “Apply Update” isn’t executed. “Press OK” shows no reaction.

So the update has to be installed manually again like in the previous month.

With TWRP “Install” in the directory /data/lineageos_updates the file e-0.7-n-2020011337416-dev-zeroltexx.zip can be installed.



/e/ for zeroltexx * dev (nougat) e-0.8-n-2020041149224-dev-zeroltexx

gitlab.e.foundation → S6 edge zeroltexx reboot when locking

Samsung s6 + /e/ 0.8 du 11/04/2020 : reboots intempestifs

/e/ sur Galaxy S6 : récupérer les contacts enregistrés avec Smart Switch

gitlab e.foundation issues 1164

After booting the phone I unlock it Use it as usual but when trying to unlock it when pressing either home or power button the screen doesn’t turn on and if I keep tapping the power button the device reboots with the notification light stuck on white (all colors on)

13.04.2020 Same bug since the beginning


Relevant screenshots

e-0.7-n-2020021541379-dev-zeroltexx - works

Subject: e-0.9-n-2020051253544-dev-zeroltexx.zip


e-0.9-n-2020051554230-dev-zeroltexx_1 e-0.9-n-2020051554230-dev-zeroltexx_2 e-0.9-n-2020051554230-dev-zeroltexx_3

After installing the /e/ OS ROM, everything seems fine.

However, if the SM-G925F is attached to the host machine via USB 2.0 cable for slow unloading, the phone will reboot constantly. The LED color in the upper left corner changes from green to bright white. A few seconds later, the LED changes back to green. It only takes a few seconds, then the “endless reboot loop” starts again.

Unfortunately, the “endless reboot loop” also works if the phone is just lying there unused without any connection. The glaring white LED lights up premanently, which means it won’t go off at all. Only the phone is switched off completely to end this scenario. Debug messages such as S6 edge zeroltexx reboot when are greeting you …

WPhone¹ based on /e/ OS ROM e-0.7-n-2020021541379-dev-zeroltexx doesn’t know these bugs

wphonearchje wphone2 wphone3 wphone4 wphone5 wphone6
¹WPhone ROM for Samsung Galaxy S6 G925F

Hi there
I am new here and new to custom roms.
I installed e-0.9-n2020051554230-dev-zeroltexx on my galaxy s6 edge SM925i and
got the same problem.
The "rebooting " (it takes about 10 seconds or so) seems to happen after I stopp using the phone. As long as I kept it awake, all seemed to be well.
Have to use LOS for now, but want to come back

Hi Piet, welcome in the forum :slight_smile:

Or you can use the latest “e-0.7-n-” version. That’s the last working version for this device.

The Samsung Galaxy S6 Edge SM-G925F (zeroltexx) is optically such a nice device. Also technically excellent, because it is very fast. But the /e/ OS firmware -n(ougart-7) unfortunately does not do justice to this device.

Since there is no official 8-Oreo or 9-Pie offshoot of LineageOS, we will’ve to wait a very long time for significant improvements. The to-do priorities at /e/ are in other areas.

Custom ROMs based on ASOP 10 with current security leases have been the only everyday alternative for months. I regret this as /e/nthusiastic very much!

1 Like

Hi, @archje

I am curious about that I doesn’t known
¹WPhone ROM for Samsung Galaxy S6 G925F

Is it a way for Nokia phone ?

In my estimation - no.The WPhone ROM only shows what creative people with technical know-how are capable of.

The WPhone ROM for Samsung Galaxy S6 G925F is based on /e/ OS ROM. It got a launcher that imitates the user interface of Wind°ws Phone and some additional features like root with Magisk and several apps.

After the first /e/ OTA-Update the whole spook is gone except for some small things and the /e/ BlissLauncher is back.

On older Nokia devices from HMD Global the bootloader is locked. On newer models this should not be the case anymore. Nokia’s with Android-One-Label could have a chance on custom roms, maybe also via GSI.

I can’t say anything more precise, because I only have one Nokia 3330, which is out of competition, but still works. For nostalogers, the cult mobile phone Nokia 3310 can be found here.

1 Like


does anyone still have a link to the latest 0.7 version?

I installed the 20200413, it does not work either, reboots all the time.

Thank you :slight_smile:

So try to download

1 Like
Sorry, my mistake

Hello @anon26953564,
on my “zeroltexx” the /e/ OS ROM e-0.7-n-2020021541379-dev-zeroltexx works.

Here the about 732 MB ZIP file from my private archive for download


In March 2020 there was no OTA update for the “zeroltexx”, as the following screenshot shows …

e-ROM latest dev build downloads SM-G925F

The last reasonably working version was e-0.7-n-2020021541379-dev-zeroltexx. All versions e-0.8-n were faulty The first two versions of e-0.9-n- aren’t suitable for daily use …

1 Like

@piero, you’re right! I apologize for my mistake.

Before I had this link => https://images.ecloud.global/dev/zeroltexx/e-0.7-n-2020021541379-dev-zeroltexx.zip tried and got an error message