/e/OS crashes randomly after a few Minutes. Moto G 5G Plus


I have a Problem after installing /e/OS.

I bought a Moto G 5g Plus and instantly unlocked the bootloader to install /e/OS. I did everything exactly like the guide and everything worked, except that it randomly froze for some seconds and then restarted. Because of that, I tried installing LOS for micro g but ran into the same issue. After that I wanted to install stock firmware with RSD, but it couldn’t set the phone to fast boot, so I tried to do it with the batch file included in the firmware zip just to see that recovery mode and fastboot both now show the no command error. After restarting, somehow /e/OS started (no clue how or why) and that’s the point where I’m stuck.

I can’t reinstall because of the recovery thing, and my OS is unusable because of the crashes. I would guess it’s some background service that’s crashing it, but I’m not an expert. Did someone have this issue in the past and can help me with this?


Did you upgrade the stock moto g to the HIGHEST software version available beforehand? Did you also flash the latest android version of /e/Os (which is mostly likely the S)? Also what is the phone model number?

Just to cross reference a similar report here: Feedback for v1.10 - #70 by shawn10thompson. This may be a case to have devs look at it by https://doc.e.foundation/support-topics/report-an-issue.

Yes, I used s and the model number is XT2075-3.
I didn’t upgrade anything before installing.

I think that would be significant. The devs build /e/ from the latest factory software update available for your device

Is there any way to do this now?

Is this option to use https://androidmtk.com/use-rsd-lite-tool still closed to you ? and are you somewhat familiar with it ? Is fastboot mode still inaccessible ?

This link is not very reassuring; I don’t think you are in the same situation, but I think worth reading as I think it will include useful links. I suggest that you continue to tread lightly.

As @Awilen found Moto devices seem not well documented if the device goes to EDL.

I am adding this as reading material maybe there is a way within /e/OS, idk, might also be worth to Report an issue, mentioned above. I guess this would depend on how confident you were that the device was fully up to date when you acquired it.

Thanks, I am going to take a look at it.

And yes, sadly fastboot just gives me the error message.

Any news on this? I ran into the same issue. I’m pretty sure I had the stock rom/fw up to date, and both Lineage 20 and microG for Lineage 20 installed and worked just fine.

To double-check, device is Moto G 5G Plus / Motorola One 5G nairo https://images.ecloud.global/dev/nairo/. The latest version is e-1.10-s-20230413279105-dev-nairo.zip. This is at Android 12, S.

/e/OS will not succeed to downgrade Android version.

Android OS 10 11 12 13
/e/OS build q r s t
LineageOS 17 18 19 20

Ah ok … so what would the procedure be here? Install Lineage 19, and then try e/OS again ?

You should really look for the manufactures method to down grade.

  • (As down grade is often problematic an alternative would be https://lineage.microg.org/, latest image lineage-20.0-20230412-microG-nairo.zip)

Hmm, but the latest recovery.img and boot.img available from microg lineage are based on 20 as well, even thought they still have the older os roms.

As for manufacturer downgrade, I have no idea … i mean, the didn’t come with Android 13, so I’m not sure what motorola’s downgrade method would be, or where it would lead me …

EDIT: or, wait, are you suggesting to use microG lineage instead of e/OS ? The problem with that is that I successfully installed it, but I need a specific app that I couldn’t get to work there (while it’s been reported to work on e/OS)

What app is that? I don’t know of any apps that won’t run under LineageOS for microG but will run under /e/OS. Any app that runs under /e/OS should run under LineageOS

The banking app for Banco Sabadell, a Spanish bank.

It has limited functionality on microG (signing transfers and other transactions doesn’t work, even though you can check your balance).

In the thread below, someone claims it works without mentioning any limitations:

But no response to your question about whether it works fully

As you said

It would be amazing if it worked any differently under /e/OS than under LineageOS

Yes, it’s unlikely, you’re right … guess I shouldn’t get my hopes to have a de-googled phone without changing banks :sweat_smile:

Environment :
Smartphone : Murena one (bought at Murena) . Software : e/OS/1.10
PC : Ubuntu 23.01 - Firefox for web

As an old professional IT’er I am very prudent to say “it works/it does not work”. So before making a statement i test multiple times. My conclusion : it works fully

Performed tests :

  1. Payment thru the web, which needs a signature from the smartphone. It works.
  2. Payment thru the smartphone. It works.
  3. Signing a purchase theu a VISA card. It works
  4. Inquiry of balance and transactions. It works.

You should DEACTIVATE any VPN (i am using ProtonVPN) during the process, otherwise the app will fail.
I never had any crash from the BS app, so I guess you have an underlying problem.


Ok (even if that derails this thread into OT territory), then there seems to be a case where an app works on e/OS that doesn’t fully work on microG4lineage.

I suppose we’re both talking about the BS App in Spain, right ?

I tried with microG4lineage 20 (!), on the Moto G 5G Plus … the app doesn’t crash, it just asks you to activate device registration on the phone, which fails with the message that “Play Services are not installed …”.

The only thing that works then is inquiry of balance, but I don’t receive the signature prompt notifications.

I’m not using any VPN.

Yes we were talking about Banco Sabadell (BS) Spain.
Sorry I can only talk about e/OS.
Registration is a long while, so I do not remember.